Bug 77860 - FILEOPEN: WPS DOC - Incorrect bullet character shown as character font name not imported
Summary: FILEOPEN: WPS DOC - Incorrect bullet character shown as character font name n...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc
Depends on:
Blocks: DOC-Bullet-Number-Lists
  Show dependency treegraph
 
Reported: 2014-04-24 03:59 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-09-30 02:47 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
bullet characters dont show correctly (35.41 KB, image/jpeg)
2014-04-24 03:59 UTC, Yousuf Philips (jay) (retired)
Details
.doc file create with kingsoft writer (186.50 KB, application/msword)
2014-04-24 04:04 UTC, Yousuf Philips (jay) (retired)
Details
hires version showing bullets (ignore the red hightlights as they are for another bug report) (97.14 KB, image/jpeg)
2014-05-01 04:59 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-04-24 03:59:32 UTC
Created attachment 97857 [details]
bullet characters dont show correctly

I downloaded the .docx file found at < http://download.microsoft.com/documents/rus/microsoft4you/How_to_license_the_operating_system_Windows_8_new.docx > and opened it in Kingsoft Writer 9.1.0.4280 < http://wps-community.org/download.html > and then saved it as a doc file. Then i opened the saved file in LibO and on most pages, bullet list character font opened as Liberation U+FB01 rather than Windings 3 U+F084. Tested in LibO 3.6+.
Comment 1 Yousuf Philips (jay) (retired) 2014-04-24 04:04:15 UTC
Created attachment 97858 [details]
.doc file create with kingsoft writer
Comment 2 Yousuf Philips (jay) (retired) 2014-04-24 04:05:51 UTC
After looking over the uploaded image, i noticed that bold text is also missing in the first few words of each bullet list item.
Comment 3 Jorendc 2014-04-26 14:21:10 UTC
I fail to reproduce the bullet style bug, tested using Windows 8.1 with LibreOffice Version: 4.3.0.0.alpha1+
Build ID: f4a6837025a293312cbc43b9c527851362f11030
TinderBox: Win-x86@47-TDF, Branch:MASTER, Time: 2014-04-26_09:21:18

I can reproduce the bold text issue. If you can't reproduce this bug too, using version 4.3 we can convert this issue to the 'bold text' (also change summary of this bug).

Kind regards,
Joren
Comment 4 Yousuf Philips (jay) (retired) 2014-04-26 15:05:09 UTC
reproduced with 4.3. maybe just a linux issue as liberation serif isnt on windows. :)

While looking at the document in 4.3, i noticed the title header's font shows up as Arial 10pt, rather than being Segoe UI Light 10pt. Same happens in 4.0+.
Comment 5 tommy27 2014-04-30 23:30:06 UTC
low resolution screenshot... however I can see that Kigsoft shows triangular bullet which is not rendered well in LibO 4.2.3.3 under Win7x64 where I see an empty rectangular bullet

status: NEW
Comment 6 tommy27 2014-04-30 23:32:42 UTC
(In reply to comment #4)
> reproduced with 4.3. maybe just a linux issue as liberation serif isnt on
> windows. :)


same wrong bullet display on Version: 4.3.0.0.alpha0+
Build ID: 870ce1188ef7bfb6e57eed2894a20b2ea30b2225
TinderBox: Win-x86@39, Branch:master, Time: 2014-04-22_00:13:36

Liberation serif font is present on my Windows Win7x64 PC.
Comment 7 Yousuf Philips (jay) (retired) 2014-05-01 04:59:56 UTC
Created attachment 98278 [details]
hires version showing bullets (ignore the red hightlights as they are for another bug report)
Comment 8 tommy27 2014-05-01 06:49:56 UTC
thanks Jay, this screenshot is much better.
not a new issue though. I tested with older releases up to 3.4.3 (I don't have previous ones) and bullets are incorrectly displayed there as well. change version field.

same thing for the bold text issue. would you please give me the number of that specific bug report?
Comment 9 Yousuf Philips (jay) (retired) 2014-05-01 07:52:45 UTC
well i've made bug reports for the two other issues i've mentioned in this bug report. bug 78142 is for the incorrect font style and size found in the title table and bug 78143 is for the removal of bold.
Comment 10 A (Andy) 2015-12-27 20:47:50 UTC
Reproducible with LO 5.1.0.1, Win 8.1
Comment 11 Yousuf Philips (jay) (retired) 2017-09-27 22:21:29 UTC
Still confirmed.

Version: 6.0.0.0.alpha0+
Build ID: 892c719fffa06de4c7aeab497326cad7bae9e5c6
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-09-27_03:02:09
Locale: en-US (en_US.UTF-8); Calc: group

Checking the WW8Num13z0 character style and there isnt a font name assigned to it.
Comment 12 QA Administrators 2018-09-30 02:47:40 UTC Comment hidden (spam)