Bug Hunting Session
Bug 77891 - LibO crashes as soon as one enters text in a module
Summary: LibO crashes as soon as one enters text in a module
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha1
Hardware: Other Windows (All)
: high normal
Assignee: Not Assigned
URL: http://connect.microsoft.com/VisualSt...
Whiteboard: BSA target:4.3.0
Keywords: possibleRegression
: 78638 78867 78869 78918 78919 79112 79113 79118 79175 (view as bug list)
Depends on:
Blocks: mab4.3
  Show dependency treegraph
 
Reported: 2014-04-24 12:43 UTC by Fabian Alexander Wilms
Modified: 2015-12-15 22:09 UTC (History)
16 users (show)

See Also:
Crash report or crash signature:


Attachments
active threads of soffice.bin for crash entering text in writer (38.43 KB, image/png)
2014-05-05 13:00 UTC, V Stuart Foote
Details
the fatal Python error on the 4.3.0alpah1 build (2.99 KB, text/plain)
2014-05-19 15:46 UTC, V Stuart Foote
Details
Windbg log TB51 (3.33 KB, text/plain)
2014-05-19 15:57 UTC, V Stuart Foote
Details
Windbg log TB51 20140520 on WinXP (7.12 KB, text/plain)
2014-05-20 14:58 UTC, V Stuart Foote
Details
screencast demonstrating cygwin workaround (1.15 MB, video/webm)
2014-05-23 11:29 UTC, Christian Lohmaier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Alexander Wilms 2014-04-24 12:43:41 UTC
Problem description: 
Starting a module from the start screen or separately results in a crash

Steps to reproduce:
1. Start LibreOffice
---------------------
2. Choose Writer    | 2. Choose Calc      | 2. Choose Impress | 2. Choose Draw
3. Type a character | 3. Type a character |                   |

Current behavior:
It crashes

Expected behavior:
I shouldn't crash
              
Operating System: Windows 7
Version: 4.3.0.0.alpha0+ Master
Last worked in: 4.2.0.4 release
Comment 1 manj_k 2014-04-24 13:39:09 UTC
Reproducible (on Windows 7) with
Version: 4.3.0.0.alpha1 (pre-release)
Build-ID: 46cfcd5a05aa1d13fecd73f5a25b64b8d8dd6781.


Not reproducible with
Version: 4.3.0.0.alpha1+
Build ID: a26d592dab62842b97d25045ce8f88a9c068dc97
TinderBox: Win-x86@39, Branch:master, Time: 2014-04-23_05:19:24.
Comment 2 Fabian Alexander Wilms 2014-04-24 14:01:02 UTC
Build-ID of the version I used: 46cfcd5a05aa1d13fecd73f5a25b64b8d8dd6781
Comment 3 manj_k 2014-04-24 15:08:00 UTC
(In reply to comment #2)
> Build-ID of the version I used: 46cfcd5a05aa1d13fecd73f5a25b64b8d8dd6781

Changed "Version" to "4.3.0.0.alpha1"
(@Fabian Alexander Wilms: Please reset the version if I am wrong).

Additional info to comment #1:
Parallel installation (msiexec /a) with default LibO user profile.
Comment 4 Fabian Alexander Wilms 2014-04-24 16:16:43 UTC
Yes, version 4.3.0.0.alpha1 is correct.

I have Version: 4.2.0.4, Build-ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71 installed, too.
Comment 5 Fabian Alexander Wilms 2014-04-25 15:57:32 UTC
Not reproducible with

Version: 4.3.0.0.alpha1+
Build ID: 808d273db098e2269e53813595a6bfc7b160e28e
TinderBox: Win-x86@39, Branch:master, Time: 2014-04-25_02:09:26
Comment 6 V Stuart Foote 2014-05-05 13:00:29 UTC
Created attachment 98483 [details]
active threads of soffice.bin for crash entering text in writer

Able to get further into a component, and to stat text input. So,
not clear it is exactly the same issue. But on Windows 7 sp1, 64-bit en-US
Version: 4.3.0.0.alpha1
Build ID: 46cfcd5a05aa1d13fecd73f5a25b64b8d8dd6781

Get the following stack trace from a writer session
=-=-=
wow64cpu.dll!TurboDispatchJumpAddressEnd+0x6c0
wow64cpu.dll!TurboDispatchJumpAddressEnd+0xf5
wow64.dll!Wow64SystemServiceEx+0x1ce
wow64.dll!Wow64LdrpInitialize+0x42a
ntdll.dll!RtlUniform+0x6e6
ntdll.dll!RtlCreateTagHeap+0xa7
ntdll.dll!LdrInitializeThunk+0xe
ntdll.dll!NtWaitForMultipleObjects+0x15
kernel32.dll!WaitForMultipleObjectsEx+0x8e
kernel32.dll!WaitForMultipleObjects+0x18
kernel32.dll!GetApplicationRecoveryCallback+0x2a7
kernel32.dll!GetApplicationRecoveryCallback+0x166
kernel32.dll!UnhandledExceptionFilter+0x161
kernel32.dll!UnhandledExceptionFilter+0xe0
MSVCR110.dll!__crtUnhandledException+0x14
MSVCR110.dll!?_invalid_parameter@@YAXPBG00II@Z+0xfd
MSVCR110.dll!abort+0x38
sal3.dll!rtl_cache_free+0x157
sal3.dll!osl_getTimeValueFromDateTime+0x9f90
=-=-=
Comment 7 V Stuart Foote 2014-05-06 03:20:54 UTC
So, TB builds are again functional.  And current builds seem to not continue to have the issues of LibreOfice 4.3.0.0 alpha1 (46cfcd5a05aa1d13fecd73f5a25b64b8d8dd6781)

Also, verified that Cloph's release build based TB-47
Version: 4.3.0.0.alpha1+
Build ID: fa8d10adbf12bef19cfe6dd39d2667944a2fb7d6
TinderBox: Win-x86@47-TDF, Branch:MASTER, Time: 2014-04-29_23:12:26

is working correctly on Windows XP.

Setting Resolved WFM

@Cloph--do you want more complete stack traces for the 4.3.0.0alpha1 build to try to determine what is broken?  Also, the Windows build(s) posted to http://dev-builds.libreoffice.org/pre-releases/win/x86/ should probably be taken down as they are un-usable on both XP and Windows 7.
Comment 8 V Stuart Foote 2014-05-15 07:02:44 UTC
Reopening -- issues on TB51

On Windows 7 sp1, 64-bit
Version: 4.3.0.0.alpha1+
Build ID: 248145f99e95cc30bb6231a8e5ea4e294f147040
TinderBox: Win-x86@51-TDF, Branch:MASTER, Time: 2014-05-14_08:18:01

Following stack trace from text entry in writer, also similar trace with text entry on calc:

=-=-=
wow64cpu.dll!TurboDispatchJumpAddressEnd+0x6c0
wow64cpu.dll!TurboDispatchJumpAddressEnd+0xf5
wow64.dll!Wow64SystemServiceEx+0x1ce
wow64.dll!Wow64LdrpInitialize+0x42a
ntdll.dll!RtlUniform+0x6e6
ntdll.dll!RtlCreateTagHeap+0xa7
ntdll.dll!LdrInitializeThunk+0xe
ntdll.dll!NtWaitForMultipleObjects+0x15
kernel32.dll!WaitForMultipleObjectsEx+0x8e
kernel32.dll!WaitForMultipleObjects+0x18
kernel32.dll!GetApplicationRecoveryCallback+0x2a7
kernel32.dll!GetApplicationRecoveryCallback+0x166
kernel32.dll!UnhandledExceptionFilter+0x161
kernel32.dll!UnhandledExceptionFilter+0xe0
MSVCR110.dll!__crtUnhandledException+0x14
MSVCR110.dll!?_invalid_parameter@@YAXPBG00II@Z+0xfd
MSVCR110.dll!abort+0x38
sal3.dll!rtl_cache_free+0x157
sal3.dll!osl_getTimeValueFromDateTime+0xaef0
=-=-=
Comment 9 V Stuart Foote 2014-05-15 07:18:29 UTC
Also seeing immediate crash attempting to launch any Tools -> Options -> Language settings ( Languages, Writing Aids, or Sentence checking).
Comment 10 Kevin Suo 2014-05-15 10:26:36 UTC
I can reproduce in windows 7 4.3.0.0.alpha1
Build ID: 46cfcd5a05aa1d13fecd73f5a25b64b8d8dd6781

Start Calc, try to type sth, then it crashes. Win7 gives the following error information:

问题签名:
  问题事件名称: APPCRASH
  应用程序名: soffice.bin
  应用程序版本: 4.3.0.0
  应用程序时间戳: 5353f634
  故障模块名称: MSVCR110.dll
  故障模块版本: 11.0.51106.1
  故障模块时间戳: 	5098858e
  异常代码:	40000015
  异常偏移:	000a327c
  OS 版本:	6.1.7601.2.1.0.768.2
  区域设置 ID:	2052
  其他信息 1:	4f5a
  其他信息 2:	4f5a312901515be744dbad472acaa2ad
  其他信息 3:	8f14
  其他信息 4:	8f148c13855d3d3bcd8dab96f2b85caa
Comment 11 V Stuart Foote 2014-05-15 12:55:54 UTC
adjusting title to reflect STR

resetting priority

@suokunlong, *,
the posted Alpha1 (46cfcd5a05aa1d13fecd73f5a25b64b8d8dd6781) from 20 April had this issue. TB builds immediately before and after that build did not, so the issue was closed. Since then Christian (cloph) has put up TB51, which I beleive models the final TDF Windows build environment to be used for 4.3 releases.

The immediate crash on text entry in a module, or if attempting to change  language settings from Tools -> Options could be completely unrelated to the problem with the Alpha1 build, but I suspect not.  So, reopening this issue and adjusting title and priority.

@cloph, any specific testing of TB51 builds you need?
Comment 12 tommy27 2014-05-15 14:06:27 UTC
added to mab4.3 list ( Bug 75025 )
Comment 13 V Stuart Foote 2014-05-15 19:56:59 UTC
So recent builds of TB51 have the crashes on Windows 7 sp1, 64-bit.

Version: 4.3.0.0.alpha1+
Build ID: 248145f99e95cc30bb6231a8e5ea4e294f147040
TinderBox: Win-x86@51-TDF, Branch:MASTER, Time: 2014-05-14_08:18:01

Version: 4.3.0.0.alpha1+
Build ID: a5b93782a18a2ddb6dee4033a578d919b10b6964
TinderBox: Win-x86@51-TDF, Branch:MASTER, Time: 2014-05-13_05:48:30


No problem with recent TB39 builds, either crash on text entry or changing one of the Tools -> Options -> Language Settings panels. But with these builds I don't seem to actually have any spell check functions.

Version: 4.3.0.0.alpha1+
Build ID: 45c89d62b527abec07072074484bd596ab1aa04a
TinderBox: Win-x86@39, Branch:master, Time: 2014-05-15_02:54:28

Version: 4.3.0.0.alpha1+
Build ID: 9d48e8fdf4e1efed5fc82e2ca00f2252debc94da
TinderBox: Win-x86@39, Branch:master, Time: 2014-05-13_13:55:33
Comment 14 V Stuart Foote 2014-05-17 19:11:07 UTC
Continues to crash on TB51 build as noted (entering text, or adjusting Language settings). But for this install noticed that if installing and launching the Helppack Help -> LibreOffice Help menu, or with <F1> key. 

Version: 4.3.0.0.alpha1+
Build ID: f62de9113a4866f7152acbe0e8221c594b7a7b68
TinderBox: Win-x86@51-TDF, Branch:MASTER, Time: 2014-05-17_07:51:54


TB39 build runs, but does not have functional spell check, or show Tools -> Options -> Language settings -- "English sentence checking" that is present on TB51 build.

Version: 4.3.0.0.alpha1+
Build ID: 48eccfb812284f43ba24c3be3903537ce954944d
TinderBox: Win-x86@39, Branch:master, Time: 2014-05-16_00:35:19
Comment 15 V Stuart Foote 2014-05-18 14:25:57 UTC
Checked today's TB42 build for Windows
Version: 4.3.0.0.alpha1+
Build ID: 0d8908b35999795ba1ffe2d3530aa9711918840a
TinderBox: Win-x86@42, Branch:master, Time: 2014-05-17_22:55:54

Inputs text and configures from the Tools -> Options -> Language setting panels with stability, but as with the TB39 builds no functional spell-check.
Comment 16 Maxim Monastirsky 2014-05-19 06:55:21 UTC
*** Bug 78869 has been marked as a duplicate of this bug. ***
Comment 17 Christian Lohmaier 2014-05-19 14:40:49 UTC
Visual Studio changed the returnvalue of a function to get a filedescriptor.

This makes initializing python fail beacuse it tries to setup stdin/stdout/stderr even if those are nonexistant for GUI apps.

To make matters worse, this works when you launch it from a shell like cygwin, since then there are those outputs.
(Thus developers starting LO from the shell won't see that anything is wrong, until they try to launch it from windows explorer (which usually they don't, at least I didn't... and of course tests are also run from a shell so those don't catch this specific problem either)

Anyway, known python/VS bug, fix will be submitted shortly
http://bugs.python.org/issue17797
http://connect.microsoft.com/VisualStudio/feedback/details/785119/
Comment 18 Christian Lohmaier 2014-05-19 14:42:19 UTC
*** Bug 78638 has been marked as a duplicate of this bug. ***
Comment 19 Christian Lohmaier 2014-05-19 14:43:50 UTC
*** Bug 78867 has been marked as a duplicate of this bug. ***
Comment 20 V Stuart Foote 2014-05-19 15:46:24 UTC
Created attachment 99343 [details]
the fatal Python error on the 4.3.0alpah1 build

Went back and checked the 4.3.0alpha1 build from 20 April, looks like that was the same issue as now with the TB51 builds. Matches Miguel Angel's stack trace from bug 78867. I've got to quit using Process Explorer--hind sight 20/20.

Windbg - command win (stack trace attached)

0:000> g
ModLoad: 0c790000 0c963000   C:\LO430alpha1\program\i18npoollo.dll
ModLoad: 0c790000 0c963000   C:\LO430alpha1\program\i18npoollo.dll
ModLoad: 0c790000 0c871000   C:\LO430alpha1\program\lnglo.dll
ModLoad: 5fff0000 60041000   C:\LO430alpha1\program\spelllo.dll
ModLoad: 0c790000 0c871000   C:\LO430alpha1\program\lnglo.dll
ModLoad: 6a040000 6a04d000   C:\LO430alpha1\program\pythonloaderlo.dll
ModLoad: 5ffa0000 5ffe7000   C:\LO430alpha1\program\pyuno.pyd
ModLoad: 1e000000 1e29a000   C:\LO430alpha1\program\python33.dll
Fatal Python error: Py_Initialize: can't initialize sys standard streams
eax=00000000 ebx=00000003 ecx=00000002 edx=00000000 esi=77ee2100 edi=77ee20c0
eip=77dffcc2 esp=0173eba8 ebp=0173ebc4 iopl=0         nv up ei pl zr na pe nc
cs=0023  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00000246
ntdll!ZwTerminateProcess+0x12:
77dffcc2 83c404          add     esp,4
Comment 21 V Stuart Foote 2014-05-19 15:57:08 UTC
Created attachment 99344 [details]
Windbg log TB51

verified the Tools -> Options -> Language Settings dialogs are also throwing the fatal Python error.
Comment 22 Commit Notification 2014-05-19 17:59:23 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e175eb3cedded28909247f4d46f2c17ff2f58be2

fdo#77891 fix python crash when in GUI mode, target WinXP with VS2012



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 23 m.a.riosv 2014-05-19 23:17:50 UTC
*** Bug 78918 has been marked as a duplicate of this bug. ***
Comment 24 Florian Reisinger 2014-05-20 10:41:54 UTC
Hi, works with
Version: 4.3.0.0.alpha1+
Build ID: f3a46244a07b76d633ccc7f83da3fa502612e978
TinderBox: Win-x86@42, Branch:master, Time: 2014-05-20_07:23:58

But not with:
Build ID: f62de9113a4866f7152acbe0e8221c594b7a7b68
TinderBox: Win-x86@51-TDF, Branch:MASTER, Time: 2014-05-17_07:51:54

As there is no recent build of TB51, is this fixed by now?
Comment 25 Christian Lohmaier 2014-05-20 10:50:07 UTC
there's no recent build for the @51 box because the daily build server was down yesterday.

But the @51 bot is about to finish another build and will upload the build - so please check for new build in ~1.5-2 hours.

And no surprise the problem stills shows up in a build from May 17, when the fix was checked in on May 19 :-)

The crashes are fixed, what is still a problem (but a different one) is that it won't recognize java properly (it will treat the JRE as invalid).
Comment 26 Maxim Monastirsky 2014-05-20 11:55:46 UTC
*** Bug 78919 has been marked as a duplicate of this bug. ***
Comment 27 V Stuart Foote 2014-05-20 13:08:29 UTC
Resolved

On Windows 7 sp1, 64-bit with
Version: 4.3.0.0.alpha1+
Build ID: cd11bc699ac50af4f560ed5f2e5e7903de0898b8
TinderBox: Win-x86@51-TDF, Branch:MASTER, Time: 2014-05-20_08:02:54

Text entry is stable, auto spell check is functional. And opening and adjusting Tools -> Options -> Language settings panels also no longer cause issue.
Comment 28 V Stuart Foote 2014-05-20 14:19:30 UTC
Reopening. 

Administrative install of 20140520 TB51 build is NOT stable on WinXP sp3 32-bit (en-US) (VMWare VM on Win7 sp1 64-bit)

Continues to exhibit the same issue on Tools -> Options -> Language Settings panels and while entering text in components.
Comment 29 V Stuart Foote 2014-05-20 14:58:03 UTC
Created attachment 99421 [details]
Windbg log TB51 20140520 on WinXP

Administrative install of LODev 430 20140520 TB51, onto WinXP sp3, 32-bit (VM)
Issues still with Windows XP, Windbg command window and stack trace attached.
Comment 30 Christian Lohmaier 2014-05-20 22:05:17 UTC
Hmm. The trace looks like if the patch wasn't applied.. I'll investigate.
Comment 31 V Stuart Foote 2014-05-21 15:28:04 UTC
@Christian, *,

Will today's commit upgrading to Python 3.3.5 impact the effort to correct this, especially on WinXP?

http://cgit.freedesktop.org/libreoffice/core/commit/?id=005fae2bddf4e43cb361bbdb9fc2cfb961693ffd
Comment 32 Christian Lohmaier 2014-05-21 15:45:26 UTC
no, it will not affect it.

I couldn't reproduce the problem with a fresh build, but with the build the tinderbox uploaded. I'm not sure why the patch wasn't included in the tinderbox build...

Beta1 will run on Windows XP, (but java won't work, so there are some restrictions - but it should not crash, esp. not with the "Py_Initialize: can't initialize sys standard streams" message)

I'll make sure to double-check before uploading the build.
Comment 33 Kevin Suo 2014-05-22 09:59:36 UTC
Just now I installed LibreDev 4.3.0.0.alpha1+, Build ID: cd11bc699ac50af4f560ed5f2e5e7903de0898b8
WinXP SP3

The problem still exists. crash with the following error message:
(translated) soffice.bin - application error: ... unknow software exception (0x40000015), position: 0x0036327c
Comment 34 V Stuart Foote 2014-05-22 10:49:27 UTC
Yes as reported comment 28 and comment 29 with trace. Next "functional" build to test should be the beta1 spin-up.  Look for it in http://dev-builds.libreoffice.org/pre-releases/win/x86/ when posted.
Comment 35 Christian Lohmaier 2014-05-22 22:18:07 UTC
man, this issue is causing me some headache.

So the all-language-build again suffers from the problem.. ARGH. Why does it work in one spin, but then again fails in another??

Anyway, so Beta 1 will *not* work properly on Windows XP (I'll do an additional build if I debugged it more).

As a workaround:
* install cygwin from http://cygwin.com
* start LibreOffice from a cygwin shell. (then also java works)
Comment 36 Kevin Suo 2014-05-23 05:32:28 UTC
(In reply to comment #35)

I installed 4.3 beta 1 and cygwin, started libreoffice from a shell, but still crash when trying to type sth. So this workaround does not work.

Also, how can I disable spellcheck? It crashes when clicking the preference options.
Comment 37 Christian Lohmaier 2014-05-23 11:29:29 UTC
Created attachment 99625 [details]
screencast demonstrating cygwin workaround

As I'm no sure whether it is understood correctly what is meant with start from cygwin shell, here's a screenshot that demonstrates the workaround.

First LO is started in GUI mode, i.e. the one that won't work/crashes. 
After going to the About screen to show that it is the beta1 buils, 
Tools|Macros → Organize Macros → Python macros is called to provoke the crash.
→ you get window's reporting window.

After the crash, a cygwin terminal is opened, and the soffice binary is dragged into the window (to save typing :-)) and started (by pressing enter when the terminal has focus)

Again the about screen is shown, and the Python macros are shown, this time without crash. The table-sample macro is run to demonstrate python runs properly, and that spellchecking then also works.
Comment 38 Kevin Suo 2014-05-23 13:55:13 UTC
(In reply to comment #37)

I installed cygwin by running http://cygwin.com/setup-x86.exe , then installed only the "default" packages (did not choose any other packages),
then I started cygwin terminal and cd to libreoffice 4.3 directory and run soffice/scalc...
Still crash.

I am not going to argue about the workaround, just waiting for the fix. 
For the bug hunting session I am now testing 4.3 beta in Ubuntu 13.10.
Comment 39 Christian Lohmaier 2014-05-23 14:25:55 UTC
this has nothing to do with arguing about a fix.

It doesn't help when it works on my installation of XP (only default cygwin packages installed as well), but not on yours. i.e. when I don't see the problem, I cannot fix it.

So please make sure that before launching from the cygwin terminal, LibreOffice is not already running (maybe you have quickstarter enabled or similar) 

The cygwin terminal must not immediately return with a prompt (the $ at the start of the line), but must be "blocked" for other commands until LibreOffice is quit. If you immediately get the prompt after running LO from cygwin shell, then it was already running.

Starting <lodir>/program/soffice.exe as well as <lodir>/program/scalc.exe or <lodir>/program/swriter.exe or the other modules should work.
Comment 40 Kevin Suo 2014-05-24 13:27:43 UTC
(In reply to comment #39)

Christian you are right, I tested in virtualbox winxp of my home PC, and your cygwin workaround works. 
Maybe something went wrong when I was doing the previous run in my office PC (maybe another bug?).
Comment 41 Commit Notification 2014-05-24 21:53:20 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=788228e4aec06501a0e73193ba85fcdeef7efb69

fdo#77891 unconditionally disable console streams for WinXP



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 42 Commit Notification 2014-05-24 21:55:58 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=53ebf689076ab2283124c8b1cbd891e77d6c928f&h=libreoffice-4-3

fdo#77891 unconditionally disable console streams for WinXP


It will be available in LibreOffice 4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 43 Yousuf Philips (jay) (retired) 2014-05-24 21:58:58 UTC
*** Bug 79118 has been marked as a duplicate of this bug. ***
Comment 44 Yousuf Philips (jay) (retired) 2014-05-24 23:03:21 UTC
*** Bug 79175 has been marked as a duplicate of this bug. ***
Comment 45 V Stuart Foote 2014-05-24 23:46:28 UTC
*** Bug 79112 has been marked as a duplicate of this bug. ***
Comment 46 V Stuart Foote 2014-05-25 01:39:55 UTC
*** Bug 79113 has been marked as a duplicate of this bug. ***
Comment 47 Christian Lohmaier 2014-05-25 10:02:11 UTC
I did a rebuild of the beta for windows with a "mercyless" :-) patch for windows XP. It now additionally checks for windows XP and disables the in/out/err console streams unconditionally (i.e. even when run from cygwin, python won't see the stdout/in).

This means: No crashes on XP, working spellcheck, working python samples, working java-recognition,.. :-)

I already replaced the builds on http://dev-builds.libreoffice.org/pre-releases/win/x86/

→ resolved fixed.
Comment 48 Yousuf Philips (jay) (retired) 2014-05-25 14:47:29 UTC
Tested it on XP SP3 and verifying it against the 4 recent closed bugs and it seems that its all better now. :)
Comment 49 Robinson Tryon (qubit) 2015-12-15 22:09:19 UTC
Migrating Whiteboard tags to Keywords: (PossibleRegression)
[NinjaEdit]