Download it now!
Bug 77981 - FILEOPEN: [regression] RTF unknown objects in margin
Summary: FILEOPEN: [regression] RTF unknown objects in margin
Status: RESOLVED DUPLICATE of bug 76633
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.5.3 release
Hardware: Other All
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks: RTF Shapes
  Show dependency treegraph
 
Reported: 2014-04-26 19:02 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-09-29 12:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-04-26 19:02:03 UTC
I downloaded the .docx file found at < http://download.microsoft.com/documents/customerevidence/Files/710000003670/Xiamen_Tungsten_Group_unifies_enterprise.docx > and opened it in LibO and then saved it as a rtf file. Then i reopened the saved file, and i noticed unknown drawing objects appearing in the left margin of the first page. Confirmed in LibO 4.1 to 4.3. I think this related to my other bug - bug 77597.
Comment 1 Joel Madero 2014-05-05 16:54:22 UTC
Confirmed on Ubuntu 14.04 using bibisect-42all package

Note: This is a read problem not a write problem.


163838afd9b53b179a390d26e7a9efeed3098aef is the first bad commit
commit 163838afd9b53b179a390d26e7a9efeed3098aef
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Thu Oct 17 22:47:20 2013 +0000

    source-hash-ea4fc480c7317b16f4abbafacda3872bb7413357
    
    commit ea4fc480c7317b16f4abbafacda3872bb7413357
    Author:     Eike Rathke <erack@redhat.com>
    AuthorDate: Fri Aug 9 22:59:31 2013 +0200
    Commit:     Eike Rathke <erack@redhat.com>
    CommitDate: Sat Aug 10 00:47:33 2013 +0200
    
        sal_Bool to bool
    
        Change-Id: If15bc8ae32674a7282861663ab4f91a958320a3c

:100644 100644 e45fdabf18736545b41132e1fda4f59911357d37 b7df7e39f81345dc8793d39192360a9d06553e87 M	autogen.log
:100644 100644 091ca23155a839fbaa2814f6e15a25c9e4b75c04 87a602ab68de3bf00b76ac4b4db6d877945620aa M	ccache.log
:100644 100644 6d8eeb764e9a963ffcde4ebcbddb6532e207a7c5 a9caa4f132520e09a54d47d02468f6b06cf91ab0 M	commitmsg
:100644 100644 3505f0453975480e0932e0890a4510706e6223b7 44c5d490a7e0e45f07d32a932f13d157af0033dc M	dev-install.log
:100644 100644 bad862e1b8f299ad71be272b9faa9bd17a304697 6bbe6d95fab814da068afff12f04ce7e01b2478f M	make.log
:040000 040000 179a0cf24fa6880227680470fd25f6145814ceed 16fc9912893b34fda6b494111599ee0ba84f45e0 M	opt



# bad: [793dbf6f80f497dfe587d560d6257f42a24273f6] source-hash-1581b1fc3ac82a7bd62df968226e98604a4ca52d
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# skip: [8092559c5013969ebda017d79200463b9b975038] source-hash-fd84daf696a368c2c7561b5253b32a63ecdeca4a
git bisect skip 8092559c5013969ebda017d79200463b9b975038
# bad: [dc5e6e4db7992231e57537528fb58f2d105e7083] source-hash-764432e36a19f8fd45538f5506f043a624ce2f5c
git bisect bad dc5e6e4db7992231e57537528fb58f2d105e7083
# good: [5648228d3e48de1590346ef4dbbf8633f44a9d04] source-hash-9210b95bcfd65ae558f445666d9b880e794d4c74
git bisect good 5648228d3e48de1590346ef4dbbf8633f44a9d04
# good: [bd951694841e40420fe7938e162ddc5e6b577d1b] source-hash-f2321c529adf6d4a455742c30fb75fbe3f7efe02
git bisect good bd951694841e40420fe7938e162ddc5e6b577d1b
# bad: [78b052f60139585995693e61311ef4fe89d0c191] source-hash-e4f55865078e887a34d7b127b75d01ae374968de
git bisect bad 78b052f60139585995693e61311ef4fe89d0c191
# good: [c5adecadfc6796e067a77c524524dce2fc013294] source-hash-e24dfbb7e7790dd5a3ad2a0a87a074a16973fb0a
git bisect good c5adecadfc6796e067a77c524524dce2fc013294
# skip: [1579781595f985eeb717ec360dc96dd5d85488f3] source-hash-31ab7f0c7d20f1d7be5ce818d0d99b6bd5a8edde
git bisect skip 1579781595f985eeb717ec360dc96dd5d85488f3
# good: [b3a5b0f7682216253089ac8ca31f5dcd0f0d4864] source-hash-ae0493ccfe7c232557fb87eef4d0444709d8b729
git bisect good b3a5b0f7682216253089ac8ca31f5dcd0f0d4864
# bad: [25c68c8968f77f4a99a080bb4fe67f47f83e53d2] source-hash-e4ebe80be51fb33545091aa4f0bbc0ea2fe674f0
git bisect bad 25c68c8968f77f4a99a080bb4fe67f47f83e53d2
# good: [8adb68cd4f1764a2492a0d3ba21c760c3ed4a47f] source-hash-3cf0b5cdb05e1d77610431b1b1328102bf05b602
git bisect good 8adb68cd4f1764a2492a0d3ba21c760c3ed4a47f
# bad: [163838afd9b53b179a390d26e7a9efeed3098aef] source-hash-ea4fc480c7317b16f4abbafacda3872bb7413357
git bisect bad 163838afd9b53b179a390d26e7a9efeed3098aef
# first bad commit: [163838afd9b53b179a390d26e7a9efeed3098aef] source-hash-ea4fc480c7317b16f4abbafacda3872bb7413357
Comment 2 Michael Stahl (CIB) 2014-06-13 19:24:41 UTC

*** This bug has been marked as a duplicate of bug 76633 ***
Comment 3 Robinson Tryon (qubit) 2015-12-15 11:03:35 UTC Comment hidden (obsolete)