Bug 78044 - FORMATTING: "constant value" error bars rounded down in property window
Summary: FORMATTING: "constant value" error bars rounded down in property window
Status: RESOLVED DUPLICATE of bug 77319
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-28 19:22 UTC by bruno.binet
Modified: 2014-05-16 21:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
simple XY chart with error bars (small values) (37.26 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-04-28 19:22 UTC, bruno.binet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bruno.binet 2014-04-28 19:22:46 UTC
Created attachment 98135 [details]
simple XY chart with error bars (small values)

This bug happens in XY charts when error bars are small (say < 1 unit) and constant value category is used. 

When the user edit the actual error bars, the value reported is rounded down to the nearest tenth (not equal to the value initially entered by the user and displayed on the graph).

In the attachment (chart bug,ods), you will see a simple XY chart with both X and Y error bars. The values entered (by me) are ±0,08 (X) and ±0,25 (Y) and you can see that this corresponds to the bars actually displayed. However, if you edit the error bars, you will see 0,00 (X) and 0,20 (Y) in the property window (error bar tab). You can enter new values that will (again) be displayed correctly but rounded when you return to the property window.

This bug may be related to Bug 70313 and Bug 77319.
Comment 1 Jorendc 2014-05-16 21:00:29 UTC
Thanks for your clear bug report!

I can reproduce this behavior, tested using Windows 8.1 with LibreOffice Version: 4.3.0.0.alpha1+ Build ID: 48eccfb812284f43ba24c3be3903537ce954944d
TinderBox: Win-x86@39, Branch:master, Time: 2014-05-16_00:35:19

It looks indeed like a dupe of bug 70313 and bug 77319. Lets mark it as such right now. If bug 77319 is fixed, and this behavior (with your attached document) is still reproducible, feel free to REOPEN afterwards.

Kind regards,
Joren

*** This bug has been marked as a duplicate of bug 77319 ***