Bug 78068 - Calling Format > Paragraph dialog freeze
Summary: Calling Format > Paragraph dialog freeze
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha1
Hardware: All Linux (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0
Keywords:
: 78107 (view as bug list)
Depends on:
Blocks: Paragraph-Dialog
  Show dependency treegraph
 
Reported: 2014-04-29 09:05 UTC by sophie
Modified: 2018-06-11 20:19 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
1 bt at random (6.23 KB, text/plain)
2014-04-30 06:13 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sophie 2014-04-29 09:05:51 UTC
With version Version: 4.3.0.0.alpha1+
Build ID: b6086aa6b6107421e1267ad7a50a74aa05770041
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-04-29_00:32:48 on Ubuntu 14.04. 
My system freeze when trying to open Format > Paragraph. I have to kill all. Format > Page is ok. 
Step to reproduce:
- add some text
- go to Format > Paragraph
- no more action possible
Sophie
Comment 1 sophie 2014-04-29 09:06:19 UTC
changed importance - Sophie
Comment 2 sophie 2014-04-29 09:23:00 UTC
Opening the Stylist and right click on a paragraph style name leads to the same effect. Sophie
Comment 3 Jean-Baptiste Faure 2014-04-29 21:03:26 UTC
No complete freeze for me with my own build, but an empty paragraph dialog and an error message box "std::bad_alloc". Master quit when I click the OK button of the error message box.
Same error message box when I try to modify a paragraph style from the Stylist.

Best regards. JBF
Comment 4 Julien Nabet 2014-04-30 05:57:33 UTC
On pc Debian x86-64 with master sources updated yesterday (1e5b495a882493a81cc82ee34e3339b071bc162d), I can reproduce this bug.
Comment 5 Julien Nabet 2014-04-30 06:13:26 UTC
Created attachment 98209 [details]
1 bt at random
Comment 6 Julien Nabet 2014-04-30 06:19:59 UTC
I noticed that I can get the paragraph dialog normally when there's no text at all.
Comment 7 Julien Nabet 2014-04-30 23:22:07 UTC
Lubos: Noticing this commit, http://cgit.freedesktop.org/libreoffice/core/commit/?id=f1b2261cef7c9996af60f8902e9c0db4bbf896ac, I thought you might be interested in this bugtracker.
I haven't tested yet but I think it should make it since it corresponds exactly to the problematic line from the bt I had attached.
Comment 8 Luboš Luňák 2014-05-01 06:22:39 UTC
Yes, that's the same problem.
Comment 9 Julien Nabet 2014-05-01 15:06:22 UTC
*** Bug 78107 has been marked as a duplicate of this bug. ***
Comment 10 Commit Notification 2018-04-07 09:53:35 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6489bf1eff4ce74b35f7b2f8e8d64dbc56c7eee9

uitest for bug tdf#78068 and tdf#114992

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.