Download it now!
Bug 78107 - [regression] LibO crash when attempting to create or modify style
Summary: [regression] LibO crash when attempting to create or modify style
Status: RESOLVED DUPLICATE of bug 78068
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha1
Hardware: Other All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: Styles-Dialog
  Show dependency treegraph
 
Reported: 2014-04-30 09:36 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-09-29 12:43 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
the crash dialog (82.96 KB, image/png)
2014-04-30 09:36 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-04-30 09:36:48 UTC
Created attachment 98226 [details]
the crash dialog

I opened a blank text document and opened the styles and formatting dialog, then set to 'applied styles' and then right-clicked on 'default style' and whether i choose 'new' or 'modify', the cpu would rev up and then i get at 'std::bad_alloc' error dialog and it would crash.

Version: 4.3.0.0.alpha1+
Build ID: 531f283b3d80b8bffeb1ac39a4656e27511fdaff
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-04-28_22:55:34
Comment 1 Julien Nabet 2014-04-30 13:22:19 UTC
"bad alloc" message reminds me fdo#78068 (cf See Also)
Comment 2 Jorendc 2014-05-01 11:30:27 UTC
Reproducible, tested using Windows 8.1 using LibreOffice Version: 4.3.0.0.alpha1+
Build ID: 0b03f7ed575838f90e6b1ebec3538a3a214f81fb
TinderBox: Win-x86@39, Branch:master, Time: 2014-04-30_01:30:46

No daily builds are currently available which includes the fix of bug 78068. Lets mark this one as NEW for now. If I/someone else can't reproduce this one anymore, we can mark this bug as dupe of bug 78068

Kind regards,
Joren
Comment 3 Julien Nabet 2014-05-01 15:06:22 UTC
On pc Debian x86-64 with master sources updated today (24ec38a96fa33b75435786caaca04f9cef86c289) so after fix for fdo#78068, I don't reproduce the problem.
I put it as dup.

*** This bug has been marked as a duplicate of bug 78068 ***