Download it now!
Bug 78079 - EDITING: Calc crashes on sort by column
Summary: EDITING: Calc crashes on sort by column
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Kohei Yoshida
URL:
Whiteboard: BSA target:4.3.0 target:4.2.5
Keywords: haveBacktrace
: 78233 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-04-29 13:03 UTC by Filip Rembiałkowski
Modified: 2014-05-18 20:17 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document to reproduce the bug (25.18 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-04-29 13:03 UTC, Filip Rembiałkowski
Details
console logs + bt with symbols (8.34 KB, text/plain)
2014-04-29 21:21 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Rembiałkowski 2014-04-29 13:03:14 UTC
Created attachment 98180 [details]
Sample document to reproduce the bug

Problem description: 

Libreoffice crashes on Sort function in Calc.

Steps to reproduce:
1. open attached file
2. in menu, select Data -> Sort
3. Click OK

Current behavior:

crash

Expected behavior:

sort
              


Operating System: Ubuntu
Version: 4.2.3.3 release
Comment 1 Julien Nabet 2014-04-29 20:30:54 UTC
I wonder if it could be a dup of fdo#76607 (ref put in See also)
For the test, could you give a try to a daily build from 4.2 branch (see http://dev-builds.libreoffice.org/daily/libreoffice-4-2/)?
Comment 2 Jean-Baptiste Faure 2014-04-29 20:38:36 UTC
Crash reproducible with LO 4.2.5.0.0+ under Ubuntu 14.04 x86-64.
In the attached file, the sort is defined as a columns sort. And the crash is resulting from that the last column has empty cells. If I remove the cell containing "flag" (D1) or if I complete the column D from D2 to D4 to avoid empty cells, then LO does not crash anymore.

Same behavior with the master (Build ID: 3fef59ce0bc00a05a0577bf8e3a76e322b538099)

Best regards. JBF
Comment 3 Julien Nabet 2014-04-29 21:15:17 UTC
Sorry, my mistake, I can also reproduce this with master sources, I'm gonna attach a bt soon.
Comment 4 Julien Nabet 2014-04-29 21:21:50 UTC
Created attachment 98197 [details]
console logs + bt with symbols
Comment 5 Julien Nabet 2014-04-29 21:23:07 UTC
Kohei/Markus/Eike: one for you?
Comment 6 Commit Notification 2014-05-01 05:19:08 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0e443b773454fa153827753812757d88eea932c5

fdo#78079: Write test for this.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2014-05-01 05:19:20 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3c4fb52d8fc89fe43983991ed2339295b2e0ef8c

fdo#78079: Re-work sort by column to get it to do the right thing.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Kohei Yoshida 2014-05-01 05:27:42 UTC
The crash was not so much because of cells being empty.  It was because of those cells containing formulas.
Comment 9 Kohei Yoshida 2014-05-01 05:37:52 UTC
4.2 backport: https://gerrit.libreoffice.org/9220
Comment 10 Commit Notification 2014-05-01 20:46:12 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5797fd7662d09a9f0f1ee3bf06204b5c4a6397ac&h=libreoffice-4-2

fdo#78079: Re-work sort by column to get it to do the right thing.


It will be available in LibreOffice 4.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Kohei Yoshida 2014-05-01 21:22:45 UTC
Fixed in 4.2.5.
Comment 12 Jean-Baptiste Faure 2014-05-02 05:43:08 UTC
Verified fixed for LibreOffice 4.2.5.0.0+ under Ubuntu 14.04 x86-64.

Thank you very much, Kohei ! :-)

Best regards. JBF
Comment 13 Filip Rembiałkowski 2014-05-02 09:16:04 UTC
Thank you Kohei & All for fast fix :-)
Comment 14 Julien Nabet 2014-05-06 14:30:00 UTC
*** Bug 78233 has been marked as a duplicate of this bug. ***