Bug 78233 - Large sorts cause crash - sometimes
Summary: Large sorts cause crash - sometimes
Status: RESOLVED DUPLICATE of bug 78079
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha1
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-03 22:25 UTC by Tom Cloyd
Modified: 2014-05-06 14:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Cloyd 2014-05-03 22:25:42 UTC
I haven't yet found the pattern precipitating this, but in about 5 hours fairly intense work I've have at least 3 crashes when sorting approximately 50 rows in a sheet that contains several hundred rows. I'm still looking for the pattern, so I can offer a replication dataset.
Comment 1 Julien Nabet 2014-05-04 05:38:49 UTC
What's the build id you use?
Indeed, it could be a dup of fdo#78079 (cf See Also). This fdo has been fixed  with http://cgit.freedesktop.org/libreoffice/core/commit/?id=3c4fb52d8fc89fe43983991ed2339295b2e0ef8c (3 days ago).
Comment 2 Tom Cloyd 2014-05-04 11:12:38 UTC
(In reply to comment #1)
> What's the build id you use?
> Indeed, it could be a dup of fdo#78079 (cf See Also). This fdo has been
> fixed  with
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=3c4fb52d8fc89fe43983991ed2339295b2e0ef8c (3 days ago).

It's 46cfcd5a05aa1d13fecd73f5a25b64b8d8dd6781

Looks like I need to update. Will do.
Comment 3 Tom Cloyd 2014-05-04 11:21:09 UTC
(In reply to comment #1)
> What's the build id you use?
> Indeed, it could be a dup of fdo#78079 (cf See Also). This fdo has been
> fixed  with
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=3c4fb52d8fc89fe43983991ed2339295b2e0ef8c (3 days ago).

It's 46cfcd5a05aa1d13fecd73f5a25b64b8d8dd6781

Looks like I need to update. Will do.

Oh but this problem: I need a deb build. I'll bet that's not what's there. Can you help?
Comment 4 Tom Cloyd 2014-05-04 11:24:36 UTC
(In reply to comment #3)
[...]
> 
> Looks like I need to update. Will do.
> 
> Oh but this problem: I need a deb build. I'll bet that's not what's there.
> Can you help?

Make that a 32bit deb build - I need. I'm downloading the package to see what's in it, but I have NO idea what I'm getting, and it probably won't work.
Comment 5 Julien Nabet 2014-05-04 11:29:24 UTC
daily builds for master sources (future 4.3.0) are here:
http://dev-builds.libreoffice.org/daily/master/
Comment 6 Tom Cloyd 2014-05-04 11:30:26 UTC
(In reply to comment #5)
> daily builds for master sources (future 4.3.0) are here:
> http://dev-builds.libreoffice.org/daily/master/

Sorry for all the noise. I'm very new at this bug reporting business! Thanks for your help.
Comment 7 Tom Cloyd 2014-05-04 22:25:09 UTC
So far, all's well with the new build. It'll take a couple of days for me to cycle through all my usual manipulations of the two large spreadsheets I use fairly constantly, then I'll know much more. But there've been no problems so far! Nice.
Comment 8 Tom Cloyd 2014-05-06 14:18:08 UTC
After two days of intense use of this version, I'm satisfied that the issue reported here is resolved. I've not had a single problem of the nature reported here, nor any of that dreaded "vector::_M_range_check" problem, since installing Version: 4.3.0.0.alpha1+
Build ID: 20778b037c688759a4dc46acb8aeb66c9d1290cc
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-05-04_01:32:58

My thanks to all involved in fixing this issue so quickly!
Comment 9 Julien Nabet 2014-05-06 14:30:00 UTC
Thank you Tom for your feedback. I suppose you were right, probably a dup of fdo#78079.

*** This bug has been marked as a duplicate of bug 78079 ***