Bug 78133 - LibO crashes when in options dialog
Summary: LibO crashes when in options dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha1
Hardware: Other All
: highest blocker
Assignee: Julien Nabet
URL:
Whiteboard: target:4.3.0 target:6.3.0
Keywords: haveBacktrace, regression
: 78196 (view as bug list)
Depends on:
Blocks: Options-Dialog
  Show dependency treegraph
 
Reported: 2014-04-30 19:52 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-11-18 21:54 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
console logs + bt with symbols (13.82 KB, text/plain)
2014-04-30 21:54 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-04-30 19:52:17 UTC
I opened LibO 4.3 alpha and when i was going through the options dialog, if i click on the 'Colors' entry, LibO will crash. Thinking about it just now, i think this must also relate to the color drop down in bug 77934.
Comment 1 Julien Nabet 2014-04-30 21:54:51 UTC
Created attachment 98265 [details]
console logs + bt with symbols

On pc Debian x86-64 with master sources updated today, I can reproduce this crash.
Comment 2 Julien Nabet 2014-04-30 21:56:27 UTC
I put max priority because:
- it's a core function
- no workaround
- crash
- regression
Comment 3 Julien Nabet 2014-04-30 22:51:09 UTC
Patch on master sources for review: https://gerrit.libreoffice.org/#/c/9219/
Comment 4 Caolán McNamara 2014-05-01 08:11:47 UTC
hmm, that pDrDoc has a GetColorList method, maybe we should call that one on the pDrDoc branch and leave the "generic" color list on the other branch
Comment 5 Cor Nouws 2014-05-01 08:13:31 UTC
It does not crash for me in Build ID: 46cfcd5a05aa1d13fecd73f5a25b64b8d8dd6781 on Linux (fresh user profile) - but that may be an older build.
Comment 6 Cor Nouws 2014-05-01 08:27:25 UTC
How the *piep* can Severity and Priority change themselves with me just giving a comment? (Due to FF crashing just before commenting??)
Comment 7 Yousuf Philips (jay) (retired) 2014-05-01 08:33:55 UTC
I found it weird that you changed it and was going to change it back, but didnt want to step on any toes. :)
Comment 8 Julien Nabet 2014-05-01 08:40:59 UTC
Caolán: I've changed https://gerrit.libreoffice.org/#/c/9219/ accordingly to what you said. Would you have some time to validate it?
Comment 9 Commit Notification 2014-05-01 08:53:47 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4558064a31bcecd7cbdfde02b1c309a3b9d9813d

Resolves: fdo#78133 LibO crashes when in options dialog (Colors part)



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Cor Nouws 2014-05-01 11:50:08 UTC
(In reply to comment #7)
> I found it weird that you changed it and was going to change it back, but
> didnt want to step on any toes. :)

It happened me before... No idea which ghost is hunting me ;)

@julien: thanks !
Comment 11 Julien Nabet 2014-05-02 15:56:40 UTC
*** Bug 78196 has been marked as a duplicate of this bug. ***
Comment 12 Commit Notification 2018-11-18 21:50:57 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/ec914194382654aa4b0ad9973acc0eed15a4ab43%5E%21

add uitest for bug tdf#78133

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.