Bug Hunting Session
Bug 77934 - right-click 'Picture...' dialog does not appear
Summary: right-click 'Picture...' dialog does not appear
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha1
Hardware: Other All
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: Image-Dialog mab4.3
  Show dependency treegraph
 
Reported: 2014-04-25 16:33 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-09-27 22:47 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
flickering dialog with only field appearing (60.73 KB, image/jpg)
2014-04-25 16:33 UTC, Yousuf Philips (jay) (retired)
Details
line style has entries but they are invisible, while colors is blank (14.09 KB, image/jpeg)
2014-04-27 15:26 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-04-25 16:33:49 UTC
Created attachment 97967 [details]
flickering dialog with only field appearing

When filing the bug 77910, i opened the mentioned .docx file in 4.3 alpha and when i right-clicked on the image and selected 'Picture...' the dialog wouldnt fully load but would flicker repeatedly. luckily i could press escape and the dialog would disappear. This doesnt happen in 4.2.
Comment 1 Jorendc 2014-04-25 18:35:39 UTC
Nice catch!

Reproducible, tested using Windows 8.1 with LibreOffice Versie: 4.3.0.0.alpha1 
Build ID: 46cfcd5a05aa1d13fecd73f5a25b64b8d8dd6781

Kind regards,
Joren
Comment 2 Julien Nabet 2014-04-26 06:08:33 UTC
On pc Debian x86-64 with master sources updated today, I got no flickering and dialog displays even if I encountered fdo#77913

Jay: on which env are you? (Windows, MacOs, Linux)
Comment 3 Yousuf Philips (jay) (retired) 2014-04-26 11:54:05 UTC
I'm on linux and was using the April 23rd build.
Comment 4 Jorendc 2014-04-27 11:16:09 UTC
Tested using Windows 8.1 using Version: 4.3.0.0.alpha1+
Build ID: 145f2e970f46a3a3e5456b122d71f17c3abe878f
TinderBox: Win-x86@42, Branch:master, Time: 2014-04-26_23:32:36 I can NOT reproduce this anymore.

@Jay: you mind retesting latest version :-)?

New issue: crash when I go to tab 'Macro' in this Picture... dialog. I will create a new bug report for that.

Kind regards,
Joren
Comment 5 Yousuf Philips (jay) (retired) 2014-04-27 15:08:23 UTC
@Joren,

Its working now, but didnt crash at the Macro tab for me on this document. While the image was selected, i click the filter button at the bottom toolbar, and there was no icons for invert and solarization. Also in the 'Borders' tab of the picture dialog, line style drop down has blank entries.

Does LibO provide what ms word classifies as 'picture effect'?
Comment 6 Julien Nabet 2014-04-27 15:10:32 UTC
Jay: about line style dropdown, see https://bugs.freedesktop.org/show_bug.cgi?id=77874
Comment 7 Yousuf Philips (jay) (retired) 2014-04-27 15:14:05 UTC
Julien: i think its slightly different as the entries are in the list but they are not showing. But maybe the 'color' drop down being empty is related to that bug.
Comment 8 Yousuf Philips (jay) (retired) 2014-04-27 15:26:24 UTC
Created attachment 98082 [details]
line style has entries but they are invisible, while colors is blank
Comment 9 Julien Nabet 2014-04-27 15:28:39 UTC
Indeed, it looks like:
"2)
-Open Calc
- Right click on a cell
-- Format cell
-Borders"
from fdo#77874
See https://bugs.freedesktop.org/show_bug.cgi?id=77874#c5
Comment 10 Yousuf Philips (jay) (retired) 2014-04-27 15:42:42 UTC
Julien: yes you are correct about comment 5 related to the line style, but what about the color drop down which is still empty.
Comment 11 Julien Nabet 2014-04-29 19:56:14 UTC
Indeed, there's still a pb with color dropdown badfully
Comment 12 Yousuf Philips (jay) (retired) 2014-05-12 12:29:45 UTC
Well i tried out the last master i downloaded a few days back and all the issues (picture dialog crash, filter button missing icons, line style drop down, color drop down) here seem to have been solved. Will check again with the latest master.
Comment 13 Maxim Monastirsky 2014-05-13 10:24:42 UTC
(In reply to comment #0)
> This doesnt happen in 4.2.
In fact we do have such reports for 4.2, for example: Bug 78212, Bug 74945, Bug 73115, and possible others. In all cases it affects dialogs with tabs, and only when opening from the popup menu, not from the top menu. I wonder if it's not really fixed, just hard to reproduce.
Comment 14 Yousuf Philips (jay) (retired) 2014-05-14 00:48:26 UTC
(In reply to comment #13)
> In fact we do have such reports for 4.2, for example: Bug 78212, Bug 74945,
> Bug 73115, and possible others. In all cases it affects dialogs with tabs,
> and only when opening from the popup menu, not from the top menu. I wonder
> if it's not really fixed, just hard to reproduce.

Well my bug was a flickering dialog, not a dialog that didnt appear drawn completely.

Well i retested the issue on the latest build (12th May) and all seems fine. The only thing i noticed is that moving between tabs is slower and isnt as smooth as in 4.2.5, but this isnt limited to just the picture dialog. It can be easily seen when jumping between tabs like 'Picture' and 'Crop'. I can see it drawing the highlight box around the radio button text caption in the newly selected tab, then paint over the tab, and then draw all the elements in it. It maybe happening this way in 4.2.5, but its so fast that i cant see it happening.