Bug Hunting Session
Bug 78259 - Enhancement request: make -Empty- one of the items for multiple choice in Autofilter
Summary: Enhancement request: make -Empty- one of the items for multiple choice in Aut...
Status: RESOLVED DUPLICATE of bug 65505
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-04 16:05 UTC by Pedro
Modified: 2014-11-12 11:37 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
ODS spreadsheet with 3 Autofiltered columns (29.65 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-05-04 16:09 UTC, Pedro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro 2014-05-04 16:05:04 UTC
Currently (since branch 3.5) you can select multiple items from the Autofilter dialog. However since Empty is a separate choice on the Autofilter menu, it is impossible to filter data based on a criteria such as (col1 = x OR col1 = empty) or a more complex filter such as (col1 = x OR col1 = empty) AND (col2 = y OR col2 = empty)

This could be simply solved by adding the -Empty- option to the multiple selection dialog (as it is possible in Excel 2007 and newer) instead of (or in addition to) one of the menu items.
Comment 1 Pedro 2014-05-04 16:09:55 UTC
Created attachment 98419 [details]
ODS spreadsheet with 3 Autofiltered columns

Please see discussion about this issue in the comments of my answer to
http://ask.libreoffice.org/en/question/26829/autofilter-usage/

The attached file allows to quickly test the case proposed by user jnnewton
Comment 2 Jérôme 2014-07-07 20:28:04 UTC
This duplicate bug describes a solution which would be intuitive for the end user, especially those using Microsoft Excel.

*** This bug has been marked as a duplicate of bug 44895 ***
Comment 3 Kevin Suo 2014-11-10 06:47:23 UTC

*** This bug has been marked as a duplicate of bug 65505 ***