Bug Hunting Session
Bug 44895 - Autofilter does not work with checkbox conddition selection if column cells contain only one value and empty cells
Summary: Autofilter does not work with checkbox conddition selection if column cells c...
Status: VERIFIED DUPLICATE of bug 65505
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-18 03:50 UTC by Nikos
Modified: 2014-11-11 19:03 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments
File showing the bug (8.56 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-01-18 03:50 UTC, Nikos
Details
Simple Sample (7.65 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2013-01-12 20:16 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikos 2012-01-18 03:50:11 UTC
Created attachment 55728 [details]
File showing the bug

Steps to Reproduce
Open the attached file.
It is not possible to select in column E only the entry containing "1". In 3.4.X this is possible.
Comment 1 Nikos 2012-02-13 23:40:47 UTC
Persists in 3.5RC3. A workaround is to use --empty-- and --not empty--. However, I consider this to be highly unintuitive.
Comment 2 sasha.libreoffice 2012-05-08 05:10:27 UTC
Thanks for bugreport
In 3.5.3 is also option "Standard filter...". It is very intuitive to click it.
Comment 3 bfoman (inactive) 2012-07-10 12:36:35 UTC
Confirmed with:
LO 3.5.5.3 
Build ID: own W7 debug build
Windows 7 Professional SP1 64 bit

Selecting cell with "1" not possible.
Workaround using Standard filter works fine.
Comment 4 sasha.libreoffice 2012-07-13 14:41:18 UTC
May be author of this bugreport complains that impossible to enter needed value using keyboard? This problem exist and it is indeed unhandy.
Comment 5 kdom 2012-07-29 10:10:33 UTC
If I may add my opinion, the standard filter workaround is not really satisfying. Indeed, this bug is an issue for me when I make several filters on several columns. It happens one contain only one content. If I want to unfilter some other columns while keeping only this value it is not possible. 
For example, the following thing is not possible in the example attached :
1-Filter on column b : no
2-Filter on column d : 1
3-Unfilter column b

Since the standard filter "removes" the automatic filter, it is not really interesting to use in practice for such cases.
Comment 6 sasha.libreoffice 2012-08-02 05:59:26 UTC
> Since the standard filter "removes" the automatic filter, it is not really
> interesting to use in practice for such cases.
Indeed, it is unhandy. Should be "empty" item in list of items.

Possible workaround: add somewhere on bottom of table line with space in each cell. Cell with space will appear in Autofilter. And it may be used as "empty" item.
Comment 7 Nikos 2012-10-12 06:51:28 UTC
I think a better workaround is using the "Not Empty" filter, since it does not change the data...nonetheless, even after half a year, people in our office keep coming to me, wondering why it does not work...so, I insist "not intuitive"
Comment 8 Rainer Bielefeld Retired 2013-01-12 19:12:28 UTC
Are we talking about normal autofilter or the autofilter with checkboxes? I believe the checkboxes ...

Definitively a Bug.
Not a regression, but bug in a new feature.

Further research results soon!
Comment 9 Rainer Bielefeld Retired 2013-01-12 20:16:34 UTC
Created attachment 72915 [details]
Simple Sample

Steps how to reproduce  with parallel installation of  "LOdev  4.0.0.1 rc   -  GERMAN UI / German Locale  [Build ID: 527dba6f6e0cfbbc71bd6e7b88a52699bb48799)]"  {tinderbox: @6, pull time 2013-01-10(?)} on German WIN7 Home Premium (64bit) with separate /40 User Profile for Master Branch:

1. open attached simple sample
2. Click Autofilter Button in A1
   > Selector appears
3. Make sue that checkbox for "1" is checked
4. <OK>
  Expected: all empty rows hidden
  Actual: nothing, filter does not work
Comment 10 Rainer Bielefeld Retired 2013-01-12 20:19:26 UTC
Easy workaround by using the Standard Filter Item in selector, so not a big problem.

@Spreadsheet Team
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf (and remove others in team from CC).
BTW, who is our current filter expert?
Comment 11 m.a.riosv 2013-09-03 22:38:52 UTC
*** Bug 68872 has been marked as a duplicate of this bug. ***
Comment 12 Jérôme Bouat 2014-07-07 14:33:02 UTC
This bug still occurs on 4.1.6.2 version (x86-64 Windows).
Comment 13 Jérôme 2014-07-07 20:28:04 UTC
*** Bug 78259 has been marked as a duplicate of this bug. ***
Comment 14 Kevin Suo 2014-11-10 06:46:26 UTC
(In reply to Nikos from comment #0)
> It is not possible to select in column E only the entry containing "1"
It is not possible because there is no "Empty" checkbox in the autofilter.

I am marking this bug as a duplicate of bug 65505. This is a feature request, and bug 65505 is "clean", with simple steps to reproduce.

Feel free to set this back to NEW if you don't agree.

Thanks!

*** This bug has been marked as a duplicate of bug 65505 ***
Comment 15 Rob 2014-11-10 16:43:49 UTC
@Kevin:
Generally one dups a newer bug against an older to not disturb original dates, etc. If the description in newer bug is better, just append it tot his bug.
Comment 16 Rob 2014-11-11 19:03:53 UTC
This bug should NOT be dupped against a newer bug. If the bugs are indeed indentical the newer bug should be dup'ed