Bug Hunting Session
Bug 76890 - The autofilter GUI is not intuitive: (a) It does not reflect current state; (b) Cannot be turned off
Summary: The autofilter GUI is not intuitive: (a) It does not reflect current state; (...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.2 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-01 08:53 UTC by narayanaras
Modified: 2016-10-27 02:00 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description narayanaras 2014-04-01 08:53:30 UTC
Take any dataset and apply autofilter to it.
(Using the "Data > Filter > Autofilter" menu).

Now from the pull-down list of any column, select the "Standard filter..." option. Use the "Contains" condition and enter a string that none of the records have. So now all the records will be filtered out.

Again, from the pull-down list of any column, select the "Standard filter..." option. Logically, the GUI should have changed to reflect the filter that we have already applied:
(a) There should be a tick against the  "Standard filter..."  option (toggleable)
(b) The check-boxes against all values should show a "neutral state" (a blue rectangle), rather "selected" (tick) or "unselected" (blank).

But the filter GUI behaves as if there are no filters applied at all!

Consequently, it does not allow you to reset those filters.

There is a work-around, though: toggle the "All" check box TWICE.
Thus effectively, you are bringing it back to "all selected" state.
Although it somehow resets the Standard filter, this is not intuitive.
(Users will not realize that they can reset the Standard Filter in this manner.)
Comment 1 narayanaras 2014-04-01 08:57:52 UTC
Here is the video that demonstrates this:
https://drive.google.com/file/d/0BwlATzWr1zTOMnYwb002a251OTQ/edit?usp=sharing

Please download and inform, so that I can remove it from my drive.
Thanks!
Comment 2 raal 2014-10-29 13:11:37 UTC
Hello,
tested with LO 4.3.2 and bug doesn't occurs. Now when standard filter is used all values are unticked. When select All, then standard filter is deleted. Please test with version 4.3.2. Thank you
Comment 3 Buovjaga 2014-10-30 06:05:40 UTC
Contrary to raal's experience, I get the same behavior as the reporter, so we need more tests.

Win 7 64-bit 4.3.2.2 and Version: 4.4.0.0.alpha1+
Build ID: 4586a3f564600f1a0ce15a5cb98868b43bb9351e
TinderBox: Win-x86@42, Branch:master, Time: 2014-10-29_07:28:16
Comment 4 raal 2014-10-30 08:44:56 UTC
My mistake, when using condition "contains" the bug is here. When using condition "=" then autofilter works as expected.
Comment 5 Rob 2014-11-11 18:52:49 UTC
These bugs are all related (but not neccesarily the same) in that they all complain about the autofilter capability and its behaviour.

bug 44895 	2012-01-18	Dup,65505
bug 46062 	2012-02-14
bug 57431 	2012-11-22
bug 65505  	2013-06-07
bug 68113 	2013-08-14
bug 68406 	2013-08-22
bug 68872 	2013-09-03	Dup,44895
bug 76890 	2014-04-01
bug 78259 	2014-05-04	Dup,44895
bug 81577	2014-07-21
bug 82821 	2014-08-19

If they shoudl be combined, first a summary should be made of all issues, and then the complete description should be added to the oldest bug. If we all agree that this desciption then all the newer bugs mentioned above can be dup'ed against bug 44895.
Comment 6 Simon Dedman 2015-10-02 23:08:33 UTC
Dear Rob, all,

if filtering bugs are being bundled together, please could I add the following:

Unintuitive UI for Standard Filter.
Removing a standard filter is unintuitive. There's the option to remove filter in the data>filter menu, but not directly in the Standard Filter interface. I thought I was going mad until I googled it. How about, at the bottom of that Standard Filter dialog box, before OK and Cancel, "Reset Filters".

Furthermore, it seems unintuitive to me that one removes a filter by changing its state to "none", rendering the rest of that filter's elements as null - I would expect there to be something alongside the filter saying, e.g. "delete filter".

Cheers. Happy to start a new bug with this if required.
Comment 7 Buovjaga 2015-10-03 14:28:55 UTC
(In reply to Simon Dedman from comment #6)
> Cheers. Happy to start a new bug with this if required.

Yeah, there should be a bug for each issue. There can be metabugs that then refer to existing reports, like for right-to-left issues, accessibility..
Comment 8 Rob 2015-10-04 19:31:47 UTC
I have just more or less given up on this issue, given.

In my opinion the whole thing is caused by having 2 means of selecting:

1- In the text: Empty & Not Empty
These selections do not have any mark that either of them is selected

2- The tick boxes 
The tick boxes miss <empty>. <empty> should match any field being empty (null), one or more spaces
To describe as regexp: "$ *#"

The solution to the problems would be:

A- Make the set of tick-boxes complete-
We could discuss if empty is the same as "1 or more spaces" as Excel does it, or that <empty> and <spaces> should be separate tick boxes

B- Take away the text selections completely OR
as a 'service' to the user leave them, but mark the appropriate tick boxes. 

Any selection should untick 'all'


This way the folowing scenarios will be implemented:
-Ticking 'all' would mark all tick boxes and effectively switch off selection
-Ticking 'all' and unticking <empty> would be the same as "Not empty"
-Unticking 'all' and ticking <empty> would be the same as "Empty"

I hope all the issues regarding this are going to be resolved, so that all 10 or so issues which looked up and documented before can be put to rest.
Comment 9 Kevin Suo 2016-10-27 02:00:51 UTC
This issue (a) as mentioned by the bug reporter does not exists anymore in the current libreoffice versions.

The issue (b) is a duplicate of bug 55398.

I mark this bug as RESOLVED WORKSFORME. (and make sure you report different issues in different bug reports in the future)