Bug Hunting Session
Bug 81577 - FILTER: Can't switch a filter of if only one value except NULL
Summary: FILTER: Can't switch a filter of if only one value except NULL
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-20 22:57 UTC by Rob
Modified: 2015-12-21 08:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Testfile (20.96 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-07-21 20:18 UTC, Rob
Details
Screenprint filtering on 'a' (98.14 KB, image/png)
2014-07-21 20:20 UTC, Rob
Details
The screen after filtering on 'a' (91.07 KB, image/png)
2014-07-21 20:20 UTC, Rob
Details
Filtering on 'a' and 'b' (100.27 KB, image/png)
2014-07-21 20:21 UTC, Rob
Details
Inconsistency1 selecting (99.60 KB, image/png)
2014-07-21 20:36 UTC, Rob
Details
Inconsistency1 dataview (80.43 KB, image/png)
2014-07-21 20:37 UTC, Rob
Details
Inc2 prep data (95.12 KB, image/png)
2014-07-21 21:26 UTC, Rob
Details
inc2 filter screen (97.93 KB, image/png)
2014-07-21 21:27 UTC, Rob
Details
inc2 filter data (87.86 KB, image/png)
2014-07-21 21:27 UTC, Rob
Details
inc2 data after delete (86.94 KB, image/png)
2014-07-21 21:28 UTC, Rob
Details
undo selection (100.40 KB, image/png)
2014-07-21 21:29 UTC, Rob
Details
workaround defilter (100.40 KB, image/png)
2014-07-21 21:32 UTC, Rob
Details
Trying to undo filter (100.40 KB, image/png)
2014-07-21 21:33 UTC, Rob
Details
workaround undo filter (93.30 KB, image/png)
2014-07-21 21:34 UTC, Rob
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rob 2014-07-20 22:57:28 UTC
Problem description: 
Can't select 'All' if a filter is on, end the last value filtered on has been deleted while the filter is on. Filter indicator in top cell stays in on position too.

Steps to reproduce:
1. Create spreadsheet with column headers
2. Create autofilter
3. Add value 'a' in one or multiple rows in the empty column
4. Add value 'b' in one or more empty places in the column (be sure to leave some empty columns)

Current behavior:
If I filter on value 'a', by removing the tick on ALL and ticking 'a' I see all rows with 'a' in it. So far soo good. 
If I filter on 'a' and 'b' the ALL tick goes on too, and I see 'a', 'b' and '' [empty].

Expected behavior:
A consistent interface would not couple ALL to only values in the selection if there are empty fields also.

Suggestion:
Add a tickbox for empty fields in the field selection and remove it from the top menu. For ease of use leave the 'not empty' selection, but change that to entering the correct ticks.

This solution makes the user interface consistent and also solves the bug that a selection can't be undone when the selection is on, and the selected values are deleted.


              
Operating System: Mac OS X
Version: 4.2.5.2 release
Comment 1 Joel Madero 2014-07-21 16:48:11 UTC
Hi Rob - 

You mind attaching a simple test case here? I tried following your steps but I don't see the same problem. Perhaps my simple test case is different from yours.

Once you provide a simple test case mark the bug as UNCONFIRMED again. Thanks!
Comment 2 Rob 2014-07-21 20:18:46 UTC
Created attachment 103218 [details]
Testfile
Comment 3 Rob 2014-07-21 20:20:04 UTC
Created attachment 103219 [details]
Screenprint filtering on 'a'
Comment 4 Rob 2014-07-21 20:20:53 UTC
Created attachment 103220 [details]
The screen after filtering on 'a'
Comment 5 Rob 2014-07-21 20:21:48 UTC
Created attachment 103221 [details]
Filtering on 'a' and 'b'
Comment 6 Rob 2014-07-21 20:36:53 UTC
Created attachment 103223 [details]
Inconsistency1 selecting
Comment 7 Rob 2014-07-21 20:37:41 UTC
Created attachment 103224 [details]
Inconsistency1 dataview
Comment 8 Rob 2014-07-21 21:26:45 UTC
Created attachment 103231 [details]
Inc2 prep data
Comment 9 Rob 2014-07-21 21:27:16 UTC
Created attachment 103232 [details]
inc2 filter screen
Comment 10 Rob 2014-07-21 21:27:47 UTC
Created attachment 103233 [details]
inc2 filter data
Comment 11 Rob 2014-07-21 21:28:52 UTC
Created attachment 103234 [details]
inc2 data after delete
Comment 12 Rob 2014-07-21 21:29:29 UTC
Created attachment 103235 [details]
undo selection
Comment 13 Rob 2014-07-21 21:32:36 UTC
Created attachment 103236 [details]
workaround defilter
Comment 14 Rob 2014-07-21 21:33:22 UTC
Created attachment 103237 [details]
Trying to undo filter
Comment 15 Rob 2014-07-21 21:34:03 UTC
Created attachment 103238 [details]
workaround undo filter
Comment 16 Rob 2014-07-21 21:46:41 UTC
Hi Joel,

I added the file, created by executing steps 1 trrough 4 (Testfile –- testfile-after_step_4.ods)

	Files: 	screenprint filtering on 'a'
		screenprint filtered on 'a'
		screenprint filtering on 'a' and 'b'
		
I executed the following steps:

– Filter on value 'a' by ticking box 
Note: 	The 'All' box switches off automatically
	The data view is now as in the file

– Now adding 'b' to filter
Bug:
The 'All' box is automatically ticked. 
This is wrong, since 'a' and 'b' is someting else as 'All'; 
I am not able to untick 'All'.

Inconsistencies in filter select popup:

Scenario 1:
	Files: 	screenprint inconsistency1-selecting 
		screenprint inconsystency1-data
Steps:
Filter on 'Not empty'

Inconsystencies:
A: There is no indicator what the current selection is
B: If I select 'Not empty' it should be the same as 'a' and 'b' (in my case). Why are the boxes not automatically ticked?

Scenario 2:
	Files: 	screenprint inconsistency2-prep-data
		screenprint inconsistency2-filter screen
		screenprint inconsistency2-filter data
		screenprint inconsistency2-filter data after delete
		screenprint inconsistency2-trying to undo filter
Steps:
Delete one of the values in the column (I deleted all occurrences of 'a')
Filter on 'b' by selecting on 'Not empty' 
	Note: Can't do this by ticking 'b' since 'All' is ticked automatically if I tick 'b'!!
Now delete the values
C: There is now no obvious way to undo the selection
	Note: The column is in the top line still marked as 'active selection' and the 'All' box is ticked!


While in scenario one all selections are undone by ticking 'All', this is not true for scenario 2.
The only way I found to unselect is to go through the standard filter and select -none- for the column (File: Screenprint-workaround undo filter)


All of this would be solved by the following changes:
1- Add 'Empty' to the ticklist, and remove it from the text selection
2- Make clear 'not empty' has been selected (a tick after the text will do)
3- Make 'not empty' and 'All' mark appropriate list boxes
4- Mark 'not empty' if all boxes except 'Empty' are marked

In this case 'All' always clears any filter!

Hope this explains,
Rob.
Comment 17 Rob 2014-07-28 22:41:23 UTC
This bug is related to "[Bug 46062] FILTER: Autofilter automatically selects All if only one category and empty cells exist", but it is not the same!

The suggested solution for this bug also solves [Bug 46062] though.
Comment 18 raal 2014-09-13 06:30:38 UTC
Hello Rob,
is this bug duplicate of bug 68406 or bug 57431?
Comment 19 Alex Thurgood 2014-10-15 14:13:35 UTC
Why is this still unconfirmed ?
Comment 20 Alex Thurgood 2014-10-15 14:20:08 UTC
Confirming on OSX 10.9.5

Selecting cells with a value also includes empty cells and sets "All" filter, so empty cells also get displayed
Comment 21 Alex Thurgood 2014-10-15 14:20:56 UTC
Tested with 

version: 4.3.2.2
Build ID: edfb5295ba211bd31ad47d0bad0118690f76407d
Comment 22 Rob 2014-10-15 14:31:20 UTC
@raal:

bug 68406 is related but not the same in that it reports part of the problem. The suggested solution for this problem solved bug 68406 too, though.

Bug 68406 is reporting the same problem, and contains part of the solution because it doesn't refer to the function of all. It does reference the inconsistency in the menu structure. Also here, the problem gets resolved by the suggestion in this bug.
Comment 23 Rob 2014-10-20 12:37:52 UTC
I retested this on Mac OS X Lion 10.7.5 (11G63)
using: LO Version: 4.3.1.2
Build ID: 958349dc3b25111dbca392fbc281a05559ef6848

The reported problem regarding the inconsistency in the menu tickboxes is resolved. The 'Empty tickbox' is available now, and it works as expected.

The problem regarding the menu item 'Not Empty' is not completely resolved. It does work, but there's no indication that its selected. It can be undone by selecting the All tickbox (and that's good).

The only remaining problem is now that there is no indication that the 'Not Empty' menu item has been used. When used, all tickboxes are unmarked, while they should all except the 'Empty' tickbox should be ticked.

The same situation occurs when the 'Empty' menuitem is selected. Only the empty tickbox should be ticked, but it isn't.

In both situations the arrow button starting the pulldown menu is correctly indicating that a selection is in effect.
Comment 24 Rob 2014-10-20 13:15:27 UTC
(In reply to Rob from comment #23)
> I retested this on Mac OS X Lion 10.7.5 (11G63)
> using: LO Version: 4.3.1.2
> Build ID: 958349dc3b25111dbca392fbc281a05559ef6848
> 
> The reported problem regarding the inconsistency in the menu tickboxes is
> resolved. The 'Empty tickbox' is available now, and it works as expected.
> 
> The problem regarding the menu item 'Not Empty' is not completely resolved.
> It does work, but there's no indication that its selected. It can be undone
> by selecting the All tickbox (and that's good).
> 
> The only remaining problem is now that there is no indication that the 'Not
> Empty' menu item has been used. When used, all tickboxes are unmarked, while
> they should all except the 'Empty' tickbox should be ticked.
> 
> The same situation occurs when the 'Empty' menuitem is selected. Only the
> empty tickbox should be ticked, but it isn't.
> 
> In both situations the arrow button starting the pulldown menu is correctly
> indicating that a selection is in effect.

Sorry, it apears I have fields just containing one space. That showed in the list of tickboxes. After deleting the space, the tickbox disapeared also, and my initial euphoria quickly vanished....
Comment 25 QA Administrators 2015-12-20 16:15:28 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.4 or later)
   https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 

4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-12-20
Comment 26 Alex Thurgood 2015-12-21 08:48:29 UTC
Works for me on

Version: 5.2.0.0.alpha0+
Build ID: ce3d3f5543e3e132a3473af27aa2c827336add0f
CPU Threads: 2; OS Version: -; UI Render: default; 
Locale : fr-FR (fr.UTF-8)

with test file provided by bug reporter. Closing as such.