Bug Hunting Session
Bug 82821 - Calc can't filter blanks AND others
Summary: Calc can't filter blanks AND others
Status: RESOLVED DUPLICATE of bug 65505
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-19 16:12 UTC by Simon Dedman
Modified: 2014-11-12 11:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Dedman 2014-08-19 16:12:32 UTC
I'm making a table for wedding invites, columns are "name", "email", and "address".
In the Address column are addresses, blanks, "Not Required" (they're not invited), and "Mum Knows".
I want to filter so I only have the people I need to contact: anyone with addresses (to have them check them), blanks, but NOT "Not Required" or "Mum Knows".
This isn't possible because "Blanks" isn't a clickable field, it's assumed one either wants only blanks or no blanks, which is incorrect.

Please could "Blanks" be added as a list item, as it is in Excel? Don't get me wrong, I like that it's a clickable button also, but this means you lose functionality if that's all you have.

Cheers
Comment 1 Regina Henschel 2014-08-19 22:16:11 UTC
Do not use the AutoFilter but a "Standard Filter". It allows to combine criteria. <>"Not Required" AND <>"Mum Knows" should work for you.
Comment 2 Kevin Suo 2014-11-10 06:33:11 UTC
(In reply to Regina Henschel from comment #1)
Yes the standard filter can do everthing we want, but the bug reporter intends to include the "empty" results together with other "non-empty" values, through "auto-filter".

This is a feature request, and there is already a bug report: Bug 65505 - FILTER: Auto filter checkbox missing for "empty" cells

Please note that MS Excel has this important feature.

*** This bug has been marked as a duplicate of bug 65505 ***