Bug 78281 - Classic theme can't be used in 4.3.x unless renaming to another supported theme name
Summary: Classic theme can't be used in 4.3.x unless renaming to another supported the...
Status: CLOSED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-05 07:13 UTC by ape
Modified: 2015-02-17 14:21 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Classic theme for LibreOffice 4.2\4.3 (2.43 MB, application/zip)
2014-05-05 07:13 UTC, ape
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ape 2014-05-05 07:13:27 UTC
Created attachment 98452 [details]
Classic theme for LibreOffice 4.2\4.3

LibreOfficeDev 4.3.0.0.alpha1+, ID: fa8d10adbf12bef19cfe6dd39d2667944a2fb7d6, TinderBox: Win-x86@47-TDF, Branch: MASTER, Time: 2014-04-29_23:12:26

Classic theme can’t be used by LibreOffice-4.3 now. It is deteriorating of the program.
Changes to the code made after publication the pre-release LibreOfficeDev 4.3.0.0.alpha1. It seems to me that the patch is done because there is no resource images_classic.zip.

I use this theme and upgrade this resource from version to version. Almost all icons of other themes are replaced by classic. My classic theme for LibreOffice 4.2\4.3 is in an attachment.
You can be sure that my classic theme works (LibreOffice 4.2.x or LibreOfficeDev 4.3.0.0.alpha1):
- put ‘images_classic.zip’ in ${ORIGIN}/share/config/..
- open the menu ‘Tools – Options – LibreOffice – View’
- set the parameter ‘Icon size and style’ to the value ‘Classic’

I'm not a programmer, I know English very bad. So I do not know how to work with code.
I propose the community:
- undo the patch and restore the ability to use the Classic theme in the program;
- take my images_classic.zip under LibreOffice’s license.

Thanks, Serg Ossin aka ‘ape’.
Comment 1 tommy27 2014-05-05 07:45:27 UTC
hi, ape.
please take a look at Bug 38175 and try my classic theme version.
it works in 4.2.x (haven't tested it yet in 4.3.x).
Comment 2 ape 2014-05-05 08:05:43 UTC
(In reply to comment #1)
> hi, ape.
> please take a look at Bug 38175 and try my classic theme version.
> it works in 4.2.x (haven't tested it yet in 4.3.x).

Hi, tommy27

No problem with that version of the file 'images_classic.zip' is used.

The problem is that changing the code does not allow to use the classic theme under the native name ‘images_classic.zip’. You must rename the file, for example, in the ‘images_tango.zip’. Classic theme will get it (Tango) name.

ape
Comment 3 tommy27 2014-05-05 08:26:29 UTC
Ok I see. The classic theme is not officially supported by LibO from ages (3.4.x era I think).

the old workaround was still possible but they removed that chance now in 4.3.x codeline.

I already know their decision was WONTFIX so you have to use the "rename to Tango" workaround.
Comment 4 Adolfo Jayme 2014-05-05 11:03:09 UTC

*** This bug has been marked as a duplicate of bug 38175 ***
Comment 5 tommy27 2014-05-05 11:26:55 UTC
sorr Adolfo,
I prefer to keep those 2 bugs separated since they are not exactly the same.

Bug 38175 was about shipping again classic theme in LibO, which was dropped in 3.4.x (probably is better to label that one as WONTFIX) 

theme was not shipped but you could use it if you manually entered the corresponding zip file in the proper folder

Bug 78281 is about the removal of the code in 4.3.x that allowed that workaround use of classic theme (another workaround exists and is to rename the theme)

bottomline is that the 2 decisions about Classic theme won't be reverted.
users who still like that theme (and I am one of theme) have an easy workaround to do it.
Comment 6 ape 2014-05-07 03:33:49 UTC
It's my mistake. I installed the daily build as the alpha’s update.
I didn't see that the configuration folder is cleared when updating program.
Therefore - closed.