Bug Hunting Session
Bug 38175 - Make Classic icon theme available again
Summary: Make Classic icon theme available again
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: All All
: medium enhancement
Assignee: tommy27
URL:
Whiteboard:
Keywords:
: 43797 (view as bug list)
Depends on:
Blocks: Icon-Themes
  Show dependency treegraph
 
Reported: 2011-06-10 22:00 UTC by tommy27
Modified: 2017-07-31 21:03 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
proposed update icons in quickstarted window (24.21 KB, image/png)
2011-06-18 16:18 UTC, Ed
Details
Classic Theme for LibO 3.4.4 (1.94 MB, application/zip)
2011-11-18 04:24 UTC, tommy27
Details
Classic Theme for LibO 3.5.0 (1.89 MB, application/zip)
2012-02-12 05:09 UTC, tommy27
Details
Classic Theme for LibO 3.6.x (1.86 MB, application/zip)
2012-09-19 05:41 UTC, tommy27
Details
Classic Theme for LibO 4.0.x (1.90 MB, application/zip)
2013-05-20 04:45 UTC, tommy27
Details
Classic Theme for LibO 4.1.x (2.47 MB, application/zip)
2014-01-30 02:27 UTC, tommy27
Details
Classic Theme for LibO 4.2.x (2.47 MB, application/zip)
2014-05-05 07:49 UTC, tommy27
Details
Classic Theme for LibO 4.3.x (2.42 MB, application/zip)
2015-01-24 11:44 UTC, ape
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tommy27 2011-06-10 22:00:37 UTC
I'm really disappointed you removed the Classic GUI theme from LibO 3.4.

now only Tango, Crystal, Oxygen and Hi-Contrast are available

please bring back the Classic theme in LibO 3.4.1

I agree that there were many redundant icons and repetition that needed to be cleaned up

however I totally disagree removing a whole theme like Classic that many users like me liked so much.
Comment 1 tommy27 2011-06-11 10:11:57 UTC
@LibO devs

I'm just curious to know if Classic GUI theme was removed intentionally or not?
Comment 2 tommy27 2011-06-11 10:26:45 UTC Comment hidden (obsolete)
Comment 3 tommy27 2011-06-15 20:20:04 UTC
there's a workaround!!!  

just copy the images_classic.zip from LibO 3.3.2 ( ....\Bin\LibreOffice 3\Basis\share\config ) and paste it into LibO 3.4

then go to Tools / Option / View / Size and Style of Icons (I'm translating in english the menu items from the italian version) and select the newly added Classic theme will be again available.
Comment 4 Ilya Chernykh 2011-06-16 07:27:00 UTC
I agree, I hate all those themes: Tango, Crystal, Oxygen and Hi-Contrast but I use Galaxy. Was it also removed?

Anyway I think there should be a classic theme choice for those who do not like bloat.
Comment 5 Don't use this account, use tml@iki.fi 2011-06-16 07:51:16 UTC
Ilya: Great idea, adding it (back) (if it really was removed; I have no idea) will surely reduce bloat. The more we add, the smaller it gets!
Comment 6 tommy27 2011-06-16 12:43:57 UTC
(In reply to comment #5)
...........................
Tor Lillqvist  said:
adding it (back) (if it really was removed; I have no idea)
will surely reduce bloat. The more we add, the smaller it gets!
...........................

As I asked before, it would be interesting to know it the removal of the Classic theme was done intentionally or unintentionally (maybe the developers just forgot to pack it)... because I can confirm that that theme is not present in LibO 3.4.0

IMHO the removal of that theme cannot be justified with space saving issues...
the zip cointaining all the classic icons is just 2.83 MB in LibO 3.3.2 which is by far smaller than other themes (Crystal, Oxygen and Tango are betwenn 3.5 and 4.8 MB)... so it had no sense to sacrifice the smaller one...
Comment 7 Rainer Bielefeld Retired 2011-06-17 00:26:05 UTC
[Reproducible] with "LibreOffice 3.4.0  – WIN7  Home Premium  (64bit) German UI [OOO340m1 (Build:12)]", "Classic" Theme is missing.

@tommy27:
Please contribute information concerning your OS!
Comment 8 tommy27 2011-06-17 01:28:45 UTC
I tried a portable version of LibreOffice 3.4 (X-LibreOffice:  http://www.winpenpack.com/main/download.php?view.1301 ) which is buildt on the official LibO release.

I tested it on Windows Vista 64bit and Windows XP 32bit and the Classic theme is missing.

copying the .zip file from the LibO 3.3.2 folder into LibO 3.4 as described before, fixes the issue.

I guess that the Classic theme was just forgotten during the clean up of icon redundancies that has taken place in this release.

hope you will reintroduce the missing icon theme in LibO 3.4.1
Comment 9 Michael Meeks 2011-06-17 01:46:40 UTC
The classic theme is very dated, and also incomplete in places, no artist I know of wants to work on maintaining or improving it. Please note that we still ship Galaxy - which OO.o has had as its default for some years now.

So yes, it was deliberately removed to save download space. I'm sorry if that removes your favorite theme :-)

I -suspect- that if you drop the .zip file into the right place on your system from 3.3.x you'll find that you can still use that theme in 3.4.x.

If someone is interested in doing the hacking, we can improve the theming mechanism to make it properly generic, so anyone can make and install a custom theme easily - is that something you'd want to hack on ?
Comment 10 tommy27 2011-06-17 02:20:36 UTC
(In reply to comment #9)
> The classic theme is very dated, and also incomplete in places, no artist I
> know of wants to work on maintaining or improving it. Please note that we still
> ship Galaxy - which OO.o has had as its default for some years now.
> 
> So yes, it was deliberately removed to save download space. I'm sorry if that
> removes your favorite theme :-)
> 
> I -suspect- that if you drop the .zip file into the right place on your system
> from 3.3.x you'll find that you can still use that theme in 3.4.x.
> 
> If someone is interested in doing the hacking, we can improve the theming
> mechanism to make it properly generic, so anyone can make and install a custom
> theme easily - is that something you'd want to hack on ?


Ok I see. As I said in comment 3, dropping the zip file from LibO 3.3.2 in 3.4.0 reintroduces the missing theme.

I have no enough technical skills to create a theming mechanism.

the only contribution I can offer is to clean the 3.3.2 Classic theme from redundant icons (all the hi-contrast that were removed from other themes) and borrow missing icons from current LibO 3.4 themes.

doing this a Classic "LibO 3.4 compliant" zip file will be created with reduced filesize.

once I'm ready I can attach that file here, and you will decide if putting it back to next releases of LibO 3.4.x, hopefully 3.4.1

remember that though dated, the Classic theme has still many fans,
removing it may create disconfort among those users

read here: http://user.services.openoffice.org/en/forum/viewtopic.php?f=101&t=41669
Comment 11 Rainer Bielefeld Retired 2011-06-17 02:47:13 UTC
@tommy27:
May be you can find some volunteers to assist you to create an extension with the Classic Theme?
Comment 12 tommy27 2011-06-17 02:53:13 UTC
(In reply to comment #11)
> @tommy27:
> May be you can find some volunteers to assist you to create an extension with
> the Classic Theme?


well, I do not know how to code an extension, however one should just pack the classic theme .zip file and create a macro to simply copy it inside  ....\Bin\LibreOffice 3\Basis\share\config
Comment 13 Ed 2011-06-17 03:25:03 UTC
@Michael Meeks 

Please remember that what is "dated" is entirely subjective.  Just because many users' favourite theme doesn't happen to match your personal taste doesn't justify forcing your personal opinion on the entire user base.
Comment 14 tommy27 2011-06-17 04:07:46 UTC
gimme a couple of days and I will prepare a "3.4 compliant" Classic theme to be reintroduced in LibO 3.4.1

remember how much discomfort was created by OOo monochromatic icons (and was one of the reasons I migrated to LibO)

don't piss off users with themes.
Comment 15 Rainer Bielefeld Retired 2011-06-17 04:54:54 UTC
(In reply to comment #14)
> don't piss off users with themes.

It's not a matter of ignorance. We can't distribute "code" without a maintainer, and as Michael stated, there was no manpower available (for example to add missing icons). So it would be great if you could take that task.

If your addition will be rejected, I recommend <http://wiki.documentfoundation.org/Extensions-website>
If you are interested to help to test the new extension Website I can tell you access data (until some tests will have been passed the Extensions Website will not be public).
Comment 16 Ed 2011-06-17 05:13:23 UTC
Which icons are missing from this theme?

This theme has been successfully used in OOo since version 2, in StarOffice for some time before that, and in previous versions of LO, without any report of it being unusable due to missing icons.
Comment 17 Rainer Bielefeld Retired 2011-06-17 06:06:17 UTC
Reassigning due to facts.
Comment 18 tommy27 2011-06-17 07:09:15 UTC
(In reply to comment #17)
> Reassigning due to facts.

Ok guys. I'll do the work. 

Classic theme rulez!!!
Comment 19 Ed 2011-06-17 10:16:48 UTC
I'm in the process of stripping out the redundant icons in the Classic theme file, will upload as attachment when done.
Comment 20 Ed 2011-06-17 12:47:15 UTC
I've reworked the Classic theme to work with LibreOffice 3.4.  As the file is too big to save as an attachment, I have uploaded it to http://www.sendspace.com/file/qsm3ch.

The only missing icons were the "slide_sorter..." files in sd/res, these look generic anyway so I just copied them from Tango.


Since deleting all the redundant files that were deleted from Tango, this theme is actually the second smallest of all the themes, only "High Contrast" is smaller.
Comment 21 tommy27 2011-06-17 13:47:05 UTC
@Ed

well done!!!

now LibO devs should pack this .zip file in next 3.4.1 release
Comment 22 tommy27 2011-06-18 08:16:24 UTC
@Ed

did you replace old seagull OOo icons with new LibO icons?
Comment 23 Rainer Bielefeld Retired 2011-06-18 10:55:11 UTC
@tommy27, Ed:
For such big uploads you also  can use our experimental upload page
<http://wiki.documentfoundation.org/QA/Bugzilla-Attachments>
Thanks for your work! Are you willing to maintain that for a while?

@christoph:
May be you can add a strategic hint?
Comment 24 Ed 2011-06-18 16:18:54 UTC
Created attachment 48148 [details]
proposed update icons in quickstarted window
Comment 25 Ed 2011-06-18 16:20:34 UTC
The version I linked to is literally the same theme as in LO 3.3, repackaged to
work with 3.4.

I'm working on a version with more of the Sun/Oracle branding replaced, but
there are a few problems:

1.  I can't find a suitable icon for the "Charts" page of the options panel. 
There is an icon for this in the SVG source file, but I can't find a 32x32 PNG
version of it anywhere.

2.  I'm not sure what icons to use for the "New Document" and "Templates" icons
on the LHS of the quickstarter window.  These icons have not been updated in
any other theme, most of them still use the Oracle icons.

Provisionally I have used the grey generic LO icon for "New Document" and added
the spiral binding and a grey background to this icon for "Templates" (see
attached screenshot), but not sure if this is acceptable use of the branding.

Maybe it would be better to use the icon from the "Templates..." button in the
start centre.  In any case these two icons should logically be the same.

3.  I can't find any suitable replacement for framework/res/logo.png (a 38x15
picture of the gulls on a dark blue background).  Where in the program
interface is this one is actually used anyway?

When I've sorted these issues out I will try uploading another version using
the experimental upload page.

What would maintaining the theme actually involve?
Comment 26 Christoph 2011-06-19 06:17:21 UTC
@ all: Rainer asked for some strategical words ... don't know whether I'm the one who should do that, but some thoughts:

* We already miss resources for even maintaining one icon set. The development changed the default from "Galaxy" to "Tango", therefore I consider this the "lead icon set" to be worked on primarily. It has been designed right from the start to fit on all platforms.

* The visual metaphors of Tango are in some places (e.g. Basic IDE) sub-optimal. Here, Galaxy still fits better due to "designed for OOo/LibO only".

* New features are being added without having proper icons (e.g. merge and center in Calc). This is a problem for all icon sets.

* Classic is the basis for the High Contrast themes in LibreOffice. Thus, the basic shapes are helpful anyway. Maintaining the additional icons should be doable.

* The majority of users I know ask for a "more vibrant / modern" UI design.

* It was planned by the Tango Desktop team to fully revise the icons (leads to visual incompatibility with the today's icons). I don't know any further details.

@ ed: Thanks for your work and your comments - I consider most of them issues that apply to all icon sets (e.g. templates visualization). It would be great if you could help us in other places as well ...

Conclusion: We don't even have a good default set at the moment. I propose to continue the discussion on the Design Team list. The overall icon strategy / issues should be documented in the Design Whiteboards section. Furthermore, it would be insanely helpful to invite the guys who already improved the internal icon handling (the both Andrews). Would that be okay?
Comment 27 Ed 2011-06-21 02:51:26 UTC
Improved Classic theme uploaded to http://wiki.documentfoundation.org/cgi_img_auth.php/5/5f/Images_classic.zip.

I think I've managed to replace most of the Sun/Oracle branding, though there may still be the odd icon hiding somewhere.

I could only find a 16x16 "Charts" icon, so I've used that for the Options page.  It doesn't look quite right but it's the best I can do at the moment.  If someone can find the correct 32x32 version then they should replace /svx/res/tr10437.png with it.

Someone with better graphic design skills could probably improve the "Templates" icon I created, saved in /framework/res/templates_32.png (for the startcentre) and /svtools/res/template.png (for the quickstarter).
Comment 28 Rainer Bielefeld Retired 2011-06-21 03:48:44 UTC
(In reply to comment #27)
> Improved Classic theme 

Great! May be you will watch <http://wiki.documentfoundation.org/Extensions_Repository>? Although I also see a realistic chance that the Theme will be reintegrated, the Extensions repository might be the shortest way to make your work available for many users. That repository will become public in few days and also will manage those irksome things like licensing, nonliability and what ever else must be considered if you make code or similar available.
Comment 29 Ed 2011-06-21 04:26:04 UTC
There's no point assigning this to me.  All that is left to do is for the developers to incorporate the file I have uploaded in the distributed packaged of LO.  I am not in a position to do that.
Comment 30 tommy27 2011-06-21 11:00:53 UTC
(In reply to comment #29)


+1.

the easiest thing is to repack the Classic theme in LibO 3.4.1 which is scheduled for june 2th. 

create an extension would be just a waste of time
Comment 31 tommy27 2011-06-21 11:05:59 UTC
(In reply to comment #30)


sorry, I meant June 29th
Comment 32 tommy27 2011-06-29 01:44:59 UTC
LibO 3.4.1 is going to be released today

has the new Classic theme been reintroduced?
Comment 33 Rainer Bielefeld Retired 2011-06-29 02:11:46 UTC
Without willing maintainer Classic icon theme will not be integrated. Definitively! You may reopen this report, nobody will be interested. The reason is very simple: currently there is no manpower available to maintain that icon set.

Please feel free to reopen this issue if a maintainer volunteer has been found who will be willing and able to integrate the new set into the build process and grants support for the icon set for at least 1 year.
Comment 34 Ed 2011-06-29 02:40:43 UTC
What does "maintaining" the icon set actually involve?

Anyway this will be the last time I go out of my way to help if the response is so ungrateful and all my hard work will be thrown away just because someone can't be bothered to copy a single file into the package after I gave so much of my own time to create it.

If you want people to volunteer their own time to help you then you have to treat them better than that!
Comment 35 tommy27 2011-06-29 03:48:01 UTC
what a disappointing and harsh response from the devs...

Ed is right: he worked hard to make a compliant LibO 3.4 classic theme and he did not deserve such a treatment.

it seems that maintaining that icon theme is not difficult at all...

I could offer myself to maintain it, if Ed passes the ball...

the volunteer maintainer obviously needs some instructions and tips and tricks.

so, guys, reopen the issue, and reintegrate the Classic theme in LibO 3.4.2 which will be published at the endof July...

you have a month just to copy the zip file assembled by Ed into the new LibO 3.4.2 package....

do not disappoint us again...
Comment 36 Ed 2011-06-29 04:23:44 UTC
@tommy27 

Do you know what is required to "maintain" this icon set?  If you do then go ahead.  I would, but I have absolutely no idea what to do.  That and I don't feel inclined to give my time to help someone as rude as the LO devs.

It doesn't make sense for the devs to complain that no one has volunteered when the reason no one has volunteered is that they haven't told anyone what they need to volunteer to do.

The .zip file I have uploaded doesn't need any maintenance, it is ready to be used.  The only thing I might do is replace the "Charts" icon since I finally found a 32x32 version (all you have to do is copy /res/lx03128.png to /svx/res/tr10437.png), but this is purely cosmetic.  Feel free to take the file I uploaded and improve it in any way you can.
Comment 37 tommy27 2011-07-02 00:41:25 UTC
OK. I reopened the bug.

I a volonteer to maintain the icon set, which means I can upgrade and/or add new icons once requested by the devs.

then I will post here or where you want the desired zip file that someone will integrate and compile in the final build.

please tell me if there's something else I can/must do.

but please, do not behave the same way OOo devs did with the infamous "color coded" issue: http://openoffice.org/bugzilla/show_bug.cgi?id=112141

show us that LibO devs are different
show us that LibO contribution is really open to everyone
Comment 38 tommy27 2011-07-08 17:03:20 UTC
feedback. please.
Comment 39 Rainer Bielefeld Retired 2011-07-09 08:23:57 UTC
(In reply to comment #38)

Sorry, (everyone, as it seems) currently very busy, I'll try to give you some help next week.
Comment 40 tommy27 2011-07-09 09:55:10 UTC
Ok, I'll stay tuned.
Comment 41 Rainer Bielefeld Retired 2011-07-12 10:06:52 UTC
Here as promised my attempt to help to make Classic Theme available.

The bad news are:
From the developers no one with required skills, enough time and enthusiasm for that issue will be available.
tommy27 is willing to maintain that theme (what also is not a guarantee that it will be included), but the efforts to become a "real maintainer" are enormous, simply reading all that "how to contribute" and "developers introduction" would cost lots of time, and it even takes lots of additional time (and a developer mentor) to understand all that source repository and building stuff. I doubt that that can be done.

The good news is:
That all is not necessary if we adjust the focus of this issue. 
The far future goal should be: Create an interface allowing to use 3rd. parties themes in an easy way. 

The near future goal is: Make the existing reworked classic theme available for interested users.
That's easy, because it already exists, we only need to publish the possibility. 
Unfortunately there still are some problems to get the new Extensions repository running, but that can't hinder to start gathering Extensions, and the Classic Theme should be one. 
 
On <http://wiki.documentfoundation.org/Extensions_Repository> you can get some information, <http://wiki.documentfoundation.org/Extensions/Diagram_Extension> might be a template how to create an "Extension homepage", additions like for that one are available on the OOo Extension homepage (How to install, licensing, ...) have to be added. 
A second step might be to integrate the theme into a .oxt

@tommy27:
If you agree with that proceeding and will be willing to invest 2 ... 3 hours to do the most of the work, I can give you a little help (Wiki infrastructure, contacts, ...), and on Sunday we can have that Theme available as extension.
If you are interested you should subscribe 'website@global.libreoffice.org', where the relevant discussions happen, and let me hear your YES here, then we can start.
Comment 42 tommy27 2011-07-17 05:03:14 UTC
Hi Reiner,
there's probably something I miss or don't know about compiling LibO...

I mean, the Classic theme file is already available to be used.

It's just a zip file that you only have to manually copy under  “ \Bin\LibreOffice
3\Basis\share\config “ to enable it in LibreOffice...

so I don't understand why make things more complex by creating an extension (which I have no clue how to code...) that just has to copy that file in the proper subfolder?

So users with LibO 3.4.x may already enable again the Classic theme, just downloading and copying the zip file made by Ed in that subfolder.

What I asked in this bug report was to ship again the Classic theme in LibO 3.4.2 install package.

that means that developers should copy the Classic theme zip file and put it back where it was before in LibO 3.3.x so next time the theme will be already be there...

I admit I don't know much about the process of compiling LibO, so please tell me if I'm saying things that are not technically correct...

but as far as I may imagine, you should just add that zip file to your repository before compiling the next LibO 3.4.2 release....

Is this possible or not?
Comment 43 Rainer Bielefeld Retired 2011-07-17 06:36:32 UTC
@tommy27
For such questions you have to try get help on developer's mailing list (libreoffice@lists.freedesktop.org) or developer's IRC channel 
(irc://freenode/%23libreoffice-dev). I have view influence and and even less knowledge concerning details , the only I can say: I doubt that you will earn much enthusiasm there. But, of course, you can try.
Comment 44 Cor Nouws 2011-08-04 13:52:13 UTC
.
Comment 45 revida 2011-08-09 01:14:04 UTC
Please, make Classic icon theme available again.
Thanks.
Jiří
Comment 46 Tamas Domjan 2011-09-01 01:34:49 UTC
I would like to ask also to please, make Classic icon theme available again in LibreOffice.
Thank you.
- Tamas
Comment 47 Rainer Bielefeld Retired 2011-11-17 05:45:45 UTC
This request is in a dead-end street because it seems that there is no one with interest AND skills to do that in a currently possible way.
Comment 48 tommy27 2011-11-18 04:22:58 UTC
(In reply to comment #42)
> the Classic theme file is already available to be used.
> 
> It's just a zip file that you only have to manually copy under  
> “ \Bin\LibreOffice 3\Basis\share\config “ to enable it in LibreOffice...
> So users with LibO 3.4.x may already enable again the Classic theme.

I'm uploading under attachments a version of that file which is tested and working on my LibO 3.4.4.  download it and move it to the proper location, then enable the Classic theme from the menu Tools/Options/View/Size and Icons Style (I'm translating from an Italian GUI so in your language it may differ)

> 
> What I asked in this bug report was to ship again the Classic theme in LibO
> 3.4.2 install package.
> 
> I admit I don't know much about the process of compiling LibO, so please tell
> me if I'm saying things that are not technically correct...
> 
> but as far as I may imagine, you should just add that zip file to your
> repository before compiling the next LibO 3.4.2 release....
> 
> Is this possible or not?

nobody has still answered this simple question... is this possible or not?
a LibO 3.4.x compliant Classic icon set is already available here.
what's preventing to add it again to the installation package?
Comment 49 tommy27 2011-11-18 04:24:41 UTC
Created attachment 53647 [details]
Classic Theme for LibO 3.4.4
Comment 50 Rainer Bielefeld Retired 2011-11-18 08:10:54 UTC
I did a quick test with "LibreOffice 3.4.4  - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:402)]".

@tommy27:
We can't distribute that theme via Bugzilla, please upload it to the Extension repository, How-to you find here <https://wiki.documentfoundation.org/Extensions_Repository>

I started Wiki page <https://wiki.documentfoundation.org/Classic_Theme_Extension>. Please feel free to to use or add information.

If upload is done please assign this bug to me, I will do some propaganda.
Comment 51 Rainer Bielefeld Retired 2011-11-18 10:20:02 UTC
Attached Theme does not work for me with with Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [(Build ID:  4f11d0a-adcf6d5-c4bb9bd)]" Windows_2008R2 - 111118), it seems something with icons handling has changed. 

@tommy27
EasyHack or assitence of a developer required?
Comment 52 tommy27 2011-11-18 11:11:09 UTC
@Reiner

1. estension repo 
--> I'll do it later

2. theme non working in 3.5 master
my guess is that in LibO 3.4.x the devs just removed physically the images_classic.zip file but the software still has some code somewhere pointing towards that file.

indeed if you put a images_classic.zip file under 3.4.x you can enable the classic theme.

however if you rename the images_classic.zip with something else (i.e. images_dummy.zip) LibO 3.4.x fails to recognize that theme.

probably the code in 3.5.x has been cleaned and there's no place for the classic theme yet, but just for the other themes (Tango, Galaxy etc. etc.)

so, to confirm my theory, put the images_classic.zip under 3.5.x and rename it as images_tango.zip (remove the original file at first) then select the tango theme from the menu... I bet you will see the classic icons istead of the tango ones
Comment 53 Rainer Bielefeld Retired 2011-12-01 10:16:00 UTC
Theme is available, FIXED

@tommy27
Already any activity concerning 3.5? I only can do little support (contacts ...)
Comment 54 Caolán McNamara 2011-12-13 12:41:04 UTC
*** Bug 43797 has been marked as a duplicate of this bug. ***
Comment 55 tommy27 2012-02-12 05:09:00 UTC
Created attachment 56913 [details]
Classic Theme for LibO 3.5.0

place this file under 
... Bin\LibreOffice 3\share\config
Comment 56 tommy27 2012-02-12 05:17:13 UTC
some changes were made in the internal icon themes structure from LibO 3.4.x to 3.5.x

basically the folder “res/commandimagelist” which contains tha majority of toolbar icons was moved from “res” up one level and renamed “cmd” 

that's why the 3.4.x classic theme did not work in 3.5.0

I reassembled accordingly the icons folders and now here's a new images_classic.zip file that fits in LibO 3.5.0.

you can downalad it from the post above and put in the proper path
Comment 57 Cor Nouws 2012-02-12 05:20:09 UTC
(In reply to comment #56)
> you can downalad it from the post above and put in the proper path

Works - thanks a lot!
Cor
Comment 58 Rainer Bielefeld Retired 2012-02-12 10:51:21 UTC
I did some quick tests and did not find any problem. 

@tommy27:
You are a hero! Can you please upload it to Extensions? That's the place where interested users will look for it, and an available 3.5 icon set will avoid disappointed users who tried whether the old 3.4 Icon set. Thanks a lot!
Comment 59 tommy27 2012-02-28 14:10:07 UTC
hi, sorry for delay in reply...

weeks ago I tried to file the 3.4.x theme as an extension

the page was created here:
http://extensions.libreoffice.org/extension-center/classic-theme

but I had troubles understanding how to upload the file itself

I tried and I tried but there's something not intuitive in the whole process that made me fail to complete a proper submission...

so, if there's anybody with moderator rights that wants to update that extension page putting there the 3.4.x icon pack and the new 3.5.x icon pack (you can dowlnload the files from here), he is welcome.
Comment 60 Andreas Mantke 2012-04-04 04:37:47 UTC
Hi tommy27,

please give a more specific explanation about the steps, you tried to get your extension on the site. I looked into your project and found out that you created two releases sections, but no release. I recommend to read through the howto from Gustavo Pacheco, linked from the home page of http://extensions.libreoffice.org --> http://wiki.documentfoundation.org/images/1/14/Publishing_extensions.pdf

If you missed something there please ask the webmaster at documentfoundation.org.

Andreas
Comment 61 tommy27 2012-09-19 05:41:20 UTC
Created attachment 67363 [details]
Classic Theme for LibO 3.6.x

Classic Theme for LibO 3.6.x

place this file under 
... Bin\LibreOffice 3\share\config
Comment 62 Rainer Bielefeld Retired 2012-09-19 07:26:48 UTC
@tommy27:
Great! Can you upload it to extensions repository? I think there much more users will find and use it.
I left a hint with link on <http://extensions.libreoffice.org/extension-center/classic-theme/>
Comment 63 tommy27 2013-05-20 04:45:34 UTC
Created attachment 79560 [details]
Classic Theme for LibO 4.0.x

here's a 4.0.x compatible classic theme for LibO.

regarding the extension page, feel free to upload those files there.
you have my permission,
Comment 64 tommy27 2014-01-30 02:27:53 UTC
Created attachment 93030 [details]
Classic Theme for LibO 4.1.x

updated classic theme for LibO 4.1.x with a few tweaks and fixes.
Comment 65 tommy27 2014-05-05 07:49:08 UTC
Created attachment 98455 [details]
Classic Theme for LibO 4.2.x

already tested and working with 4.2.3.3
Comment 66 tommy27 2014-05-05 08:27:36 UTC
LibO 4.3.x user who wanna still use the classic theme may be interested in this report Bug 78281 - Classic theme can't be used in 4.3.x unless renaming to another supported theme name
Comment 67 Adolfo Jayme 2014-05-05 11:03:09 UTC
*** Bug 78281 has been marked as a duplicate of this bug. ***
Comment 68 tommy27 2014-05-05 11:28:05 UTC
I change status to WONTFIX since a lot of time ago was decided to not ship anymore the classic theme.

people who still love have easy workarounds to keep using it.
Comment 69 ape 2015-01-24 11:44:38 UTC
Created attachment 112773 [details]
Classic Theme for LibO 4.3.x

I forgot to post the classic icon for the LibreOffice-4.3.x. Excuse me. 
Is there a need to make changes for version 4.4.x?