Download it now!
Bug 78303 - FORMATTING: footnote numbering wrong for per page numbering if moved to next page due missing space
Summary: FORMATTING: footnote numbering wrong for per page numbering if moved to next ...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Footnote-Endnote
  Show dependency treegraph
 
Reported: 2014-05-05 13:52 UTC by metaphalon
Modified: 2019-05-14 02:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example for broken Footnote numbering: Footnote on page 2 starts with 2 instead of 1 (10.86 KB, application/vnd.oasis.opendocument.text)
2014-05-05 13:52 UTC, metaphalon
Details
Screen Cast of Problem (2.88 MB, video/x-matroska)
2014-06-10 16:35 UTC, metaphalon
Details
Footnote Numbering Test Steps (16.72 KB, application/vnd.oasis.opendocument.text)
2015-03-03 01:05 UTC, Gordo
Details
Footnote Numbering (9.31 KB, application/vnd.oasis.opendocument.text)
2015-03-03 01:05 UTC, Gordo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description metaphalon 2014-05-05 13:52:14 UTC
Created attachment 98489 [details]
Example for broken Footnote numbering: Footnote on page 2 starts with 2 instead of 1

Paragraphs with footnotes which are moved to the next page, due footnote and paragraph do not fit together on the same page i.e. paragraph is at the end of the page, break the per page numbering of the footnote.

Example attached.

Tested with:
  Windows 7 + LO 4.0.4.2
  Ubuntu 14.04 + LO 4.2.2.3
Comment 1 Yousuf Philips (jay) (retired) 2014-05-27 14:57:14 UTC
Opening the attached file i see the broken numbering in 4.2.4 and 4.3 beta, but i cant produce the same result myself, so maybe you can send in an initial document where the numbering is correct, along with instructions on how to produce the problem. A screencast would also be great if you know how to do it.
Comment 2 metaphalon 2014-05-28 09:25:24 UTC
This can be easy reproduced by following steps:

* Open new Document
* Insert 3 Paragraphs with footnotes
* Insert before those three paragraphs as many empty paragraphs until the last paragraph with footnote is placed on the next page
  -> numbering is broken for last paragraph with footnote


Sometimes this has not been worked, then i could reproduce this error by inserting more empty paragraphs until the last 2 paragraphs with footnotes are placed on the next page and then remove the empty paragraphs until only the last paragraph with footnote remains on the next page.

Hope this helps.
Comment 3 Yousuf Philips (jay) (retired) 2014-06-03 02:04:53 UTC
I tried and tried but still with no success. Would it be possible for you to produce a screencast.
Comment 4 metaphalon 2014-06-10 16:35:19 UTC
Created attachment 100832 [details]
Screen Cast of Problem

In the cast i show how to reproduce the wrong behaviour.
Comment 5 Yousuf Philips (jay) (retired) 2014-06-10 17:17:15 UTC
(In reply to comment #4)
> In the cast i show how to reproduce the wrong behaviour.

Thanks for the screencast but after i attempted to reproduce the same thing as the 46 second clip, after saving and reopening the file, it still was fine. I tried it on 4.0.6 and 4.2.4.
Comment 6 metaphalon 2014-06-10 17:57:31 UTC
Interesting.

I've could reproduce the behaviour on Win 7 and 
LO 4.2.4.2 
Build-ID: 63150712c6....
(this is the most recent version)

I've used 2 different computers with 2 Ubuntu 14.04 and Win7 and 3 different LO Versions.

Have you tried an clean OS (i.E. in a virtual machine).
Perhaps you have some very custom settings (if so i would like to know, to solve my problem ;-) )


Thanks Jay for taking the time.
Comment 7 Yousuf Philips (jay) (retired) 2014-06-10 21:22:10 UTC
My system is clean as i only use Libreoffice on it to test bug reports. If you could do a longer screencast with you creating the file and saving it and opening up again, i will try again to confirm it. There is a 3mb file size limit here and if the video goes above that size, maybe you can upload it to dropbox, google drive or onedrive and share the link here.
Comment 8 metaphalon 2014-06-16 09:35:03 UTC
The original video file is can be downloaded her:

https://drive.google.com/file/d/0B6WyR_rVx7SATUVKXzBsUmNjdjQ/edit?usp=sharing
Comment 9 Yousuf Philips (jay) (retired) 2014-06-27 23:48:37 UTC
Sorry for the delay. I watched the video and when you reopened the file the number was fine. Am i missing something?
Comment 10 metaphalon 2014-07-14 19:14:08 UTC
Sorry for my delay.

No you haven't missed something in my screencast.
By trying to simplyfy the problem, I interpreted correct behaviour of LO as faulty.

I gave it another try.
The linked screencast [1] shows, how I add some paragraphs with keep together and distribute them so, that removing a single paragaph results in most of them switch pages and the last one remains with wrong footnote numbering.
It is a little bit long, but i hope you get the idea.
I also linked the created documents [2], in case you want to check.


[1]
https://drive.google.com/file/d/0B6WyR_rVx7SAY0N1NHIzSWR6RFk/edit?usp=sharing
[2]
https://drive.google.com/file/d/0B6WyR_rVx7SAU0tYWFBNOG5XT2c/edit?usp=sharing
https://drive.google.com/file/d/0B6WyR_rVx7SAaVR2Q0lpN2dvaFk/edit?usp=sharing
https://drive.google.com/file/d/0B6WyR_rVx7SAeE94U19IQnp1WW8/edit?usp=sharing
Comment 11 Buovjaga 2014-11-26 10:41:46 UTC
(In reply to metaphalon from comment #10)
> https://drive.google.com/file/d/0B6WyR_rVx7SAY0N1NHIzSWR6RFk/edit?usp=sharing

I tried following this, but I don't know, what you did in 01:52 when the first 6 paragraphs jump to the first page.
Comment 12 Gordo 2015-03-03 01:05:24 UTC
Created attachment 113842 [details]
Footnote Numbering Test Steps

I was able to produce incorrect numbering.

Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: en_GB
Comment 13 Gordo 2015-03-03 01:05:57 UTC
Created attachment 113843 [details]
Footnote Numbering

And here is the document.
Comment 14 Buovjaga 2015-03-03 06:07:50 UTC
Keymasher: thanks for testing! I'll set this to NEW.
Comment 15 tommy27 2016-04-16 07:28:43 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.5 or 5.1.2 https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-04-16
Comment 16 QA Administrators 2019-05-14 02:56:31 UTC
Dear metaphalon,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug