Bug 78401 - FILEOPEN: DOC table in frame with "Page Wrap" lets next table overlap
Summary: FILEOPEN: DOC table in frame with "Page Wrap" lets next table overlap
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bisected, filter:doc, regression
: 96307 108095 (view as bug list)
Depends on:
Blocks: Writer-Tables DOC
  Show dependency treegraph
 
Reported: 2014-05-07 19:11 UTC by Ari Latvala
Modified: 2017-10-22 11:09 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
the .doc file (97.00 KB, application/msword)
2014-05-28 11:51 UTC, Yousuf Philips (jay) (retired)
Details
LibO 4.0 VS 4.3 beta (268.94 KB, image/png)
2014-05-28 12:01 UTC, Yousuf Philips (jay) (retired)
Details
Right after opening the file (83.54 KB, image/png)
2015-10-30 08:11 UTC, Ari Latvala
Details
Extended some table rows to show all content (53.14 KB, image/png)
2015-10-30 08:12 UTC, Ari Latvala
Details
Screenshot showing DOC vs PDF side by side pointing errors (211.83 KB, image/jpeg)
2015-12-05 07:37 UTC, Ari Latvala
Details
Screenshot showing RTF vs PDF side by side pointing errors (195.99 KB, image/jpeg)
2015-12-05 07:40 UTC, Ari Latvala
Details
Another DOC example for table overlap (54.60 KB, application/msword)
2017-08-16 17:33 UTC, Timur
Details
Another DOC example for table overlap - PDF from MSO (173.13 KB, application/pdf)
2017-08-16 17:34 UTC, Timur
Details
Another DOC example for table overlap - frame wrap set to None (54.62 KB, application/msword)
2017-08-16 17:41 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ari Latvala 2014-05-07 19:11:41 UTC
Problem description:
http://www.kissaliitto.fi/lomakkeet/nayttely -site has all sort of forms on PDF, Word and RTF -formats. Unfortunately Word/RTF versions do not show correctly on LibreOffice 4.2.3 nor on AOO 4.0.1.

Steps to reproduce:
1. Download from http://www.kissaliitto.fi/lomakkeet/nayttely -site Word version of "Kotimaan näyttelyilmoittaumislomake"
2. Open it on Writer
3. You'll see that layout does not match PDF version

Current behavior:
Fonts are badly overlapping on the small texts

Expected behavior:
Layout should look identical to PDF version

              
Operating System: Windows 7
Version: 4.2.3.3 release
Comment 1 Yousuf Philips (jay) (retired) 2014-05-28 11:51:13 UTC
Confirmed in Linux Mint in the latest releases from 4.1 to 4.2 and 4.3 beta. This is a regression as it works fine in 4.0.

Basically one table near the bottom is appearing behind the content that follows it.
Comment 2 Yousuf Philips (jay) (retired) 2014-05-28 11:51:45 UTC
Created attachment 100027 [details]
the .doc file
Comment 3 Yousuf Philips (jay) (retired) 2014-05-28 12:01:49 UTC
Created attachment 100028 [details]
LibO 4.0 VS 4.3 beta
Comment 4 Joel Madero 2014-06-18 05:06:35 UTC Comment hidden (obsolete)
Comment 5 Michael Stahl (CIB) 2014-07-07 15:42:03 UTC
comment #4 is pretty useless, no idea which repo those are from...

bibisect range:

358b60b3b172968a7605b428af01df456d7669b2..d74ba0c4147f33abd9d0c03883cc88f15e160ee5

regression from:

commit 4e07258cbd1f4fb16d6ce2174fb5c74c3b36da33
Author:     Chen ZuoJun <zjchen@apache.org>
AuthorDate: Mon Oct 8 12:21:52 2012 +0000

    #i119466# Doc file loaded by AOO, table with incorrect text wrapping property.
Comment 6 Michael Stahl (CIB) 2014-07-21 10:00:27 UTC Comment hidden (obsolete)
Comment 7 Björn Michaelsen 2014-10-16 14:59:13 UTC Comment hidden (obsolete)
Comment 8 Ari Latvala 2015-10-30 08:11:09 UTC Comment hidden (obsolete)
Comment 9 Ari Latvala 2015-10-30 08:12:59 UTC Comment hidden (obsolete)
Comment 10 Ari Latvala 2015-10-30 08:16:10 UTC Comment hidden (no-value)
Comment 11 Ari Latvala 2015-10-30 08:20:39 UTC Comment hidden (obsolete)
Comment 12 Joel Madero 2015-10-30 14:31:23 UTC Comment hidden (obsolete)
Comment 13 Ari Latvala 2015-10-30 18:50:37 UTC Comment hidden (no-value)
Comment 14 Ari Latvala 2015-11-03 21:29:15 UTC Comment hidden (obsolete)
Comment 15 Ari Latvala 2015-12-05 07:02:13 UTC Comment hidden (obsolete)
Comment 16 Ari Latvala 2015-12-05 07:37:20 UTC
Created attachment 121032 [details]
Screenshot showing DOC vs PDF side by side pointing errors

Red arrows and red box pointing to some of the problematic places on the DOC version of the documents vs. PDF showing, how it should be
Comment 17 Ari Latvala 2015-12-05 07:40:07 UTC Comment hidden (obsolete)
Comment 18 Ari Latvala 2015-12-05 07:40:47 UTC Comment hidden (obsolete)
Comment 19 Xisco Faulí 2016-09-12 12:23:56 UTC Comment hidden (obsolete)
Comment 20 Aron Budea 2016-09-24 15:10:56 UTC
Bisected as per comment 5.
Same commit as the one caused bug 78756, but the issue is different, so I wouldn't close it as duplicate.
Comment 21 Ari Latvala 2017-07-30 09:47:42 UTC
Problem still exist on LO 5.4.0.3 running on Windows 10 64-bit Creators update. Table 6 is located inside a frame correctly but frame wrapping should be using either "Wrap off" or "Optimal page wrapping" to get correct layout. Current "Page wrap" lets next tables to overlap table 6.
Comment 22 Yousuf Philips (jay) (retired) 2017-07-30 12:36:34 UTC
Bug 75331 has the same issue as this, though it shows up in 4.0 and this bug shows in 4.1.
Comment 23 Timur 2017-08-16 17:33:15 UTC
Created attachment 135593 [details]
Another DOC example for table overlap

Here is another DOC example for table overlap, looks like this bug.
I obolsted some of Ari's comments and attachment because this is not "document based" bug and other issues with that specific doc are not relevant - only table overlap is.
Comment 24 Timur 2017-08-16 17:34:42 UTC
Created attachment 135594 [details]
Another DOC example for table overlap - PDF from MSO

How "Another DOC example for table overlap" should look.
Comment 25 Timur 2017-08-16 17:41:46 UTC
Created attachment 135595 [details]
Another DOC example for table overlap - frame wrap set to None

"Another DOC example for table overlap" opens fine when frame wrap is previously set to None and saved in MSO.
Comment 26 Timur 2017-09-13 14:11:38 UTC
Table overlap for attachment 100027 [details] looks better after Bug 112346. 
Due to https://bugs.documentfoundation.org/show_bug.cgi?id=112346#c4 I'll close this bug. Please track Bug 112359.
Comment 27 Timur 2017-09-13 14:52:19 UTC
*** Bug 108095 has been marked as a duplicate of this bug. ***
Comment 28 Timur 2017-09-13 14:53:39 UTC
*** Bug 96307 has been marked as a duplicate of this bug. ***