Bug 96307 - FILEOPEN DOC: Incorrect Frame wrapping (should be None instead of Parallel)
Summary: FILEOPEN DOC: Incorrect Frame wrapping (should be None instead of Parallel)
Status: RESOLVED DUPLICATE of bug 78401
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: bibisected, bisected, filter:doc, regression
Depends on:
Blocks:
 
Reported: 2015-12-07 10:33 UTC by Ari Latvala
Modified: 2017-09-13 14:53 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
PDF version showing the expected layout (36.99 KB, application/pdf)
2015-12-07 10:33 UTC, Ari Latvala
Details
DOC version having incorrect Frame positioning (97.00 KB, application/msword)
2015-12-07 10:34 UTC, Ari Latvala
Details
RTF version of the same document for comparison (1.36 MB, application/rtf)
2015-12-07 10:34 UTC, Ari Latvala
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ari Latvala 2015-12-07 10:33:07 UTC
Created attachment 121102 [details]
PDF version showing the expected layout

Libre Office 5.0.4.1 running on Windows 7 64-bit

Attached document "kissaliitto_ilmo_141.doc" from site http://www.kissaliitto.fi/lomakkeet/nayttely has Frame 1 incorrectly positioned and on the RTF version of the same document it seems to be Table, not Frame at all. PDF version shows the expected layout.
Comment 1 Ari Latvala 2015-12-07 10:34:01 UTC
Created attachment 121103 [details]
DOC version having incorrect Frame positioning
Comment 2 Ari Latvala 2015-12-07 10:34:42 UTC
Created attachment 121104 [details]
RTF version of the same document for comparison
Comment 3 Buovjaga 2015-12-08 11:30:03 UTC
Confirmed.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: 81fa5340191baf8687f9c82f1f414f5afc86b529
Threads 4; Ver: Windows 6.1; Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-03_21:19:19
Locale: fi-FI (fi_FI)

4.3.0.1
Comment 4 Cor Nouws 2015-12-09 12:32:25 UTC
Comparing with the PDF, the frame misses the setting for wrapping.
(The RTF looks better, since the frame seems to be converted to a table)
Comment 5 Cor Nouws 2015-12-09 12:35:35 UTC
In LibreOffice 3.3.0 the frame wrapping is fine: Dynamic / first paragraph.
Comment 6 Joel Madero 2015-12-12 22:33:11 UTC
Can someone please explain exactly what I'm looking for so I can bibisect this? I opened the file and I can't see immediately what I'm bibisecting. Thanks
Comment 7 Cor Nouws 2015-12-12 23:00:40 UTC
Hi Joel,

(In reply to Joel Madero from comment #6)
> Can someone please explain exactly what I'm looking for so I can bibisect
> this? I opened the file and I can't see immediately what I'm bibisecting.

Near the lower part of the page there is a frame, that - of correct - pushes a not to high table to the lower part.
What we see in LibreOffice, is the frame allows the table to overlap it.
HTH :)
Comment 8 Joel Madero 2015-12-13 06:10:58 UTC
This one is a little tricky because there's an issue in the bibisect package so it's one of the following two bibisects - I'm relatively sure it's the second one :)

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
ff4b17247dc05a006a5c4c57dced132c87f2396c is the first bad commit
commit ff4b17247dc05a006a5c4c57dced132c87f2396c
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Thu Oct 17 00:01:56 2013 +0000

    source-hash-d74ba0c4147f33abd9d0c03883cc88f15e160ee5
    
    commit d74ba0c4147f33abd9d0c03883cc88f15e160ee5
    Author:     Miklos Vajna <vmiklos@suse.cz>
    AuthorDate: Mon Apr 15 13:01:22 2013 +0200
    Commit:     Miklos Vajna <vmiklos@suse.cz>
    CommitDate: Mon Apr 15 13:36:56 2013 +0200
    
        RtfAttributeOutput::FormatBackground: export fillColor
    
        Change-Id: I9d187fc5b52a27ff5b8bc847a52fe95c63558a40

:100644 100644 bcb5325d326d1019624ac2a10df9ff3e3b5e0917 5676a0ef86cad714a93a8053a58ed56e364ea52c M	autogen.log
:100644 100644 cec2e1adcf8746af97f26d1520d2b75c69b6c324 b4ae4276966dd04a235f93e06811bbaf85f069d6 M	ccache.log
:100644 100644 da1e48b30fa7c006b7b3271dbe51fd3c1ea662b5 72a68e85f3ec4874df57f44e4c59176b35568fe1 M	commitmsg
:100644 100644 21222da91791b9a43c32af0ba90e106f267295f1 7d8918ebdd196b2d41f17e988111aa6f3e0ef7cb M	dev-install.log
:100644 100644 b81a2daaf0a429bab845f06a54fe69a9140ba537 0ccc5c466da2571a608f6af2df3e738e980704af M	make.log
:040000 040000 8a40471aabde5be7138d6f0d4c0b9e619db85f97 2877f1f554a288b090ef603a1e3227c8a0cb8229 M	opt


# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# bad: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect bad e02439a3d6297a1f5334fa558ddec5ef4212c574
# good: [8f4aeaad2f65d656328a451154142bb82efa4327] source-hash-1885266f274575327cdeee9852945a3e91f32f15
git bisect good 8f4aeaad2f65d656328a451154142bb82efa4327
# good: [9995fae0d8a24ce31bcb5e9cd0459b69cfbf7a02] source-hash-8600bc24bbc9029e92bea6102bff2921bc10b33e
git bisect good 9995fae0d8a24ce31bcb5e9cd0459b69cfbf7a02
# good: [8ad82bc1416a07501651e8d96fe268e47d3931d3] source-hash-13821254f88d2c5488fba9fe6393dcf4ae810db4
git bisect good 8ad82bc1416a07501651e8d96fe268e47d3931d3
# bad: [d084d250b04446535ca1d7c29cf2062e6bd042b3] source-hash-688f72e3a2c3ef923389bbd21f6aea3afe1114db
git bisect bad d084d250b04446535ca1d7c29cf2062e6bd042b3
# bad: [013adf05b6bf8e5d44a4e820d43177d7fb749079] source-hash-a16a4006e40bdb2cb4671846295fe2bf5a856e68
git bisect bad 013adf05b6bf8e5d44a4e820d43177d7fb749079
# bad: [ff4b17247dc05a006a5c4c57dced132c87f2396c] source-hash-d74ba0c4147f33abd9d0c03883cc88f15e160ee5
git bisect bad ff4b17247dc05a006a5c4c57dced132c87f2396c
# good: [54c7e3977148ffe7631292f2f7d6d60cf7c86bbc] source-hash-5ad95cec96f6f08c55bb226a6eaeb1eeb95c1279
git bisect good 54c7e3977148ffe7631292f2f7d6d60cf7c86bbc
# good: [6a9079688b8251402bfcea35b741a418cab30229] source-hash-bd7b2c7befbd10bebaba3a9b6ea491969ac1dcb0
git bisect good 6a9079688b8251402bfcea35b741a418cab30229
# first bad commit: [ff4b17247dc05a006a5c4c57dced132c87f2396c] source-hash-d74ba0c4147f33abd9d0c03883cc88f15e160ee5

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

6a9079688b8251402bfcea35b741a418cab30229 is the first bad commit
commit 6a9079688b8251402bfcea35b741a418cab30229
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Wed Oct 16 23:32:34 2013 +0000

    source-hash-bd7b2c7befbd10bebaba3a9b6ea491969ac1dcb0
    
    commit bd7b2c7befbd10bebaba3a9b6ea491969ac1dcb0
    Author:     Takeshi Abe <tabe@fixedpoint.jp>
    AuthorDate: Thu Apr 11 18:32:27 2013 +0900
    Commit:     Takeshi Abe <tabe@fixedpoint.jp>
    CommitDate: Fri Apr 12 06:30:03 2013 +0900
    
        sal_Bool to bool
    
        Change-Id: Ia86be34c6cfeab2a853305aa1568c384d7b4e2b9

:100644 100644 39c5c079630c945bc7ac6deda19f2f83a467049c cec2e1adcf8746af97f26d1520d2b75c69b6c324 M	ccache.log
:100644 100644 190f5bcd4d5c05cdf2e85d1818f78db8233c2590 da1e48b30fa7c006b7b3271dbe51fd3c1ea662b5 M	commitmsg
:100644 100644 c4d0c84ffdd0ded15cbf8b4a062b8db45b38914c 21222da91791b9a43c32af0ba90e106f267295f1 M	dev-install.log
:100644 100644 df6725a44982d870e5fc06db36b8b140b9247c82 b81a2daaf0a429bab845f06a54fe69a9140ba537 M	make.log
:040000 040000 39b0b04f601c8b5389fc3a278779367e28cbb7bd 8a40471aabde5be7138d6f0d4c0b9e619db85f97 M	opt


# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# bad: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect bad e02439a3d6297a1f5334fa558ddec5ef4212c574
# good: [8f4aeaad2f65d656328a451154142bb82efa4327] source-hash-1885266f274575327cdeee9852945a3e91f32f15
git bisect good 8f4aeaad2f65d656328a451154142bb82efa4327
# good: [9995fae0d8a24ce31bcb5e9cd0459b69cfbf7a02] source-hash-8600bc24bbc9029e92bea6102bff2921bc10b33e
git bisect good 9995fae0d8a24ce31bcb5e9cd0459b69cfbf7a02
# good: [8ad82bc1416a07501651e8d96fe268e47d3931d3] source-hash-13821254f88d2c5488fba9fe6393dcf4ae810db4
git bisect good 8ad82bc1416a07501651e8d96fe268e47d3931d3
# bad: [d084d250b04446535ca1d7c29cf2062e6bd042b3] source-hash-688f72e3a2c3ef923389bbd21f6aea3afe1114db
git bisect bad d084d250b04446535ca1d7c29cf2062e6bd042b3
# bad: [013adf05b6bf8e5d44a4e820d43177d7fb749079] source-hash-a16a4006e40bdb2cb4671846295fe2bf5a856e68
git bisect bad 013adf05b6bf8e5d44a4e820d43177d7fb749079
# bad: [ff4b17247dc05a006a5c4c57dced132c87f2396c] source-hash-d74ba0c4147f33abd9d0c03883cc88f15e160ee5
git bisect bad ff4b17247dc05a006a5c4c57dced132c87f2396c
# good: [54c7e3977148ffe7631292f2f7d6d60cf7c86bbc] source-hash-5ad95cec96f6f08c55bb226a6eaeb1eeb95c1279
git bisect good 54c7e3977148ffe7631292f2f7d6d60cf7c86bbc
# bad: [6a9079688b8251402bfcea35b741a418cab30229] source-hash-bd7b2c7befbd10bebaba3a9b6ea491969ac1dcb0
git bisect bad 6a9079688b8251402bfcea35b741a418cab30229
# good: [005d70d91c2589e3a200a9dfd4050820cbf73376] source-hash-358b60b3b172968a7605b428af01df456d7669b2
git bisect good 005d70d91c2589e3a200a9dfd4050820cbf73376
# first bad commit: [6a9079688b8251402bfcea35b741a418cab30229] source-hash-bd7b2c7befbd10bebaba3a9b6ea491969ac1dcb0
Comment 9 Ari Latvala 2016-03-14 20:52:48 UTC
Still reproducible on the latest LO 5.1.1.3 release for Windows 7 SP1 64-bit. Frame wrap is parallel for Frame1 (Table6) leading overlapping with the following tables. Frame wrapping should be None to produce correct layout.
Comment 10 Cor Nouws 2016-03-15 10:04:24 UTC
@takeshi, @miklos, can you please have a look (see comment #8)

Frame wrapping should be none (or or dynamic & first paragraph)
thanks
Comment 11 Takeshi Abe 2016-03-16 04:37:24 UTC
Found that both LibO 4.1.0 and AOO 4.1.1 are NG in a similar fashion (while LibO 4.0.6 is OK), I think the bibisects result is misleading and the root of the issue seems deeper.
Comment 12 Takeshi Abe 2016-03-16 07:26:10 UTC
4e07258cbd1f4fb16d6ce2174fb5c74c3b36da33 is the commit introducing the regression.
See https://bz.apache.org/ooo/show_bug.cgi?id=119466 for details.
Comment 13 Ari Latvala 2016-06-02 20:12:15 UTC
Problem still exist on the latest LO 5.2 Beta 1 for Windows 7 SP 1 64-bit
Comment 14 Xisco Faulí 2016-09-24 14:37:36 UTC

*** This bug has been marked as a duplicate of bug 78756 ***
Comment 15 Timur 2017-09-13 14:53:39 UTC
Same file.

*** This bug has been marked as a duplicate of bug 78401 ***