Download it now!
Bug 78524 - Other: Some options on Portuguese grammar checking don't display entirely
Summary: Other: Some options on Portuguese grammar checking don't display entirely
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: Other Linux (All)
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: BSA target:4.3.0 target:4.2.5
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-10 10:32 UTC by Julien Nabet
Modified: 2014-05-10 12:02 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Screenshot of the problem (74.44 KB, image/png)
2014-05-10 10:32 UTC, Julien Nabet
Details
Result screenshot after patch (97.70 KB, image/png)
2014-05-10 11:11 UTC, Julien Nabet
Details
patch (11.10 KB, patch)
2014-05-10 11:44 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Nabet 2014-05-10 10:32:17 UTC
Created attachment 98814 [details]
Screenshot of the problem

Problem description: 
Some options on Portuguese gramar corrector don't display entirely

Steps to reproduce:
1. Open Writer
2. Tools/Options/Language Settings
3. Grammar checking Portuguese

Current behavior:
Some options on Portuguese gramar corrector don't display entirely
like:
- "Palavras duplicadas" (the final "s" is cut)
- "Concordância verbal" (final "a" is cut and final "l" doesn't appear at all)
- etc.

Expected behavior:
Every option should display entirely

              
Operating System: Debian
Version: 4.3.0.0.alpha0+ Master
Comment 1 Julien Nabet 2014-05-10 10:40:25 UTC
Taking a look at dictionaries/pt_BR/dialog/pt_BR.xdl since it's quite the same as fdo#76692 put in See Also
Comment 2 Julien Nabet 2014-05-10 11:11:30 UTC
Created attachment 98816 [details]
Result screenshot after patch
Comment 3 Julien Nabet 2014-05-10 11:44:20 UTC
Created attachment 98817 [details]
patch
Comment 4 Commit Notification 2014-05-10 11:48:18 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/dictionaries/commit/?id=b76a214cc1e5c52cc0f012888b25aaa3b3b4e032

Resolves: fdo#78524 Some wrong display on Portuguese grammar checking



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2014-05-10 11:57:24 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/dictionaries/commit/?id=5666484298c4252e56d32fa630ecde93e44d54d3&h=libreoffice-4-2

Resolves: fdo#78524 Some wrong display on Portuguese grammar checking


It will be available in LibreOffice 4.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.