Bug 76692 - UI: LightProof: Italian translation too long in options
Summary: UI: LightProof: Italian translation too long in options
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: BSA target:4.3.0 target:4.2.5
Keywords:
: 72669 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-03-27 14:23 UTC by Marina Latini (CIB)
Modified: 2014-05-27 07:18 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the problem (75.26 KB, image/png)
2014-03-27 14:23 UTC, Marina Latini (CIB)
Details
Layout problem on LibO 4.3.0.0.alpha1 (66.79 KB, image/png)
2014-04-29 09:56 UTC, Marina Latini (CIB)
Details
Screenshots after patch for English, Italian, German and French (322.39 KB, application/zip)
2014-05-01 16:58 UTC, Julien Nabet
Details
proposed patch (7.83 KB, patch)
2014-05-01 17:00 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marina Latini (CIB) 2014-03-27 14:23:18 UTC
Created attachment 96458 [details]
Screenshot of the problem

Problem description: 

Steps to reproduce:
1. Launch LibreOffice
2. Go to Tools -> Options -> Language Settings -> English sentence checking 

Current behavior:
The Italian sentences are too long and are truncated under the checkboxes

Expected behavior:
The Italian sentences are correctly visualized.

Error confirmed in LibreOffice versions:
* 4.1.5.3
* 4.2.2.1
* 4.2.3.1
* 4.2.3.2
All the versions (GNU/Linux x86_64 .deb) are directly downloaded from LibreOffice website.

Not tested on previous versions.

              
Operating System: Linux (Other)
Version: 4.1.5.3 release
Comment 1 Julien Nabet 2014-03-27 18:54:15 UTC
There's an ongoing conversion of UI elements.

For the test, could you give a try to 4.2.2 LO version (see https://www.libreoffice.org/download/libreoffice-fresh/) and indicate if you reproduce the problem?
Comment 2 Marina Latini (CIB) 2014-03-27 19:15:23 UTC
I can reproduce the problem in LibO versions (x86_64 .deb):
* 4.1.5.3
* 4.2.2.1
* 4.2.3.1
* 4.2.3.2
Comment 3 Julien Nabet 2014-03-27 19:38:04 UTC
Marina: thank you for your feedback.

I tried to reproduce the problem but it seems this feature is provided by an extension, doesn't it?
Comment 4 Marina Latini (CIB) 2014-03-27 20:14:56 UTC
Hi Julien,

it's my fault, I'll try to explain. You can see the problem only with the Italian UI. The English one works fine. 
You can reproduce the problem when you install LibreOffice with the Italian language pack. Maybe the problem is common also for other languages where the translated sentences are longer then the English one.

I know that there's a conversion of UI elements but I can confirm the problem on all the tested versions.
Comment 5 Julien Nabet 2014-03-27 20:31:40 UTC
Caolán: I thought about master daily build (http://dev-builds.libreoffice.org/daily/master/) But I don't know where are the language packs
Any idea?
Comment 6 Marina Latini (CIB) 2014-03-27 21:10:21 UTC
There aren't language packs for the daily builds.
Only in pre-release http://dev-builds.libreoffice.org/pre-releases/ you can find the help and language packs.
I can try to build LibO from sources and test the new UI :)
Comment 7 Caolán McNamara 2014-03-28 16:58:09 UTC
That page is from the lightproof extension via dictionaries/en/dialog/en.xdl so it's not a layout-enabled page. So it can't be converted to layout to get the goodness of that (not now anyway, maybe in the future we can make layout available to extensions/starbasic)

caolanm->julien/nemeth: There seems to be lots of vertical space, so reworking the .xdl shouldn't be to hard to have three rows of checkboxes at the bottom and say, three or two checkboxes per row elsewhere.
Comment 8 Marina Latini (CIB) 2014-04-29 09:54:22 UTC
Hi all,
I can confirm the same layout problem with:

LibreOffice from .deb packages downloaded from http://dev-builds.libreoffice.org/pre-releases/deb/x86_64/

*LibreOffice 4.3.0.0.alpha1 
*Build ID: 46cfcd5a05aa1d13fecd73f5a25b64b8d8dd6781
*OS: Ubuntu 13.10 x86_64

See the attachment.

Regards,
Marina
Comment 9 Marina Latini (CIB) 2014-04-29 09:56:40 UTC
Created attachment 98171 [details]
Layout problem on LibO 4.3.0.0.alpha1

Screenshot with the layout problem for the version 4.3.0.0.alpha1
Comment 10 Julien Nabet 2014-04-29 14:54:48 UTC
julien->caolanm: If I want to give a try to this bugtracker, should I just add this in autogen.input?
--with-lang="en-us it fr"
or must I add some other options like "--with-myspell-dicts"?
Comment 11 Julien Nabet 2014-04-29 15:03:39 UTC
Even with this slight change 
--with-lang="en-US it fr"

I got this error when running ./autogen.sh

checking which languages to be built... "en-US it fr"
configure: error: invalid language: '"en-US' (vs ''); supported languages are: en-US af am ar as ast be bg bn bn-IN bo br brx bs ca ca-valencia cs cy da de dgo dz el en-GB en-ZA eo es et eu fa fi fr ga gd gl gu he hi hr hu id is it ja ka kk km kmr-Latn kn ko kok ks lb lo lt lv mai mk ml mn mni mr my nb ne nl nn nr nso oc om or pa-IN pl pt pt-BR ro ru rw sa-IN sat sd sr-Latn si sid sk sl sq sr ss st sv sw-TZ ta te tg th tn tr ts tt ug uk uz ve vi xh zh-CN zh-TW zu
Error running configure at ./autogen.sh line 257.

Any idea?
Comment 12 David Tardon 2014-04-30 06:35:11 UTC
(In reply to comment #11)
> Even with this slight change 
> --with-lang="en-US it fr"
> 
> I got this error when running ./autogen.sh
> 
> Any idea?

Yes. Drop the quotes. autogen.sh already quotes whole lines, so this second level of quotes would be passed to configure as if it was a part of the argument. And "en-US locale really does not exist :-)
Comment 13 Julien Nabet 2014-04-30 06:42:41 UTC
(In reply to comment #12)
> (In reply to comment #11)
> > Even with this slight change 
> > --with-lang="en-US it fr"
> > 
> > I got this error when running ./autogen.sh
> > 
> > Any idea?
> 
> Yes. Drop the quotes. autogen.sh already quotes whole lines, so this second
> level of quotes would be passed to configure as if it was a part of the
> argument. And "en-US locale really does not exist :-)

You were right about dropping the quotes (I didn't think autogen could retrieve a list without quotes).
About "en-US", I let it, autogen.sh didn't complain, moreover it's present in the list. Did you mean "en-us"?

Also, must I do a "make clean" before building?
Comment 14 Julien Nabet 2014-04-30 23:35:10 UTC
Ok I added --with-myspell-dicts and now I can see this dialog.
The problem is also on French ui.
Comment 15 Julien Nabet 2014-05-01 16:58:22 UTC
Created attachment 98306 [details]
Screenshots after patch for English, Italian, German and French
Comment 16 Julien Nabet 2014-05-01 17:00:07 UTC
Created attachment 98307 [details]
proposed patch

I read this https://wiki.documentfoundation.org/Development/Dictionaries but I don't know how to submit a patch on gerrit when it doesn't concern core.
There's no logerrit in "Dictionaries" and calling logerrit from Dictionaries doesn't work:
julien@julienPC:~/compile-libreoffice/libreoffice/dictionaries$ ../logerrit submit
no branch specified, and could not guess the current branch
Comment 17 Julien Nabet 2014-05-02 06:29:43 UTC
*** Bug 72669 has been marked as a duplicate of this bug. ***
Comment 18 Julien Nabet 2014-05-02 06:31:45 UTC
The dup shows it's been there since 4.1.3.2.
(I suppose it's been there even before 4.1.3.2 but let's let like this for the moment)
Comment 19 Commit Notification 2014-05-07 14:11:06 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/dictionaries/commit/?id=d478664ac0a8e8997d8d17a76a39d2704f7a254d

Resolves: fdo#76692 LightProof: Italian translation too long in options



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2014-05-07 14:13:41 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/dictionaries/commit/?id=06217fb7e4e03bca013563558c61cc10b8437eb7&h=libreoffice-4-2

Resolves: fdo#76692 LightProof: Italian translation too long in options


It will be available in LibreOffice 4.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 21 Marina Latini (CIB) 2014-05-27 07:18:13 UTC
Fix VERIFIED on:

* Version: 4.3.0.0.beta1
* Build ID: 2e39c7e59c8fc8b16a54c3d981dceef27fb0c07f
* OS: Ubuntu 13.10 x86_64
with fresh user profile and Italian langpack and helppack