Download it now!
Bug 78526 - Other: Some problem on display of Hungarian sentence checking (German)
Summary: Other: Some problem on display of Hungarian sentence checking (German)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.6.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.4.0 target:4.3.0.2
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-10 12:09 UTC by Julien Nabet
Modified: 2014-06-21 06:32 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the problem in German UI (88.01 KB, image/png)
2014-05-10 12:09 UTC, Julien Nabet
Details
Proposition (with German UI) (112.81 KB, image/png)
2014-05-21 19:18 UTC, Julien Nabet
Details
Proposition with screenshots in different languages (620.03 KB, application/x-bzip)
2014-05-21 21:01 UTC, Julien Nabet
Details
Modified version of Julien's screenshot (103.81 KB, image/png)
2014-06-07 09:21 UTC, Stefan Knorr (astron)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Nabet 2014-05-10 12:09:34 UTC
Created attachment 98819 [details]
Screenshot of the problem in German UI

Problem description: 
With German UI, not only with this localization, some options don't display entirely

Steps to reproduce:
1. Open Writer
2. Tools/Options/Language Settings
3. Hungarian sentence checking

Current behavior:
Some options on Portuguese gramar corrector don't display entirely.

Expected behavior:
Every option should display entirely
              
Operating System: Debian
Version: 4.3.0.0.alpha1
Comment 1 Julien Nabet 2014-05-11 11:57:36 UTC
Caolan: Some lines have 4 options and we could put 2 per row but some lines have a problem with only 2 options per row and we don't have enough room to put 1 option per line. Any idea?
(dictionaries/hu_HU/dialog/hu_HU.xdl)
Comment 2 Caolán McNamara 2014-05-19 13:04:55 UTC
Would we get away with three columns (instead of four) for Typography, would that not-collide and allow enough space for extra rows in Korrektur (perhaps making one row of the three little short ones to fit them in if necessary)
Comment 3 Joel Madero 2014-05-20 04:04:50 UTC
Marking as NEW as it appears like this one is confirmed. Might want to get UX involved but you two seem to have it under control :-D
Comment 4 Joel Madero 2014-05-20 04:05:46 UTC
Oh - also is this new to 4.3? If not it would be nice to get a more accurate version number (I know I'm nit picky ;) )
Comment 5 Julien Nabet 2014-05-20 19:23:10 UTC
Joel: At least 4.1.6 since git log -1 hu_HU/dialog/hu_HU.xdl gives:
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sat Sep 1 09:50:26 2012 -0500

    move dictionaries structure one directory up
    
    Change-Id: I70388bf6b95d8692cc6f25fc5a9c7baf3a675710
Comment 6 Julien Nabet 2014-05-21 19:18:24 UTC
Created attachment 99534 [details]
Proposition (with German UI)

I think we may split the first row of Korrektur in 3 rows since there should be enough room. But it won't let room for other options.
Comment 7 Julien Nabet 2014-05-21 19:30:04 UTC
Stefan/Alexander/Christoph: I attached a proposition of layout + explain some choice. Any feedback?
Comment 8 Julien Nabet 2014-05-21 19:33:17 UTC
Comment on attachment 99534 [details]
Proposition (with German UI)

Damn, there's a pb with French UI :-(
Comment 9 Julien Nabet 2014-05-21 21:01:18 UTC
Created attachment 99537 [details]
Proposition with screenshots in different languages

This time, I tested:
- German
- French
- English
- Italiano
- Spanish
- Dutch
- Hungarish (hopefully! :))
Comment 10 Julien Nabet 2014-06-05 11:28:41 UTC
Any update here? May I submit for review the patch?
Comment 11 Stefan Knorr (astron) 2014-06-06 07:40:20 UTC
Given that someone will add another option eventually which would then cause another complete redesign, why not go for a list view similar to that on LibreOffice > Appearance?
Comment 12 Stefan Knorr (astron) 2014-06-06 07:41:34 UTC
(Also, sorry for me taking so long to take a look at this bug.)
Comment 13 Julien Nabet 2014-06-06 11:48:00 UTC
Stefan: thank you for your feedback. I must recognize I know too few about xdl to know if it's even possible to do it. But if it's possible, I indeed wouldn't bother putting several items in the same row and therefore put 1 option/1 row :-)
I'll try to take a look.
Comment 14 Julien Nabet 2014-06-06 23:46:49 UTC
I took a look in xmlscript/dtd/dialog.dtd but didn't find a way to do this :(
Comment 15 Stefan Knorr (astron) 2014-06-07 09:21:26 UTC
Created attachment 100592 [details]
Modified version of Julien's screenshot

Okay, if an embedded box is hard to do for now, I think you should just resolve obvious truncation problems.
Above is a mockup that is derived from one of your screenshots. As you can see, the only difference is, that for aesthetic reasons, the second category now features only a single column of option. Would be great if you could arrange that, otherwise I would be fine with your patch.

I will open a new bug for a longer-term redesign of these option pages.
Comment 16 Stefan Knorr (astron) 2014-06-07 09:54:27 UTC
Opened bug 79764 for the redesign.
Comment 17 Commit Notification 2014-06-07 11:55:17 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/dictionaries/commit/?id=ad4dea48c420f123afa083ac5cc4b12287c9c17f

Resolves: fdo#78526 Some problem on display of Hungarian sentence checking



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 18 Julien Nabet 2014-06-07 13:36:41 UTC
I can't gerrit submit the change for 4.3 and 4.2
I got this error:
no branch specified, guessing current branch libreoffice-4-3
Décompte des objets: 8054, fait.
Delta compression using up to 4 threads.
Compression des objets: 100% (2646/2646), fait.
Écriture des objets: 100% (8054/8054), 107.29 MiB | 103.00 KiB/s, fait.
Total 8054 (delta 4682), reused 7861 (delta 4576)
remote: Resolving deltas: 100% (4682/4682)
remote: Processing changes: refs: 1, done    
To ssh://logerrit/core
 ! [remote rejected] HEAD -> refs/for/libreoffice-4-3 (no common ancestry)
error: impossible de pousser des références vers 'ssh://logerrit/core'

(impossible to push references)

Moreover, I'm trying some tests but gerrit is very long.
If somoneone wants to cherry-pick... As for me, I give up.
Comment 19 Commit Notification 2014-06-21 06:28:35 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/dictionaries/commit/?id=01d651ba47f78681a863548690d8da73cf5af18d&h=libreoffice-4-3

Resolves: fdo#78526 Some problem on display of Hungarian sentence checking


It will be available in LibreOffice 4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2014-06-21 06:31:15 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/dictionaries/commit/?id=4941ec64e84e41bc461c5641c6a783a339f08102&h=libreoffice-4-3

Revert "Resolves: fdo#78526 Some problem on display of Hungarian sentence checking"


It will be available in LibreOffice 4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 21 Julien Nabet 2014-06-21 06:32:14 UTC
Sorry I had pushed it instead of submitting for review, so I reverted this.
(still stuck to put the patch for review on 4.3/4.2 branches)
Anyway, let's put this one to FIXED.