Download it now!
Bug 78557 - PRINTING svg graphic not printed (to pdf)
Summary: PRINTING svg graphic not printed (to pdf)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha1
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 78871 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-11 16:10 UTC by Cor Nouws
Modified: 2015-02-18 21:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
text file with three versions of the graphic (27.21 KB, application/vnd.oasis.opendocument.text)
2014-05-11 16:10 UTC, Cor Nouws
Details
png with screenshot of two pdf's (44.41 KB, image/png)
2014-05-11 16:12 UTC, Cor Nouws
Details
LinuxMint Screenshot (131.21 KB, image/png)
2014-06-16 19:21 UTC, Matthias Blümel
Details
LinuxMint Screenshot with ppa (111.19 KB, image/png)
2014-06-16 19:51 UTC, Matthias Blümel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2014-05-11 16:10:17 UTC
Created attachment 98858 [details]
text file with three versions of the graphic

Attached a file with three graphics.
First is the original one, an svg
Second and third are jpg/png

Export to PDF in 4.2.0.alpha1 and higher: svg graphic not visible
Export in 4.1.5.x > svg is visible
Comment 1 Cor Nouws 2014-05-11 16:12:52 UTC
Created attachment 98859 [details]
png with screenshot of two pdf's
Comment 2 Cor Nouws 2014-05-11 16:13:25 UTC
Was OK in 4.1.5 > regression
Comment 3 Cor Nouws 2014-05-19 06:48:02 UTC
*** Bug 78871 has been marked as a duplicate of this bug. ***
Comment 4 Tomaz Vajngerl 2014-05-19 15:44:55 UTC
Hey Cor,

I tried this in master and it works as expected.
Comment 5 Matthias Blümel 2014-06-16 19:21:18 UTC
Created attachment 101187 [details]
LinuxMint Screenshot

I can confirm this with the current version in Ubuntu trusty 14.04 and LinuxMint Qiana 17

http://packages.ubuntu.com/trusty/libreoffice
Comment 6 Matthias Blümel 2014-06-16 19:51:20 UTC
Created attachment 101192 [details]
LinuxMint Screenshot with ppa

The Version from the libreoffice ppa works.

https://launchpad.net/~libreoffice/+archive/libreoffice-4-2

Someone should file a bug for ubuntu – mayme I, but tomorrow
Comment 7 Cor Nouws 2014-06-22 09:24:30 UTC
(In reply to comment #4)

> I tried this in master and it works as expected.


Tried now, and it works fine again in 4.2.5.2 and 4.3.0.1 :)

Lovely anonymous fixer - thanks :)