Download it now!
Bug 78672 - FILEOPEN Import SVG crops content
Summary: FILEOPEN Import SVG crops content
Status: RESOLVED DUPLICATE of bug 78554
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.6.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2014-05-13 19:28 UTC by earl_chew
Modified: 2015-12-15 11:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example SVG that is imported incorrectly (18.65 KB, image/svg+xml)
2014-05-13 19:28 UTC, earl_chew
Details
Outcome with Firefox displaying the SVG correctly, but Libreoffice cropped (74.08 KB, image/jpeg)
2014-05-13 19:32 UTC, earl_chew
Details
svg in 3.6 (59.97 KB, image/jpeg)
2014-05-26 14:05 UTC, Yousuf Philips (jay) (retired)
Details
svg in 4.1 (67.87 KB, image/jpeg)
2014-05-26 14:06 UTC, Yousuf Philips (jay) (retired)
Details
svg in 4.3 (57.83 KB, image/jpeg)
2014-05-26 14:06 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description earl_chew 2014-05-13 19:28:00 UTC
Created attachment 98994 [details]
Example SVG that is imported incorrectly
Comment 1 earl_chew 2014-05-13 19:32:12 UTC
Created attachment 98995 [details]
Outcome with Firefox displaying the SVG correctly, but Libreoffice cropped
Comment 2 earl_chew 2014-05-13 19:33:40 UTC
To reproduce:

1. Start Libreoffice Impress/Presentation
2. Import Picture

The imported picture appears cropped, and the content cannot be recovered by adjusting cropping or resizing parameters.
Comment 3 earl_chew 2014-05-13 19:37:07 UTC
Attempted on LibreOffice 4.1.3.2 Build 410m0(Build 2) Ubuntu 13.10, and also LibreOffice 4.1.4.2 Build 0a0440ccc0227ad9829de5f46be37cfb6edcf72  OSX 10.9.2
Comment 4 Firas Hanife 2014-05-26 11:58:13 UTC
I can reproduce this issue with LibreOffice 4.1.6.2, the SVG is cropped. The same file is correctly opened in Inkscape.


Tested also with
Version: 4.3.0.0.beta1
Build ID: 2e39c7e59c8fc8b16a54c3d981dceef27fb0c07f
and the SVG is loaded even worse, it is not visible. If a Shadow is applied some details of the SVG are visible.
Comment 5 Yousuf Philips (jay) (retired) 2014-05-26 14:02:54 UTC
Confirmed in Linux Mint. The import works fine in 3.6, in 4.0 and 4.1 it gets cropped, and 4.2 and 4.3, it is blank.
Comment 6 Yousuf Philips (jay) (retired) 2014-05-26 14:05:56 UTC
Created attachment 99869 [details]
svg in 3.6
Comment 7 Yousuf Philips (jay) (retired) 2014-05-26 14:06:17 UTC
Created attachment 99870 [details]
svg in 4.1
Comment 8 Yousuf Philips (jay) (retired) 2014-05-26 14:06:37 UTC
Created attachment 99871 [details]
svg in 4.3
Comment 9 Xisco Faulí 2014-05-29 12:32:11 UTC
bibisected:

0acca754077bf74469c3e1a3c7eabbc3da795266 is the first bad commit
commit 0acca754077bf74469c3e1a3c7eabbc3da795266
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Mon May 12 12:04:53 2014 +0000

    source-hash-5e651d4084df7662b56ea980934c0428ba31b062
    
    commit 5e651d4084df7662b56ea980934c0428ba31b062
    Author:     Caolán McNamara <caolanm@redhat.com>
    AuthorDate: Tue Apr 15 21:08:13 2014 +0100
    Commit:     Caolán McNamara <caolanm@redhat.com>
    CommitDate: Wed Apr 16 11:23:13 2014 +0100
    
        coverity#1202948 Uninitialized pointer field
    
        Change-Id: I2764b1f9c3d50cf7ff7bd2c552a3dec93509b245

:100644 100644 42123dfbed90154f94f2f1dc8eacf21ed9bf155e 0d2db29f9ae8626eca4aa470157737cc2fffcde0 M	autogen.log
:100644 100644 0c1402c4f181927b2de7b580b596a19c454ff44b 76dfad2a19c6025ab1ff32510e73930f97ae063f M	ccache.log
:100644 100644 3c2e4c5380217c309eb8ca87b2e009760a2e4e9c c60fabab11f976674ac5611f37cba9ef49405589 M	commitmsg
:100644 100644 3b4121c32f82a582e7375c90656c26d59b1d9e61 645384f6ca01eb832351e51b21a3e68e798177f0 M	make.log
:040000 040000 e411e8188872ccf6a50816da7de0ce184071ca16 c66ac4ae3cd31ba3fa723f1ef8376310723747ec M	opt

# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574
# good: [4850941efe43ae800be5c76e1102ab80ac2c085d] source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b
git bisect good 4850941efe43ae800be5c76e1102ab80ac2c085d
# good: [a900e72b6357882284c5955bdf939bf14269f5fb] source-hash-dd1050b182260a26a1d0ba6d0ef3a6fecc3f4e07
git bisect good a900e72b6357882284c5955bdf939bf14269f5fb
# skip: [e80660c5a1d812cd04586dae1f22767fc3778c4a] source-hash-07c60c8ee2d1465544a6a39e57bc06b3690b8dfb
git bisect skip e80660c5a1d812cd04586dae1f22767fc3778c4a
# good: [df9bcaed2faa2a8d11b19f877cdff3a12a887278] source-hash-6ba9692d8bbe3e3c245aca9a7c928e81178d05f1
git bisect good df9bcaed2faa2a8d11b19f877cdff3a12a887278
# bad: [741197a13a361480f59eeb3bd1401f984f49f1c0] source-hash-9a61470eb1fa161cba70f2e9c4ea8817dc7f617e
git bisect bad 741197a13a361480f59eeb3bd1401f984f49f1c0
# skip: [60da347518798811f7adbfbf1eb07d59cd9f08bf] source-hash-28fc951233a58fb4d8515ed4380140aaee0afd32
git bisect skip 60da347518798811f7adbfbf1eb07d59cd9f08bf
# bad: [0acca754077bf74469c3e1a3c7eabbc3da795266] source-hash-5e651d4084df7662b56ea980934c0428ba31b062
git bisect bad 0acca754077bf74469c3e1a3c7eabbc3da795266
# good: [465e2be02951f9645beb3024506a5212907caf5f] source-hash-674801eb4af21c9ae83c122499f15fa4f4785b0f
git bisect good 465e2be02951f9645beb3024506a5212907caf5f
# first bad commit: [0acca754077bf74469c3e1a3c7eabbc3da795266] source-hash-5e651d4084df7662b56ea980934c0428ba31b062
Comment 10 Xisco Faulí 2014-06-05 11:23:51 UTC
it looks like the empty image regression was introduced by 3b7472b284131c09d91b69f26d5d26d54648f939. I'll ping the developer
Comment 11 Xisco Faulí 2014-07-16 08:28:10 UTC
Following commit fixes this issue as well:
Joren De Cuyper committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f6df52aa3aad9c7650b6ca051d9a28c4ccb6a060

fdo#78554 - SVG: Text from SVG no longer displayed in LibreOffice

Mark it as duplicated and close it.

*** This bug has been marked as a duplicate of bug 78554 ***
Comment 12 Robinson Tryon (qubit) 2015-12-15 11:03:30 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]