Bug 78777 - Keyboard shortcut for format as Currency and Date on OSX used by system for screenshot
Summary: Keyboard shortcut for format as Currency and Date on OSX used by system for s...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.6.2 release
Hardware: Other Mac OS X (All)
: medium minor
Assignee: Heiko Tietze
URL:
Whiteboard: BSA target:6.1.0
Keywords:
Depends on: 34704
Blocks: MacOS-Wishlist
  Show dependency treegraph
 
Reported: 2014-05-16 09:52 UTC by Eva
Modified: 2018-04-16 18:13 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eva 2014-05-16 09:52:10 UTC
Problem description: 
Mac Problem: This combination is used for making a picture of a selected area.
Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior:
The combination does not work to change numbers into the currency Euro.
Expected behavior:
A combination to change into the currency Euro. cmd+4 is free :o)

              
Operating System: Mac OS X
Version: 4.1.6.2 release
Comment 1 Alex Thurgood 2014-09-30 09:25:23 UTC
I'm sorry, what do you mean by "changing numbers to the Euro currency" ?
Comment 2 Eva 2014-09-30 10:25:39 UTC
HI Alex,

with the combination "Shift+cms+4" you can make a picture of the window 
under mac. But as long as this combination changes numbers into the 
currency euro, you can’t use it any longer to make a picture of the 
window. What you could do is, that you should leave the combination 
free and change the combination for this currency change :o) I hope 
that you understand what I mean. My English is not so good, sorry.

Take care
Eva

Lächeln ist ein Miniurlaub für die Seele ;o)


-----Ursprüngliche Mitteilung-----
Von: bugzilla-daemon <bugzilla-daemon@freedesktop.org>
An: eva.friedrich2 <eva.friedrich2@aol.com>
Verschickt: Di, 30 Sept 2014 11:25 am
Betreff: [Bug 78777] FORMATTING: Combination Shift+cmd+4 (Currency: 
Euro)

                  " Alex Thurgood changed              bug 78777
                                    What            Removed            
Added                              Status           UNCONFIRMED         
              NEEDINFO                                        Ever 
confirmed                                                 1             

                     Comment # 1              on bug 78777              
 from " Alex Thurgood        I'm sorry, what do you mean by "changing 
numbers to the Euro currency" ?
                   You are receiving this mail because:                  
    You reported the bug.
Comment 3 Buovjaga 2014-11-27 10:47:48 UTC
Setting to UNCONFIRMED.
Comment 4 Alex Thurgood 2014-12-01 10:42:55 UTC
Hi Eva,

Testing with LO 4400 alpha 2 :

1) Open a new Calc document
2) Type in some data
3) Press Shift Cmd 4

Expected : screenshot definable by user dragging mouse to define capture area
Obtained : screenshot definable by user dragging mouse to define capture area

So this worksforme on my Macbook. The key combo doesn't attempt to convert the cell format to Euro monetary currency.

So I can not reproduce your problem.
Comment 5 Alex Thurgood 2014-12-01 10:45:53 UTC
Okay, so are you saying that Euro currency cell formatting style doesn't work with the Apple OS-defined keyboard shortcut ? If so, I agree.
Comment 6 Alex Thurgood 2014-12-01 10:49:18 UTC
Confirming that LO shouldn't use OSX predefined shortcuts to apply formatting styles.
Comment 7 QA Administrators 2015-12-20 16:05:13 UTC Comment hidden (obsolete)
Comment 8 Alex Thurgood 2015-12-21 07:53:24 UTC
Confirming on

Version: 5.2.0.0.alpha0+
Build ID: ce3d3f5543e3e132a3473af27aa2c827336add0f
CPU Threads: 2; OS Version: -; UI Render: default; 
Locale : fr-FR (fr.UTF-8)
Comment 9 Alex Thurgood 2015-12-21 07:59:36 UTC
Steps to reproduce :

1) Open a Calc document
in cell A1 type 23,45 (French UI / locale) press enter
in cell B1 type 76,89 (Fren UI /locale) press enter

2) Select both cells with the mouse / cursor keys
3) Press the keyboard shortcut - Shift+Cmd+4

What happens in Linux : the automatic number format Euro currency is applied
What happens in Mac : the OSX screenshot utility is activated.

Steps needed to correct this behaviour : LO should not try to assign system OS shortcuts to internal functions as these will fail on OSX. There is thus no shortcut for LibreOffice on OSX that allows this currency format to be applied quickly.
Comment 10 QA Administrators 2017-01-03 19:54:38 UTC Comment hidden (obsolete)
Comment 11 eisa01 2017-10-20 22:16:16 UTC
Still present, cmd+shift+4 is a system shortcut used for screenshots, and can not be used to format as currency

Raising importance as keyboard shortcuts are crucial for professionals. This also applies to format as date (cmd+shift+3, also screenshots)

I think the UX team needs to take a look at this
Comment 12 Heiko Tietze 2017-10-23 19:17:40 UTC Comment hidden (no-value)
Comment 13 Heiko Tietze 2018-04-11 10:29:05 UTC
Shift+cmd+1,2,3,4,5,6 are assigned to the different value formats (3,4,6 are assigned to screenshots). We can go with 

a) Shift+alt+1..6, 
b) modify it to 1,2,5,7,8,9, or
d) keep them empty for user customization. 

What would a macOS user prefer?
Comment 14 Buovjaga 2018-04-11 11:02:07 UTC
No dispute over confirming, so NEEDINFO is incorrect status
Comment 15 Heiko Tietze 2018-04-14 07:43:16 UTC
Comment received per mail votes for a).
Comment 16 eisa01 2018-04-14 11:33:54 UTC
Was just commenting on this, shift+alt can not be used as that is used to type symbols on a mac

---

Mac Excel uses ctrl+shift+different keys for the formatting, and the alt+shift combo is actually used to type signs like ¡®¥¢‰¶, so it should be ctrl+shift that is used.

Numbers don't have shortcuts for this.

Excel uses the following (in parantheses the key it represents on a mac US keyboard layout)
Apply the general number format: ~ (key above tab) 
Apply the currency format with two decimal places (negative numbers appear in red with parentheses): $ (4)
Apply the percentage format with no decimal places: % (5)
Apply the exponential number format with two decimal places: ^ (6)
Apply the date format with the day, month, and year: # (3)
Apply the time format with the hour and minute, and indicate AM or PM: @ (2)
Apply the number format with two decimal places, thousands separator, and minus sign (-) for negative values: ! (1)

So the logic is to use the first 7 keys on the top row with logical placement according to the signs (e.g., percent symbol to format as percent)

Is it possible to localize the shortcuts? It can be quite annoying that keyboard layouts differ, and then the US keyboard logic fails. E.g., ~ is not on a Norwegian keyboard, you have to press alt+^ next to the return key to type it.

If the shortcuts are defined with numbers instead of the symbol you actually type when holding down the shift key, then it is easier, and just an issue with the general number format.
Comment 17 Commit Notification 2018-04-14 12:36:26 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=eb6531dcb19e61baff69356eda5fd7f2a5d46458

tdf#78777 - Keyboard shortcut for number format interfers with macOS defaults

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Heiko Tietze 2018-04-14 12:39:34 UTC
Shortcuts are now assign by default to Shift+Alt+1..6
Comment 19 eisa01 2018-04-14 12:41:48 UTC
Sorry for being late in giving input on this, but the commit should be reverted and the shortcut be made the same as Windows/Linux to use ctrl+shift. Otherwise we will have bug reports from users who can't type ¡, ®, ¥, ¢, ‰, ¶ (which would be a valid new bug)
Comment 20 Heiko Tietze 2018-04-14 12:54:15 UTC
(In reply to eisa01 from comment #19)
> Sorry for being late in giving input on this, but the commit should be
> reverted and the shortcut be made the same as Windows/Linux to use
> ctrl+shift. Otherwise we will have bug reports from users who can't type ¡,
> ®, ¥, ¢, ‰, ¶ (which would be a valid new bug)

On my German keyboard it's ¬ ” # £ fi ^ for shift+opt+1..6.

Reverting is not an option. If you find people agreeing on the premise of being able to type very special characters over having a shortcut for number format I will clear the assignment (option c) from comment 13). Otherwise the workaround is to use the special character dialog.
Comment 21 eisa01 2018-04-14 13:09:06 UTC
(In reply to Heiko Tietze from comment #20)
> Reverting is not an option. If you find people agreeing on the premise of
> being able to type very special characters over having a shortcut for number
> format I will clear the assignment (option c) from comment 13). Otherwise
> the workaround is to use the special character dialog.

The other option would be to use ctrl+shift which is what LO Win/Linux already uses, and what Mac Excel also uses. Being consistent across platforms would be even friendlier for users as it increases the discoverability of the shortcuts ;)

And it still enables entry of special symbols

(I fundamentally disagree that alt+shift is a good option for Mac as it breaks entry of these symbols and leaves LO as a second class citizen on Mac)

I know we're all volunteers here with limited time on our hands, so if you don't feel like prioritizing this, I can see if I can find the time to write the patch (didn't seem too complicated) in the coming weeks :)
Comment 22 Heiko Tietze 2018-04-14 18:06:07 UTC
(In reply to eisa01 from comment #21)
> The other option would be to use ctrl+shift which is what LO Win/Linux...

Shift+cmd+1..6 are mostly occupied by shortcut functions, that's why the issue was filed. And those shortcuts are more known and used than very special characters.
Comment 23 steve -_- 2018-04-15 20:46:04 UTC
Read through the bug, no strong feelings on this as I personally do not use this, but agree with eisa01:

- shift+alt+1-6 not good since it
     - alters platform compatibility
     - overwrites existing functionality

So shift+ctrl+1-6 would be the better solution.

Disclaimer: I am not an expert on shortcuts :)

But I take the liberty to re-open this to NEW. Hope that is ok.

@Heiko if you strongly disagree, feel free to revert to fixed. Not sure about your comment 22, since you talk about shift+cmd+1-6 but eisa01 suggested shift+ctrl+1-6
Comment 24 Heiko Tietze 2018-04-15 20:50:05 UTC
(In reply to steve -_- from comment #23)
> @Heiko if you strongly disagree, feel free to revert to fixed. Not sure
> about your comment 22, since you talk about shift+cmd+1-6 but eisa01
> suggested shift+ctrl+1-6

Yes, I do. Ctrl=Cmd, shortcuts are universally assigned to those shortcuts.
Comment 25 eisa01 2018-04-15 21:18:38 UTC
Yes, cmd is the equivalent to Ctrl on Mac.

But, there can still be valid reasons for deviating which LO Mac already does:
The shortcut for selecting a row is ctrl+space across all platforms as Cmd+space is used for spotlight on Mac (not all localizations). MOD3 would indicate the Ctrl key on Mac in the accelerator configuration as far as I can tell

Aside, alt (option) key shortcuts are not standard at all on Macs.
They’re sometimes used together with cmd, but I can not recall any shortcut using option standalone in my life as a Mac user

In fact, the option key is used for special signs, with and without shift
Comment 26 Heiko Tietze 2018-04-15 21:45:24 UTC
For clarification: we can use ctrl/cmd = mod1 and alt = mod2 but not the mac ctrl key. At least not out of the box.
Comment 27 Heiko Tietze 2018-04-16 08:51:56 UTC
Thanks for the tip with MOD3. That works (patch is submitted), though it breaks customization a bit (bug 34704) and the tooltip shows the alt symbol. I'll look into the issue.
Comment 28 Heiko Tietze 2018-04-16 11:34:16 UTC
New patch at https://gerrit.libreoffice.org/#/c/52966/
(customization for ctrl and correct symbol also submitted)
Comment 29 Commit Notification 2018-04-16 18:12:03 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a616d1e52fdf5f5ace39f8d706d89f4d28228dec

tdf#78777 - Keyboard shortcut for number formatting on macOS

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 30 Heiko Tietze 2018-04-16 18:13:23 UTC
Shortcuts are not the macOS ctrl (^) + shift + 1..6