Download it now!
Bug 79126 - EDITING: Form-Wizard: choosing styles like background-color impossible with a timestamp-field in the datasource of the form
Summary: EDITING: Form-Wizard: choosing styles like background-color impossible with a...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.5.0
Keywords:
Depends on: 71027
Blocks:
  Show dependency treegraph
 
Reported: 2014-05-23 14:28 UTC by José Reinaldo
Modified: 2014-12-26 16:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Text produced in the sdout when libreoffice is executed from a command line (5.07 KB, text/plain)
2014-05-23 14:28 UTC, José Reinaldo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description José Reinaldo 2014-05-23 14:28:33 UTC
Created attachment 99643 [details]
Text produced in the sdout when libreoffice is executed from a command line

Problem description: The Wizard process doesn't obey the styles choosed when building a new form(and controls) from a table

Steps to reproduce:
1. Open(or create) a database file
2. Create a table
3. Use the wizard to generate a form from the created table

Current behavior: It makes a mass in the styles of the forms

Expected behavior: To build the form using the choosed styles for forms and controls 
              
Operating System: Linux (Other)
Version: 4.2.2.1 release
Comment 1 Robert Großkopf 2014-05-23 18:49:04 UTC
Have tested the same version with OpenSUSE 12.3 64bit rpm Linux. No problem to create a normal form with any style.
The style of a form with a timestamp-field could not be changed by the wizard. But this is one part of
https://bugs.freedesktop.org/show_bug.cgi?id=71027
Comment 2 José Reinaldo 2014-05-23 20:38:06 UTC
Thank you Robert
I tested with tables from other database and I didn't have problem.
You wrote something about time-stamp field. The problem has occurred with tables who has a time-stamp field.
Can this to be the problem?
Comment 3 Robert Großkopf 2014-05-24 07:28:51 UTC
Hi José,

did you get a crash while creating a form with the wizard and time-stamp-fields or couldn't you change the style?
I am able to create a form and have to change the style later, when there is a time-stamp-field inside the table.
If you could also create a form with the wizard, but without styles when there is a time-stamp-field, we should set this bug to New and change the title a little bit.
Comment 4 José Reinaldo 2014-05-24 13:01:58 UTC
Hi Robert,

In the old version of Libreoffice it crashed. In this version I can create the form and, after, I have to change the styles. 
Only one correction: They are date/time fields and not time-stamp fields. Sorry
Comment 5 Robert Großkopf 2014-05-24 18:33:14 UTC
Hi José,

a date/time-field in the table is splitted into two fields in a form. This fields are called TIMESTAMP-fields in the table-editor.

Only with this two fields in a form it is impossible to change the style and sometimes it seems to be a problem to change a layout like tablecontrol or ordered textfields. This problem has been solved here: https://bugs.freedesktop.org/show_bug.cgi?id=70674

Let us try to set the bug to new and change the title.
Comment 6 Julien Nabet 2014-12-26 16:26:48 UTC
After the Lionel's fixes made for fdo#87301, this one should be  fixed right now (with recent daily build from master sources).
If I'm wrong and so someone reproduces this problem, please don't hesitate to reopen this tracker.