Download it now!
Bug 87301 - EDITING: Form-wizard doesn't show background-styles
Summary: EDITING: Form-wizard doesn't show background-styles
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.4.0.0.beta1
Hardware: All All
: medium normal
Assignee: Lionel Elie Mamane
URL:
Whiteboard: target:4.5.0
Keywords:
: 49048 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-12-14 10:54 UTC by Robert Großkopf
Modified: 2014-12-26 16:24 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2014-12-14 10:54:01 UTC
Opened a database with 
Version: 4.4.0.0.beta1+
Build ID: a15a538fb191b1851f366716914822411b583c58
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-4-4, Time: 2014-12-03_06:05:11
Locale: de_DE
Started the form-wizard to create a form.
When reaching "7. Apply styles" there arent shown any colors of the background of the form and of the controls. All leaves blank.
Form could be saved as expected, but without colors.
Comment 1 Jacques Guilleron 2014-12-14 13:30:44 UTC
Hi robert,

I reproduce with 
LO 4.5.0.0.alpha0+ Build ID: 736b040cb158308e002d24cee8c33e794b2f59a1
TinderBox: Win-x86@39, Branch:master, Time: 2014-12-01_15:20:47 Locale: fr_FR
& Windows 7 Home Premium

but not with
LO 4.3.4.1 Build ID: bc356b2f991740509f321d70e4512a6a54c5f243

Regards,

Jacques
Comment 2 Julien Nabet 2014-12-16 20:29:35 UTC
Here are some interesting console logs:
[jni_uno bridge error] UNO calling Java method itemStateChanged: non-UNO exception occurred: java.lang.NullPointerException
java stack trace:
java.lang.NullPointerException
	at com.sun.star.wizards.form.StyleApplier.setDBControlColors(StyleApplier.java:360)
	at com.sun.star.wizards.form.StyleApplier.applyDBControlProperties(StyleApplier.java:409)
	at com.sun.star.wizards.form.StyleApplier.changeLayout(StyleApplier.java:228)

Noel: taking a look to git history of wizards/com/sun/star/wizards/form/StyleApplier.java, I thought you might be interested in this one.
Comment 3 Julien Nabet 2014-12-16 20:41:36 UTC
I noticed that if you don't change the default value of the form at step 5, the color can be changed in step 7.
But above all, the console logs from my previous comment appears as soon as yu change form type at step 5, then it appears again in step 7 each time you try to change the color.
Comment 4 Julien Nabet 2014-12-16 20:58:49 UTC
I just noticed this first error console log:
java.lang.NullPointerException
	at com.sun.star.wizards.common.Helper.setUnoPropertyValue(Helper.java:46)
	at com.sun.star.wizards.form.FormControlArranger.insertDBControl(FormControlArranger.java:628)
	at com.sun.star.wizards.form.FormControlArranger.positionControls(FormControlArranger.java:351)
	at com.sun.star.wizards.form.FormDocument$ControlForm.initialize(FormDocument.java:405)
	at com.sun.star.wizards.form.UIControlArranger$ArrangeButtonList.itemStateChanged(UIControlArranger.java:270)
	at com.sun.star.wizards.ui.ButtonList.fireItemSelected(ButtonList.java:409)
	at com.sun.star.wizards.ui.ButtonList.setSelected(ButtonList.java:527)
	at com.sun.star.wizards.ui.ButtonList.actionPerformed(ButtonList.java:719)
Comment 5 Julien Nabet 2014-12-17 22:48:28 UTC
I fixed locally the last error quoted but it doesn't solve the problem.
So it must be the first error quoted.
I'll give a try.
Comment 6 Julien Nabet 2014-12-18 23:28:08 UTC
Lionel: I submitted a patch for review, thought you might be interested in this one:
https://gerrit.libreoffice.org/13535
Comment 7 Lionel Elie Mamane 2014-12-19 12:34:17 UTC
Can reproduce only if field selection (step 1) contains a timestamp field.
Comment 8 Lionel Elie Mamane 2014-12-19 12:35:46 UTC
(In reply to Lionel Elie Mamane from comment #7)
> Can reproduce only if field selection (step 1) contains a timestamp field.

But then, I can also reproduce that with 4.3.6.0.0+, so maybe that's a different bug, since Jacques says he can reproduce with master but not with 4.3.4.1! Robert, Jacques, do your reproduction examples include a timestamp field? Could you attach them here?
Comment 9 Julien Nabet 2014-12-19 13:17:58 UTC
Lionel: try too to change the default form layout.
Indeed, if you don't change the default form layout everything works with LO Debian package 4.3.3 (I must retest but I think that even with timestamp field), see my previous comments with main part of stacktraces.

Anyway, I'm building 4.3 sources and so will give a try tomorrow.
Comment 10 Lionel Elie Mamane 2014-12-19 13:27:46 UTC
(In reply to Julien Nabet from comment #9)
> Lionel: try too to change the default form layout.

Yes, I saw that in your comment and I am indeed changing the form layout.
Comment 11 Robert Großkopf 2014-12-19 18:54:53 UTC
Have tested it again with version: 4.4.0.1
Build-ID: 1ba9640ddd424f1f535c75bf2b86703770b8cf6f
Gebietsschema: de_DE
The background-styles did appear in this version.

So I tested again with version: 4.4.0.0.beta2
Build-ID: be92f32b8f21603a6b7a75dd645f7475bdee519d
Gebietsschema: de_DE
and a new user-profile vor the dev-version. The background-styles werden't shown.

The table hasn't any timestamp-field, only a date-field.

Don't know why the bug disappears with LO 4.4.0.1. Should we set this to "Worksforme" or is there anybody who could still reproduce?
Comment 12 Commit Notification 2014-12-19 22:37:20 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=68f65c4c08a8804b9a28b926c2a08cee486b60e9

fdo#87301 don't rely on the shape to get the control

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2014-12-19 22:37:24 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a983fb0f7c7b94d0771d277777035254acce093f

Revert "fdo#87301 don't rely on the shape to get the control"

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Lionel Elie Mamane 2014-12-19 23:09:40 UTC
I did many fixes in/for the Form wizard.

This bug was corrected anyway somewhere in the unknown past...
Comment 15 Julien Nabet 2014-12-20 09:11:40 UTC
Thank you Lionel!
Unassign myself since the final and right fix is from you :-)
Comment 16 Julien Nabet 2014-12-21 09:36:06 UTC
I updated my master sources repo and could verify this one.
Comment 17 Julien Nabet 2014-12-21 09:52:57 UTC
*** Bug 49048 has been marked as a duplicate of this bug. ***