Bug 79185 - Dialogs not appearing as smoothly
Summary: Dialogs not appearing as smoothly
Status: RESOLVED DUPLICATE of bug 80633
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta1
Hardware: All All
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf, regression
Depends on:
Blocks: Dialog
  Show dependency treegraph
 
Reported: 2014-05-24 16:40 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-09-30 19:29 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-05-24 16:40:08 UTC
This bug is being brought over from bug 77934 comment 14.

"The only thing i noticed is that moving between tabs is slower and isnt as smooth as in 4.2.5, but this isnt limited to just the picture dialog. It can be easily seen when jumping between tabs like 'Picture' and 'Crop'. I can see it drawing the highlight box around the radio button text caption in the newly selected tab, then paint over the tab, and then draw all the elements in it. It maybe happening this way in 4.2.5, but its so fast that i cant see it happening."

I tested the same issue today with the 4.3 beta with 'table format', 'character', and 'paragraph style' dialogs.
Comment 1 Yousuf Philips (jay) (retired) 2014-05-24 18:29:36 UTC
I have uploaded a screencast to show that is meant - http://www.youtube.com/watch?v=Bc4dffJFXek
Comment 2 pierre-yves samyn 2014-05-24 18:39:45 UTC
Hello

I confirm on windows 7/64 & Version: 4.3.0.0.beta1
Build ID: 2e39c7e59c8fc8b16a54c3d981dceef27fb0c07f

Intel core  2Duo 3,6GHz RAM 4,0 Go

Regards
Pierre-Yves
Comment 3 Joel Madero 2014-05-24 20:37:35 UTC
Tried to bibisect and couldn't (really weird, tried both 4.3 and 4.2all).

Confirmed on:
Ubuntu 14.04 x64
LibreOffice 4.3 beta1

Works on LibreOffice 4.2.4.2 release.


Trivial - not going to really impact anything but it's a little regression
Low - bumped up from lowest as it's a regression

regression
Comment 4 Björn Michaelsen 2014-06-04 17:19:18 UTC
Could this just be a sideeffect of the new Widget Layout?
https://wiki.documentfoundation.org/Development/WidgetLayout
Comment 5 Michael Stahl (CIB) 2014-06-30 14:44:30 UTC
so ... this is about dialogs being "slow"?
Comment 6 Yousuf Philips (jay) (retired) 2014-06-30 17:48:53 UTC
jumping between tabs is slow. check out my screencast, it has audio commentary. :)
Comment 7 Caolán McNamara 2014-07-01 15:58:45 UTC
might be the same as bug#80633
Comment 8 Matthew Francis 2015-01-30 02:50:44 UTC
This does seem to be essentially the same as bug 80633 - closing in favour of that (although it is the later bug, 80633 has some investigation and commits against it already)

*** This bug has been marked as a duplicate of bug 80633 ***
Comment 9 Yousuf Philips (jay) (retired) 2015-01-30 06:46:38 UTC
Bug 80633 talks about a similar issue but states the regression is in 4.2.4, while this bug has the regression starting in 4.3 beta, so not sure if they going after the same issue.
Comment 10 Robinson Tryon (qubit) 2015-12-15 11:05:14 UTC Comment hidden (obsolete)