Bug 79262 - PDF: Export selection should respect slide selection and not object selection
Summary: PDF: Export selection should respect slide selection and not object selection
Status: RESOLVED DUPLICATE of bug 40163
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.6.1 rc
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-26 13:25 UTC by ediaz
Modified: 2015-09-29 13:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ediaz 2014-05-26 13:25:20 UTC
if you try export a presentation with 2 pages. in pdf and select selection the software export all pages not only the selected.

              
Operating System: Windows 7
Version: 4.2.4.2 release
Comment 1 sophie 2014-06-05 13:12:43 UTC
Hi, confirmed using 4.2.4.2 under Ubuntu 14.04 and 4.1.6.1 under Debian, using both the dialog or the direct export. Change plateform and version. Set as New - Sophie
Comment 2 QA Administrators 2015-06-08 14:41:19 UTC Comment hidden (obsolete)
Comment 3 Buovjaga 2015-06-21 16:52:34 UTC
Confirmed with Selection. Defining the slide works ok.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)
Comment 4 Jean-Baptiste Faure 2015-07-07 07:15:14 UTC
Not sure if "selection" in pdf export dialog means what you think. If you select an object in a slide and export as pdf choosing selection, then you get a pdf document containing only the object you selected. For me the choice "selection" is intended to work the same way it works for graphic export.

Does somebody can confirm or infirm my thought ?

Exporting a list of selected slides (choice #2) works well in LO 5.0 branch.

Best regards. JBF
Comment 5 Buovjaga 2015-07-07 08:59:24 UTC
(In reply to Jean-Baptiste Faure from comment #4)
> Not sure if "selection" in pdf export dialog means what you think. If you
> select an object in a slide and export as pdf choosing selection, then you
> get a pdf document containing only the object you selected. For me the
> choice "selection" is intended to work the same way it works for graphic
> export.
> 
> Does somebody can confirm or infirm my thought ?
> 
> Exporting a list of selected slides (choice #2) works well in LO 5.0 branch.
> 
> Best regards. JBF

Gosh, you are right! If I select an object before PDF export, the "Selection" export option correctly exports only the slide with the selected object.

Yet, that is highly unintuitive in the context! I think a use case of ctrl-clicking a selection of slides in the Slide Pane would be quite common.

Compare this to ctrl-clicking objects in multiple slides: it is impossible! So in effect selecting an object and exporting as PDF "Selection" is the same as saying you want to export a single slide with the object. It is redundant.

Yet another inconsistency: if we select an object, go to File - Export... tick selection in the file dialog and select PDF as the file type, the regular PDF export dialog appears. We then would have to again select "Selection", otherwise it produces a PDF with all the pages (the default option).

Adjusted summary.
Comment 6 ediaz 2015-07-07 09:35:43 UTC
I download the last version 4.4.4.2 for Windows 7 Version 64.

Open Libreoffice impress

Create a doc with 3 slides

Select 2 slices

Menu/File/Export PDF

Select selection

export all the doc not the selection.
Comment 7 Jean-Baptiste Faure 2015-07-07 18:23:37 UTC
(In reply to Beluga from comment #5)
> [...]
> Gosh, you are right! If I select an object before PDF export, the
> "Selection" export option correctly exports only the slide with the selected
> object.

In my tests, it export only the selected object, not the entire slide containing the selected object. Do you agree?

For the sake of clarity, I think the pdf export dialog should have two excluding selection choices :
1/ selected slides
2/ selected graphic object(s)

Note: when I try to export a selection of slides made in the slide sorter tab by choosing the radio button "selection", I get the following error message:

Error saving the document [...]:
Write Error.
The file could not be written.

No error message if I selected the slides in the slide sidebar.

Best regards. JBF
Comment 8 Buovjaga 2015-07-07 18:30:22 UTC
(In reply to Jean-Baptiste Faure from comment #7)
> In my tests, it export only the selected object, not the entire slide
> containing the selected object. Do you agree?
> 
> For the sake of clarity, I think the pdf export dialog should have two
> excluding selection choices :
> 1/ selected slides
> 2/ selected graphic object(s)
> 
> Note: when I try to export a selection of slides made in the slide sorter
> tab by choosing the radio button "selection", I get the following error
> message:
> 
> Error saving the document [...]:
> Write Error.
> The file could not be written.
> 
> No error message if I selected the slides in the slide sidebar.
> 
> Best regards. JBF

No, I don't agree. It exports the entire slide for me, both in 4.4 and 5.1.

I've never seen the error you mention.

Win 7 Pro 64-bit, Version: 4.4.4.3
Build ID: 2c39ebcf046445232b798108aa8a7e7d89552ea8
Locale: fi_FI

Version: 5.1.0.0.alpha1+
Build ID: a625cd702700ae1773966a3133d27027d1c4d083
TinderBox: Win-x86@39, Branch:master, Time: 2015-07-07_08:23:06
Locale: fi-FI (fi_FI)
Comment 9 Antonello 2015-09-25 07:36:36 UTC
This bug is related to (possible duplicate?) of https://bugs.documentfoundation.org/show_bug.cgi?id=40163
Comment 10 Buovjaga 2015-09-29 13:58:16 UTC
(In reply to Antonello from comment #9)
> This bug is related to (possible duplicate?) of
> https://bugs.documentfoundation.org/show_bug.cgi?id=40163

Yep, the report seems to cover this as well.

*** This bug has been marked as a duplicate of bug 40163 ***