Bug 79278 - Background color in Writer too dark
Summary: Background color in Writer too dark
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta1
Hardware: Other All
: medium normal
Assignee: Adolfo Jayme
QA Contact:
URL:
Whiteboard: target:4.3.1 target:4.4.0
Keywords:
: 79277 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-26 21:07 UTC by Fabian Alexander Wilms
Modified: 2014-09-03 06:48 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot comparing 4.2 vs 4.3 (221.08 KB, image/png)
2014-05-26 21:12 UTC, Fabian Alexander Wilms
Details
Libreoffice writer version 4.3.1 (same color as 4.3.0) (130.26 KB, image/png)
2014-09-03 03:34 UTC, nomnex
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Alexander Wilms 2014-05-26 21:07:42 UTC
Problem description: 
Compared to 4.2, the background color got darker. Before, it was easier on the eyes.

Steps to reproduce:
1. Start Writer

Current behavior:
The background should be brighter and the rulers should blend in

Expected behavior:
This isn't the case
Comment 1 Fabian Alexander Wilms 2014-05-26 21:11:13 UTC
*** Bug 79277 has been marked as a duplicate of this bug. ***
Comment 2 Fabian Alexander Wilms 2014-05-26 21:12:58 UTC
Created attachment 99899 [details]
Screenshot comparing 4.2 vs 4.3
Comment 3 Adolfo Jayme 2014-05-27 06:55:00 UTC
I agree it’s too dark, but this was done as requested in bug #72142.
Comment 4 Emir Sarı (away) 2014-05-27 07:02:48 UTC
How come more easy on the eyes when one cannot distinguish the document from the background itself (both white)?

A nice texture would be more appropriate than a single dark colour maybe.
Comment 5 Adolfo Jayme 2014-05-27 07:29:56 UTC
Yeah Emir, I was thinking on a texture as well, or maybe a delicate gradient made out of shading the default, native window colors in the respective platform, so that it doesn’t look out of place.

The thing here is that I think the new default is again too dark [*], but the color introduced in 3.6 was too similar to the document’s white (I can confirm that myself as well, because I have eyesight issues).

Anyway, let’s wait for the opinion of other UX-Advise members to see what they think.

--
[*] (Not that it bothers me much, as it only shows up on Windows and Mac, and I use Linux GTK most of the time. My GTK theme is nicely colored, and it’s happily showing as its designers intended.)
Comment 6 retired 2014-05-27 12:13:50 UTC
Fabian, so you think that apps like Adobe Lightroom, Photoshop or Aparture are "hard on the eyes" because they are dark?

Actually I think the opposite is true. But since we are talking about an office application, making changes is difficult without an overall design concept in which direction this should be moving.

I think that what's bothering here is the increased contrast now between sheet to write on and the darker background color.

In general I welcome the darker background (before as Emir pointed out it was close to white) also the grey top menu background is a great improvement moving in the right direction.

I think this should be discussed in design / ux department. There's still a lot to do to bring this to a nice overall concept where LO wants to go UI wise.

Just my 2Cents.
Comment 7 Emir Sarı (away) 2014-05-27 16:05:21 UTC
For OS X I propose a background, which is similar to the one found in the background of the OS X login screen. 

http://i52.tinypic.com/1251j5z.jpg

I think it is not permitted for use, but a similar one can be designed with the help of someone who has graphics skills.
Comment 8 Yousuf Philips (jay) 2014-05-28 03:39:16 UTC
In Linux Mint, they (4.2.4 and 4.3 beta) are both exactly the same for me with #EDECEB.
Comment 9 Stefan Knorr (astron) 2014-05-28 18:10:51 UTC
Hm, if I am not mistaking this is the third bug (in the LibO era) about this:
1. too dark (not sure of bug number) => 2. too light => 3. too dark.

In contrast to how I remember the first of these bugs though, this bug seems to be picking up the OS-specific aspect of the issue. Which is good...

Then,...
+ Emir asked for Apple's gray linnen wallpaper in the document background:
  Given how I-OS 7 looks, it seems like a safe bet that the linnen wallpaper
  will not survive much longer on OS X. Not a good idea, then to implement
  anything similar in LibO.

+ It would be nice if we could get back to the ruler background matching the
  document background, even if this was more of an accident before. See also
  bug 51534
Comment 10 Emir Sarı (away) 2014-05-29 10:02:02 UTC
Actually OS X does not use a linen anymore, since Mountain Lion it uses a gray gradient, which is on par with iOS 7 design language. And I believe we do not have to worry about much iOS 7 design compatibility, considering we got even not totally native ruler background after more than 10 years. 

This has become more of an infinite loop kind of, someone submits something, then someone opens a bug, someone submits another thing and this goes on. Without any specifications and roadmap this is bound to happen. Then what we have at hand is some non-understandable freak interface which carries parts from both Mac OS, Carbon, Cocoa, GTK etc. which can break or change any time whenever someone decides something on his/her own. 

LibreOffice is a pro application, if we are going to use a design language on OS X, it might be the Apple Pro apps, which is darker, and not likely to change any time soon.

To end these pointless discussions, I suggest creating specifications and documenting them, therefore directing volunteers/developers contribute in that direction. If the UX team is willing to start such initiative, I am more than ready to contribute.
Comment 11 retired 2014-05-31 14:54:00 UTC
As for OS X 10.10 design direction, we'll no more in 2 days. Let's wait and find a nice appropriate solution. Emir's suggestion is good. White paper and background is not good.
Comment 12 Commit Notification 2014-07-30 14:15:30 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=88f720db4ad5b0dfb922fcd2492276edd2340e62&h=libreoffice-4-3

Resolves fdo#79278: not too dark, not too bright background color


It will be available in LibreOffice 4.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2014-08-11 10:33:04 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2b9ad46b23fdb39cd456cdc543cce346c6f325c3

Resolves fdo#79278: not too dark, not too bright background color



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 nomnex 2014-09-03 03:34:58 UTC
Created attachment 105650 [details]
Libreoffice writer version 4.3.1 (same color as 4.3.0)

Reopen the bug please.

No change from previous version (4.3.0) as announced for 4.3.1.

The background is still the same (light gray) indistinguishable from the tool bars.
Comment 15 Adolfo Jayme 2014-09-03 06:48:52 UTC
> No change from previous version (4.3.0) as announced for 4.3.1.

This bug just dealt with the color used under Windows and Mac. Reopening it would be incorrect. You can manually set the background color you want, or you can use a different GTK+ theme.