Bug Hunting Session
Bug 79326 - FILEOPEN: DOCX - Doesn't colorize Sepia-filtered images correctly
Summary: FILEOPEN: DOCX - Doesn't colorize Sepia-filtered images correctly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX-Images Image-Colorize
  Show dependency treegraph
 
Reported: 2014-05-27 17:32 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-09-30 20:54 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
same as attachment 97273 except one image was changed from color greyscale to sepia (136.49 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-05-27 17:32 UTC, Yousuf Philips (jay) (retired)
Details
the image sepia colorized in LibO and word 2010 (178.34 KB, image/png)
2014-05-27 17:36 UTC, Yousuf Philips (jay) (retired)
Details
word 2010's various colorizations of the image (137.19 KB, image/png)
2014-05-27 17:37 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-05-27 17:32:14 UTC
Created attachment 99967 [details]
same as attachment 97273 [details] except one image was changed from color greyscale to sepia

While reviewing attachment 97273 [details] in bug 77374, i noticed that LibO correcting imports grayscaled images in LibO 4.3, but doesnt do it correctly with sepia as its not first grayscaling the image and then adding sepia above it. Tested in Linux Mint. LibO 4.2 doesnt have image colorize capabilities.
Comment 1 Yousuf Philips (jay) (retired) 2014-05-27 17:36:31 UTC
Created attachment 99968 [details]
the image sepia colorized in LibO and word 2010
Comment 2 Yousuf Philips (jay) (retired) 2014-05-27 17:37:23 UTC
Created attachment 99969 [details]
word 2010's various colorizations of the image
Comment 3 Yousuf Philips (jay) (retired) 2014-05-27 17:44:04 UTC
Also to be noted is that there is nothing in the picture properties dialog for changing the colorization. Atleast as far as i can see. :)
Comment 4 Firas Hanife 2014-05-27 18:26:12 UTC
Reproduced the same behavior described by Jay Philips with 4.2.4.2 and 4.3.0.0.beta1 on openSUSE 13.1.
Comment 5 Buovjaga 2014-09-25 11:51:55 UTC
Sepia colorization works for me. Looks like the [word 2010].pdf side diff.

Version: 4.4.0.0.alpha0+
Build ID: 0a32edcdc2bda75a7536ce7f88c91cbc56e7afb1
TinderBox: Win-x86@39, Branch:master, Time: 2014-09-24_00:45:04
Comment 6 Yousuf Philips (jay) (retired) 2014-10-07 03:19:44 UTC
Closing as it has been fixed in 4.3 and master.

Version: 4.3.3.0.0+
Build ID: 18b9cb260a5ec358f6a7b73362bbc306af0417b1
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:libreoffice-4-3, Time: 2014-10-04_04:41:44