Bug 79391 - FILEOPEN: RTF - Pages merged into 1 page and layout loops
Summary: FILEOPEN: RTF - Pages merged into 1 page and layout loops
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.3.1 rc
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:4.4.0 target:4.3.0
Keywords: bibisected, regression
: 79651 (view as bug list)
Depends on:
Blocks: RTF
  Show dependency treegraph
 
Reported: 2014-05-29 03:32 UTC by Joel Madero
Modified: 2017-10-08 12:10 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joel Madero 2014-05-29 03:32:04 UTC
Steps to Reproduce:

Open attachment 98599 [details] in LibreOffice 4.2.4.2 - 4.3 beta1

Observed:
The document is 11 pages but are merged into a single page and CPU spikes

Expected:
Here it's tricky as the bibisect only shows the regression but the file has an additional bug associated with it (bug 78730) which makes it so the document shows 10 pages instead of 11 - ideally the file opens perfectly, but worse case it should at least open like it did prior to this regression
Comment 1 Yousuf Philips (jay) (retired) 2014-05-29 03:35:45 UTC
Confirmed. It was actually bug 78370.
Comment 2 Yousuf Philips (jay) (retired) 2014-06-04 22:50:01 UTC
*** Bug 79651 has been marked as a duplicate of this bug. ***
Comment 3 Joel Madero 2014-06-09 17:14:57 UTC
7c18060e3625d89e7ca6c3a75b0f609200150252 is the first bad commit
commit 7c18060e3625d89e7ca6c3a75b0f609200150252
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Sun May 11 20:14:08 2014 +0000

    source-hash-2589d9e3e6e9fab18ff735561991a3dcdd3d8b4b
    
    commit 2589d9e3e6e9fab18ff735561991a3dcdd3d8b4b
    Author:     Norbert Thiebaud <nthiebaud@gmail.com>
    AuthorDate: Mon Mar 3 18:36:38 2014 -0600
    Commit:     Norbert Thiebaud <nthiebaud@gmail.com>
    CommitDate: Mon Mar 3 18:37:15 2014 -0600
    
        coverity#738727: Unitialized scalar field
    
        Change-Id: I37bdf601f7a6bb179f8a14dfb22d3e102868fea1

:100644 100644 3ba1e23da4c5fd856ca77edeccf35fd8f981d2fb 92c5df078bd2356a2b4b3f3bab5dab0d2a074f96 M	autogen.log
:100644 100644 5da83ef1a73c852acba2193baa023808afaecfcb 35b98cf4e7132db444ade1a8fbe702ce239fa043 M	ccache.log
:100644 100644 d52b1f94ada187469913ba3cc2d95ef8260f059b d0a147531c455fcc393f56b5c47aefc124741d31 M	commitmsg
:100644 100644 27e78072edf8aaacff4d36dc84c6bca2985ac17a 7e5e035059fa93faf911711f22cb7f7e088421da M	make.log
:040000 040000 b8f0d08bc0f51eec3f61beaa6fe72a45487bb446 49bc91d0282657b62fdddd7baba1b8bed4ad07f9 M	opt


# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574
# good: [4850941efe43ae800be5c76e1102ab80ac2c085d] source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b
git bisect good 4850941efe43ae800be5c76e1102ab80ac2c085d
# bad: [a900e72b6357882284c5955bdf939bf14269f5fb] source-hash-dd1050b182260a26a1d0ba6d0ef3a6fecc3f4e07
git bisect bad a900e72b6357882284c5955bdf939bf14269f5fb
# good: [e1d0365cd2b073a859f59ad0a4584385a66dc611] source-hash-2eea96c702a44ab009743b0d22ef639127f0b57b
git bisect good e1d0365cd2b073a859f59ad0a4584385a66dc611
# skip: [8f55938c891ee3e4c252b193dba9419f130537bc] source-hash-93f3f72d18e551c8edd6a010cb78d9cbe404f8ef
git bisect skip 8f55938c891ee3e4c252b193dba9419f130537bc
# good: [7518fcaf863962bf4f6f3cdf84f6e42f0f59225f] source-hash-ab1f5eab4830f00dbbd7c883b98b59975ecd3bb1
git bisect good 7518fcaf863962bf4f6f3cdf84f6e42f0f59225f
# bad: [56a3b3c781fc2eb55f46641d89a866a91119a8a3] source-hash-21e6fd2b2dfdb806db320f699e434e6f2351a7b6
git bisect bad 56a3b3c781fc2eb55f46641d89a866a91119a8a3
# bad: [1b1974dec96ab21a79c3f574f3654a9515fed9d0] source-hash-51f74e362b364e51f13f3abaa00df1aa01c81cef
git bisect bad 1b1974dec96ab21a79c3f574f3654a9515fed9d0
# bad: [7c18060e3625d89e7ca6c3a75b0f609200150252] source-hash-2589d9e3e6e9fab18ff735561991a3dcdd3d8b4b
git bisect bad 7c18060e3625d89e7ca6c3a75b0f609200150252
# first bad commit: [7c18060e3625d89e7ca6c3a75b0f609200150252] source-hash-2589d9e3e6e9fab18ff735561991a3dcdd3d8b4b
Comment 4 Michael Stahl (CIB) 2014-07-30 14:42:15 UTC
current libreoffice-4-2 and libreoffice-4-3 branch 1-page and looping
4.1.6.2 and master don't loop, on 11 pages

broken since 4.2.3.1

regression from

commit e3f254ab8211fbab7541cde2100a35c875b0c240
Author:     Michael Stahl <mstahl@redhat.com>
AuthorDate: Thu Feb 27 23:48:59 2014 +0100

    RTF import: fix spurious page breaks at doc end (related: rhbz#1065629)
    

...

ok this one fixed it on master:

commit 75fc9e669f209472ec6a282848166d96d02d84d9
Author:     Umesh Kadam <umesh.kadam@synerzip.com>
AuthorDate: Fri Jun 13 17:26:19 2014 +0530
Commit:     Miklos Vajna <vmiklos@collabora.co.uk>
CommitDate: Fri Jun 20 08:48:36 2014 +0000

    fdo#78904 : LO hangs while saving the document.
Comment 5 Michael Stahl (CIB) 2014-07-30 16:05:33 UTC
fixed on libreoffice-4-3 branch by commit
77ab92bfae9cd32f50e993e0fd8cdec4e6e4a2ff

...unfortunately this backport is apparently not enough to fix it for 4.2...
Comment 6 Michael Stahl (CIB) 2014-08-01 10:29:24 UTC
these commits are needed to fix it for 4.2:

commit 6c0e1270889deb513f961f864dfc1c02ee8705f4
Author:     Michael Stahl <mstahl@redhat.com>
AuthorDate: Fri Jun 13 23:49:59 2014 +0200

    fdo#70578: writerfilter RTF import: by default style is para style 0


commit 5e2f54d8b2c3e80e2e347e9bb00df4f8fcc2252e
Author: Miklos Vajna <vmiklos@collabora.co.uk>
Date:   Thu Jan 23 21:20:47 2014 +0100

    writerfilter: NS_rtf::LN_SGC -> NS_ooxml::LN_CT_Style_type

commit 1be0a3fa9ebb22b607c54b47739d4467acfed259
Author:     Michael Stahl <mstahl@redhat.com>
AuthorDate: Tue Jun 17 18:40:04 2014 +0200

    n#825305: writerfilter RTF import: override style properties like Word


... argh ... the last one is rather risky and i don't want to backport it
for 4.2.7...

what makes the difference between looping and properly paginated
document is the default paragraph style containing 10.5 pt Calibri font
{ \fs21\f37 Normal;}

meh.... i'd say this document is a pathological case, and the various
import filter changes just trigger a pre-existing bug in Writer's
horrendous layout code; there won't be many documents affected
in this way by commit e3f254ab8211fbab7541cde2100a35c875b0c240
and so fixing this in 4.2 is not worth it;
resolving fixed in 4.3 and master.
Comment 7 Robinson Tryon (qubit) 2015-12-17 08:20:17 UTC Comment hidden (obsolete)