Bug Hunting Session
Bug 79432 - file open .xlsx appears in blank on share file samba
Summary: file open .xlsx appears in blank on share file samba
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Network
  Show dependency treegraph
 
Reported: 2014-05-29 23:52 UTC by Guillermo Lengemann
Modified: 2017-07-27 21:01 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Guillermo Lengemann 2014-05-29 23:52:41 UTC
On Debian GNU/Linux 7.5 with gnome3. From Nautilus search the file and double click DOCUMENTOS2001.xlsx.

The bash command "ps":
user-foo+ 22687     1  0 19:12 ?        00:00:00 /opt/libreoffice4.2/program/oosplash --calc smb://xxx.xx.xx.xx/dir/DOCUMENTOS2001.xlsx
user-foo+ 22705 22687 15 19:12 ?        00:00:00 /opt/libreoffice4.2/program/soffice.bin --calc smb://xxx.xx.xx.xx/dir/DOCUMENTOS2001.xlsx --splash-pipe=5

But when open same file whit other format (.ods) opens correctly.
Comment 1 Guillermo Lengemann 2014-05-30 13:38:36 UTC
There are two ways to open a shared file: smb or gvfs, example (ps -ef |grep offi):

/opt/libreoffice4.2/program/soffice.bin --calc smb://xxx.xx.xx.xx/folder/DOCUMENTOS01.xlsx

and:

/opt/libreoffice4.2/program/oosplash --calc /home/user-foo/.gvfs/folder en xxx.xx.xx.xx/DOCUMENTOS01.xlsx

with:
.doc, good with gvfs and smb
.odt, good with gvfs and smb
.ods, good with gvfs and smb
.xlsx, good with gvfs and not smb

On Debian GNU/Linux 7.5 resolved using gvfs, in this manner:

1.- aptitude install gvfs-fuse
2.- sed -i 's/#X-GIO-NoFuse=true/X-GIO-NoFuse=true/' /usr/share/applications/libreoffice-*
3.- adduser user-foo fuse
4.- service gdm3 restart (perhaps reboot pc)
Comment 2 Yousuf Philips (jay) (retired) 2014-05-30 17:04:46 UTC
If i run `$ libreoffice4.2 smb://jay-r1-cup1e1/desktop/1.doc` or `$ /opt/libreoffice4.2/program/soffice smb://jay-r1-cup1e1/desktop/1.doc` i get the following error "Warning: failed to read path from javaldx". Doesnt matter which file extension that the file has. The splash screen shows for a second and the progress bar goes for maybe 10% and then it disappears.

If i use the file manager (caja) to open the smb file it runs it through gvfs and this doesnt work using the .desktop file associated with Calc but if i open it if you tell it to open through /usr/bin/libreoffice4.2, it works fine.

Its even worse us the .desktop file associate with Calc 4.1 as it says the file is corrupt and if i say open it anyway, it gives me a 'The file '$(ARG1)' could not be repaired and therefore cannot be opened.' error and then after that a 'General Error' dialog appears. If i say click no at the corrupt file dialog, it give me the '$(ARG1)' error dialog and then jumps back to the corrupt file dialog, and keeps on looping a few times until a 'text import' dailog appears with binary data in it.

The .desktop file associated with Calc 3.6 and 4.0 work fine.

This was test on Linux Mint.
Comment 3 Joel Madero 2014-05-30 17:13:57 UTC
Jay - the problems you describe sound substantially different from the bug report.
Comment 4 Yousuf Philips (jay) (retired) 2014-05-30 21:12:33 UTC
The first paragraph is related to the reported bug, while the others paragraphs were things i observed while trying to confirm the bug.
Comment 5 Maxim Monastirsky 2014-06-01 19:35:09 UTC
@Guillermo Lengemann: Do you have the following packages installed - 'libgnomevfs2-0', 'libgnomevfs2-extra', 'liborbit2'?

@Jay: Also check those packages. If this still doesn't work, try also to export 'OOO_FORCE_DESKTOP=gnome' (to workaround Linux Mint specific issue). Does it work now?
Comment 6 Yousuf Philips (jay) (retired) 2014-06-02 04:59:19 UTC
Yes i have the three packages installed. Yes with the export worked and i could load .odt, .docx, but not .xlsx.
Comment 7 Maxim Monastirsky 2014-06-02 13:03:27 UTC
(In reply to comment #6)
> and i could load .odt, .docx, but not .xlsx.
That's weird. I couldn't confirm that with 4.2.4 under Ubuntu 14.04 & Fedora 20. I'm able to open also .xlsx files, without any issue.
Comment 8 Maxim Monastirsky 2014-06-02 16:13:50 UTC
I also couldn't reproduce with 4.2.4 under Debian 7.5 (the same env. as the original reporter). I'm able to open .xlsx file via double click in nautilus.
Comment 9 Guillermo Lengemann 2014-06-02 16:54:16 UTC
@Maxim Monastirsky, i have the three packages installed ('libgnomevfs2-0', 'libgnomevfs2-extra', 'liborbit2'). The file (.xlxs) open via gvfs but not without gvfs. The other formats open without gvfs. The problem occurs only .xlxs file without gvfs.
Comment 10 Yousuf Philips (jay) (retired) 2014-06-04 23:30:22 UTC
Tested it more and 3.6 and 4.0 worked fine. 4.1 gives an error message that the file was corrupt and when i press repair i get another error message and it crashes. 4.2.4, 4.2.6, and 4.3 beta opened the file with the sheet name but with no data on the sheet with the follow commandline error:

(soffice:10693): WARNING **: Input Stream exceptional result 'Internal error' (3)
Comment 11 Maxim Monastirsky 2014-06-05 09:27:21 UTC
(In reply to comment #10)
> 4.1 gives an error message that
> the file was corrupt and when i press repair i get another error message and
> it crashes.
What version of Linux Mint this is tested on? And what the source of this 4.1 build? If it's Linux Mint 'Maya' and the libreoffice build is from a PPA, then it's already reported as Bug 67527. But in that case it has nothing to do with this bug, which is about the build downloaded from libreoffice.org. See Bug 49776 comment 6 for more information about different builds.

> 4.2.4, 4.2.6, and 4.3 beta opened the file with the sheet name
> but with no data on the sheet
As I already said, I can't reproduce this on several systems. Could you please attach a test file, and tell your samba server config?
Comment 12 Yousuf Philips (jay) (retired) 2014-06-05 18:53:25 UTC
(In reply to comment #11)
> What version of Linux Mint this is tested on? And what the source of this
> 4.1 build? If it's Linux Mint 'Maya' and the libreoffice build is from a
> PPA, then it's already reported as Bug 67527. But in that case it has
> nothing to do with this bug, which is about the build downloaded from
> libreoffice.org. See Bug 49776 comment 6 for more information about
> different builds.

Running Linux Mint 13 and i think bug 67527 deals with a similar problem that i reported for 4.1, but that bug was over gvfs and not smb. I have 4.1 installed from the PPA and 4.2.4 is installed from the fresh download page on libreoffice.org. 4.2.6 and 4.3 are extracted from the daily builds.

> As I already said, I can't reproduce this on several systems. Could you
> please attach a test file, and tell your samba server config?

i used attachment 98759 [details] on a Linux Mint 16 running samba 3.6.18 from my Linux Mint 13 running 3.6.3. If you need additional samba server info, please let me know which commands i should execute to provide that info.
Comment 13 Yousuf Philips (jay) (retired) 2014-06-05 19:44:40 UTC
Just tested it again on a brand new installation of ubuntu 14.04 as the external source. Here are the steps:

Ubuntu 14.04
1) open file manager, right-click on Desktop and select 'Local Network Share'
2) it will say that samba isnt installed, so install it
3) then in the 'folder sharing' dialog, enable 'share this folder' and 'guest access'
4) download attachment 98759 [details] to the desktop and name it 1.xlsx

Linux Mint 13
1) in terminal type '$ export OOO_FORCE_DESKTOP=gnome' (without this libreoffice wont start)
2) in terminal type '$ libreoffice smb://ubuntu-server/Desktop/1.xlsx'
3) libO 4.2.4 will load and say that the file has links to other files, click no
4) the sheet will appear with the name 'HQ Wise Report' but the contents of the sheet will be blank

If you would like a screencast of this, i can supply it. :)
Comment 14 Maxim Monastirsky 2014-06-06 07:49:28 UTC
(In reply to comment #12)
> i think bug 67527 deals with a similar problem
> that i reported for 4.1, but that bug was over gvfs and not smb.
The PPA build of LO uses gvfs internally to access smb, so it's exactly the same problem. *Please* read Bug 49776 comment 6.

> i used attachment 98759 [details]
Thanks for the test file. I indeed can reproduce the bug with gnome-vfs build (from libreoffice.org), but not with a gvfs based builds. But that seems specific to that file, which has external references (see Bug 78490). It isn't reproducible with other xlsx files.

But I wonder if this is the problem of the original reporter.
@Guillermo Lengemann: Could you please attach a test file?
Comment 15 Yousuf Philips (jay) (retired) 2014-06-06 22:29:05 UTC
(In reply to comment #14)
> > i used attachment 98759 [details]
> Thanks for the test file. I indeed can reproduce the bug with gnome-vfs
> build (from libreoffice.org), but not with a gvfs based builds. But that
> seems specific to that file, which has external references (see Bug 78490).
> It isn't reproducible with other xlsx files.

Even if the external references dont load for attachment 98759 [details], why is the entire page blank. There are cells in the document with just plain text in it like G7 and there are cell borders that dont appear. I think something else is going wrong there. And here is an smb xlsx file that loads correctly, even when it has external references - attachment 100083 [details].

(In reply to comment #14)
> But I wonder if this is the problem of the original reporter.
> @Guillermo Lengemann: Could you please attach a test file?

Yes i do agree that the only way to track down the issue is for Guillermo to supply us with DOCUMENTOS2001.xlsx, as it seems that this problem is not for all xlsx files.
Comment 16 QA Administrators 2015-01-10 18:06:48 UTC Comment hidden (obsolete)
Comment 17 QA Administrators 2015-02-11 19:54:45 UTC Comment hidden (obsolete)
Comment 18 QA Administrators 2015-02-11 20:00:58 UTC Comment hidden (obsolete)
Comment 19 Robinson Tryon (qubit) 2015-12-17 08:22:20 UTC Comment hidden (obsolete)