Bug 79476 - FILESAVE: DOCX saved files with passwords not openable by MS Word
Summary: FILESAVE: DOCX saved files with passwords not openable by MS Word
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: interoperability ooxml
Keywords:
Depends on:
Blocks: DOCX Password-Protected
  Show dependency treegraph
 
Reported: 2014-05-31 08:36 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-10-07 12:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample file saved in LibO 4.2 (6.50 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-05-31 08:36 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-05-31 08:36:47 UTC
Created attachment 100193 [details]
sample file saved in LibO 4.2

If you create a document in LibreOffice 4.2 and above with a password, when attempting to open it with MS Word 2007 or 2010. It will claim you have the wrong password.
Comment 1 Yousuf Philips (jay) (retired) 2014-05-31 21:08:07 UTC
the password is 1234. :)
Comment 2 Alex Thurgood 2014-05-31 21:10:18 UTC
Confirming with regard to MS Word for Mac 2011 version 14.4.1 on OSX 10.9.3
Comment 3 Alex Thurgood 2014-05-31 21:27:37 UTC
Can't even open the same docx file in LO 4.2.3.3, I get an error message saying incorrect password
Comment 4 Yousuf Philips (jay) (retired) 2014-05-31 21:44:07 UTC
sorry the password was test. :)
Comment 5 Yousuf Philips (jay) (retired) 2014-05-31 21:46:24 UTC
well i'm running on 4.2.4 and reopening it in LibO is fine.
Comment 6 Alex Thurgood 2014-05-31 21:47:27 UTC
Well so 1234 wasn't the password, the correct one being test.

I can open this file in Word 2011 for Mac, so no confirmation then. Setting to needinfo.
Comment 7 Ibrahim 2014-06-04 00:21:27 UTC
It opened fine with word 2007 on windows 7.
Comment 8 ign_christian 2014-06-10 04:11:28 UTC
Then should be WFM after 2 working confirmations
Comment 9 Yousuf Philips (jay) (retired) 2014-06-10 04:31:49 UTC
(In reply to comment #8)
> Then should be WFM after 2 working confirmations

Well Alex checked Mac 2011, so thats not a confirmation. If you could confirm for 2007 or 2010, then that would be a second.
Comment 10 ign_christian 2014-06-10 05:00:27 UTC
I think this problem related to LO not OS, and Ibrahim has confirmed with your situations (even I just guessing your OS since you didn't inform).
Comment 11 Kevin Suo 2014-07-07 10:41:01 UTC
I confirm that I can open this file with MSO 2010, win xp sp3.

However, I found another bug, I filed it saparately at bug 80999.
Comment 12 Yousuf Philips (jay) (retired) 2014-07-07 15:32:06 UTC
I must have been wrong about this so i'm closing it.