Bug 79637 - FORMATTING: Add style selector to sidebar (feature request)
Summary: FORMATTING: Add style selector to sidebar (feature request)
Status: RESOLVED DUPLICATE of bug 73071
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0 all versions
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Sidebar-Properties-Style
  Show dependency treegraph
 
Reported: 2014-06-04 14:16 UTC by troels
Modified: 2017-09-26 21:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Showing what is missing in sidebar (51.97 KB, image/png)
2014-06-04 14:16 UTC, troels
Details

Note You need to log in before you can comment on or make changes to this bug.
Description troels 2014-06-04 14:16:26 UTC
Created attachment 100398 [details]
Showing what is missing in sidebar

Sidebar almost replaces the formatting toolbar. 

However, while it is possible to change font name, size, color, etc, the style selector is not available. The sidebar therefore does not replace the toolbar.

Feature request is therefore to add the style selector to the sidebar under "character".

Style selector is the drop down where user can choose between
"default style", "heading 1", "heading 2", etc.
              
Operating System: Windows 7
Version: 4.2.4.2 release
Comment 1 V Stuart Foote 2014-06-04 17:49:19 UTC
In Writer, the SideBar already offers the Styles and Formatting content panel. It is second icon down the tab bar, you are pointing to the first--Properties in your capture.

Is this not sufficient in some fashion?
Comment 2 Cor Nouws 2014-06-05 08:47:13 UTC
There is (somewhere, prolly in my UX-archives) a discussion on improving the side bar by making the use of styles more obvious.
IMO this request belongs to the same category...
Comment 3 troels 2014-06-05 09:06:37 UTC
(In reply to comment #1)
> In Writer, the SideBar already offers the Styles and Formatting content
> panel. It is second icon down the tab bar, you are pointing to the
> first--Properties in your capture.
> 
> Is this not sufficient in some fashion?

It is in some fashion. Though, I would argue that it is not as intuitive as it has been moved away from the other formatting options from the formatting toolbar and therefore less discoverable.
Comment 4 Maxim Monastirsky 2014-06-05 09:44:24 UTC

*** This bug has been marked as a duplicate of bug 73071 ***