Bug 73071 - SIDEBAR: Styles are missing from Properties tab
Summary: SIDEBAR: Styles are missing from Properties tab
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: BSA target:5.1.0 target:5.0.0.1 targe...
Keywords: needsDevEval, topicUI
: 77323 79637 80698 86443 (view as bug list)
Depends on:
Blocks: Sidebar-Properties-Style
  Show dependency treegraph
 
Reported: 2013-12-27 14:37 UTC by Tin Man
Modified: 2017-09-26 21:22 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments
Calligra Words styles (107.51 KB, image/png)
2014-06-05 15:17 UTC, Francisco
Details
Calligra Words - new styles (103.79 KB, image/png)
2014-06-05 15:18 UTC, Francisco
Details
MS Office's Style Inspector (24.47 KB, image/png)
2014-06-30 20:16 UTC, Yousuf Philips (jay)
Details
how paragraph style could look in sidebar (64.66 KB, image/png)
2014-08-07 20:00 UTC, Yousuf Philips (jay)
Details
iWork Pages: Formatting sidebar (258.14 KB, image/png)
2014-08-30 10:29 UTC, Tin Man
Details
iWork Pages: Style picker (264.92 KB, image/png)
2014-08-30 10:30 UTC, Tin Man
Details
iWork Pages: Style options (291.66 KB, image/png)
2014-08-30 10:34 UTC, Tin Man
Details
iWork Pages: Chart styles (277.83 KB, image/png)
2014-08-30 11:09 UTC, Tin Man
Details
my current mockup of a redesigned sidebar (58.40 KB, image/png)
2014-09-07 01:33 UTC, Yousuf Philips (jay)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tin Man 2013-12-27 14:37:14 UTC
The Character and Paragraph sections of the Properties panel, among others, are missing the style picker, which is otherwise accessible from the toolbar.

As the panel should offer the most important properties and as we want to encourage the use of styles, a style picker should be added to every section for which it is relevant.
Operating System: All
Version: 4.3.0.0.alpha0+ Master
Comment 1 A (Andy) 2013-12-27 20:25:50 UTC
reproducible with LO 4.1.4.2 (Win7 Home, 64bit)
Comment 2 Cor Nouws 2013-12-27 20:49:28 UTC
Hi Mirek,

Is there some mockup or discussion about details somewhere ?
(Hmm, we talked about this in Milan, but I lost connection with that...)
Ciao- Cor
Comment 3 Cor Nouws 2014-02-03 17:29:20 UTC
discussing this at the UX-hackfest ... mockup to follow..
Comment 4 Cor Nouws 2014-04-11 14:55:17 UTC
*** Bug 77323 has been marked as a duplicate of this bug. ***
Comment 5 Maxim Monastirsky 2014-06-05 09:44:24 UTC
*** Bug 79637 has been marked as a duplicate of this bug. ***
Comment 6 Francisco 2014-06-05 15:17:50 UTC
Created attachment 100469 [details]
Calligra Words styles

Hello everyone. I'm attaching to screenthots that I think they could help. Both are from Calligra Words, which already had a sidebar and it managed to add styles.

The first is simply a screenshot of how they are introduce in the sidebar.

The second is how it manages to add new styles in a simple manner.

Regards
Comment 7 Francisco 2014-06-05 15:18:22 UTC
Created attachment 100470 [details]
Calligra Words - new styles
Comment 8 Maxim Monastirsky 2014-06-30 08:11:27 UTC
*** Bug 80698 has been marked as a duplicate of this bug. ***
Comment 9 Yousuf Philips (jay) 2014-06-30 20:16:18 UTC
Created attachment 102031 [details]
MS Office's Style Inspector

Yes i think Calligra does it well.

I would like to suggest that we improve on this by providing an advanced hidden field that contains style info found under the contains field in the organizer tab of the paragraph style dialog. I've included an image of ms word's style inspector, which i think we can brainstorm ideas from.
Comment 10 Yousuf Philips (jay) 2014-08-07 14:05:07 UTC
After more thinking about this issue, i think this is a perfect opportunity to go beyond the drop down approach for styles in the toolbar and go for a full visual paragraph style list, something similar to how it is in MS Word.

The drop down in the toolbar was limited in space, but that restriction is not there in the sidebar, so why not rethink the manner in which the character style is presented to users, so that we can promote the usage of styles over direct formatting.

I personally think that adding a character style drop down in the sidebar will confuse regular users, especially as we never had that drop down in the toolbar before. To me, this is an advanced feature and i think that shouldnt be displayed to regular users.
Comment 11 Yousuf Philips (jay) 2014-08-07 20:00:02 UTC
Created attachment 104246 [details]
how paragraph style could look in sidebar

Well i was messing around with the concept of a ms word type style list being integrated into the sidebar and here are two mockups. I prefer the one on the right, as styles gets its own dedicated portion that can be hidden when/if a user chooses to do so. :)
Comment 12 Jean-Baptiste Faure 2014-08-07 21:03:16 UTC
(In reply to comment #11)
> Created attachment 104246 [details]
> how paragraph style could look in sidebar

Why paragraph style only? Both paragraph and character styles need to be easily reachable when writing.

> Well i was messing around with the concept of a ms word type style list
Nothing more innovative than copying ms-word when we already have something original and working?

That said, on your mockup the name of each style is not readable because there is not enough room. I think that a scrolling ribbon a not the good tool here.

Best regards. JBF
Comment 13 Yousuf Philips (jay) 2014-08-08 07:00:40 UTC
(In reply to comment #12)
> Why paragraph style only? Both paragraph and character styles need to be
> easily reachable when writing.

As previously stated in comment 10 - "adding a character style drop down in the sidebar will confuse regular users, especially as we never had that drop down in the toolbar before."

> Nothing more innovative than copying ms-word when we already have something
> original and working?

I'm not a designer so i wont attempt to come up with how it should look. We currently dont have anything original and working in the sidebar and i was using ms-word as an idea mockup to show a visual idea of what it could be like. I would of course want the designer team to use it as a concept for whatever they choose to do in the end, if they choose to go with the idea.

> That said, on your mockup the name of each style is not readable because
> there is not enough room. I think that a scrolling ribbon a not the good
> tool here.

As i only copied and pasted, there was little i could do about making them readable. In the right mockup, i also stretched it, which of course caused blurriness, so things became less readable. It is a concept mockup that can be used if such a route is wanted to be taken.
Comment 14 Jean-Baptiste Faure 2014-08-08 07:42:28 UTC
(In reply to comment #13)
> (In reply to comment #12)
> > Why paragraph style only? Both paragraph and character styles need to be
> > easily reachable when writing.
> 
> As previously stated in comment 10 - "adding a character style drop down in
> the sidebar will confuse regular users, especially as we never had that drop
> down in the toolbar before."

Poor argumentation, it was an opportunity to make progress from typewriter to word processing.

Best regards. JBF
Comment 15 Evil Overlord 2014-08-08 07:59:09 UTC
I agree with leaving character styles out of the sidebar.

I'm a pretty big fan of styles, but I think that while paragraph styles are both easy to comprehend and widely useful, character styles are much less frequently used. I rarely use them myself. It seems to me perfectly reasonable (and extremely useful) for the sidebar to have a section for paragraph styles, while leaving character styles somewhat more hidden.
Comment 16 Tin Man 2014-08-30 10:29:59 UTC
Created attachment 105458 [details]
iWork Pages: Formatting sidebar
Comment 17 Tin Man 2014-08-30 10:30:47 UTC
Created attachment 105459 [details]
iWork Pages: Style picker
Comment 18 Tin Man 2014-08-30 10:34:40 UTC
Created attachment 105460 [details]
iWork Pages: Style options
Comment 19 Tin Man 2014-08-30 11:09:29 UTC
Created attachment 105461 [details]
iWork Pages: Chart styles
Comment 20 Tin Man 2014-08-30 11:26:43 UTC
I have to say that, out of all the style UI implementations I know, iWork has the best approach and it doesn't leave out any style category. (See attachments.) I'll run through it here:

Hierarchy
=========
The style hierarchy is well-represented in the sidebar.
Paragraph styles are up at the top, as they pertain to both paragraph properties and character properties.
Character styles are presented within the character-related section, but as the last element -- that makes sense given that the section applies to paragraph styles as well and font and size should generally only be set in paragraph styles (for good typography).
List styles serve as the titular element of the list category and custom bullets are relegated to a hidden section.

Quick access
============
All style drop-downs are quickly accessible. The most important one, the Paragraph style picker, is big and visually distinctive, thus very easy to target.
More importantly, styles can be assigned keyboard shortcuts, which potentially makes them as quick to apply as hard formatting.
Lastly, it's also nice to be able to edit ALL the style properties from within the sidebar without having to go through dialogs.

Quick edits
===========
Hard-coded formatting is indicated by an asterisk after the style name. Along with that, a large "Update" button appears next to the style in the drop-down, in the case of Paragraph styles right in the sidebar as well. There's also an "Update style" option in each style's drop-down menu. (The behavior is very similar to Google Docs.)

Quick creation
==============
There's also a button for creating a new style based on the selection in each style picker.

Presentation
============
iWork presents styles based on their properties. Highly graphical and visually distinguishable styles (e.g. chart, shape, and table styles) are presented in a grid, while the harder-to-distinguish text-based styles are presented as a list.

Context
=======
Styles appear as they're needed. Not all headings are shown by default -- only once Heading 3 is used does Heading 4 appear.


Anyway, I'm not proposing to blatantly copy iWork's implementation (which itself takes a lot of ideas from Google Docs) -- that's not even within the scope of this bug. However, it's important that we consider these areas and strive to rival or exceed iWork in all of them.

Also, as I said before, the goal for the Properties section of the sidebar is to replace formatting dialogs and include all of the various formatting options, so leaving out Character styles is not an option.
Comment 21 Yousuf Philips (jay) 2014-08-30 23:11:25 UTC
Thanks for the screenshots Mirek as i havent seen or used Pages before :D. It was nice to see that a number of the ideas i have already submitted (up/down control for increasing/decreasing the font size) and was as hoping to submit (rearrangement of sections based on topic rather than dialog) for the improvement of the sidebar are already there in Pages.
Comment 22 Cor Nouws 2014-09-06 21:03:35 UTC
(In reply to comment #10)
> After more thinking about this issue, i think this is a perfect opportunity
> to go beyond the drop down approach for styles in the toolbar and go for a
> full visual paragraph style list, something similar to how it is in MS Word.

Pls keep in mind that:
The drop down has the advantage that it shows only applied (+ some basic) styles.
It allows creating new styles.
And it shows frame styles - if frame is selected.
Comment 23 Yousuf Philips (jay) 2014-09-07 01:33:51 UTC
Created attachment 105848 [details]
my current mockup of a redesigned sidebar

(In reply to comment #22)
> (In reply to comment #10)
> > After more thinking about this issue, i think this is a perfect opportunity
> > to go beyond the drop down approach for styles in the toolbar and go for a
> > full visual paragraph style list, something similar to how it is in MS Word.
> 
> Pls keep in mind that:
> The drop down has the advantage that it shows only applied (+ some basic)
> styles.
> It allows creating new styles.
> And it shows frame styles - if frame is selected.

Yes it was a mistake to think that an ms word ribbon-styled paragraph style list would be suitable for the sidebar. The more suitable one would be similar to iwork pages, so that when the drop down is closed, the current style is styled in the displayed text.

I have been working on a new mockup for the sidebar, which can be seen in the attachment. It has re-organized sections, advanced features that are hidden by default, and uses larger icons. Those interested in more info can read it at this link < https://redmine.documentfoundation.org/boards/1/topics/69 >.
Comment 24 Maxim Monastirsky 2014-11-22 17:37:25 UTC
*** Bug 86443 has been marked as a duplicate of this bug. ***
Comment 25 Yousuf Philips (jay) 2015-06-14 00:26:55 UTC
Styles are treated differently between the different apps -

Writer - Paragraph and character styles
Calc - Cell styles
Impress - Graphic and presentation styles
Draw - Graphic styles

So with this difference, the best approach would be to create a styles section in the properties tab that would sit above the character section and it would contain comboboxes of the needed style types.

The primary style combobox (e.g. paragraph styles for writer) would have a preview of the style in it and it would have a large height, while the secondary style combobox (e.g. character styles for writer) wouldnt have a preview and would be of standard height. The size and preview of these comboboxes can be seen in attachment 105848 [details].
Comment 26 Evil Overlord 2015-06-14 01:27:14 UTC
(In reply to Yousuf (Jay) Philips from comment #25)
> Styles are treated differently between the different apps -
> 
> Writer - Paragraph and character styles
> Calc - Cell styles
> Impress - Graphic and presentation styles
> Draw - Graphic styles
> 
> So with this difference, the best approach would be to create a styles
> section in the properties tab that would sit above the character section and
> it would contain comboboxes of the needed style types.
> 
> The primary style combobox (e.g. paragraph styles for writer) would have a
> preview of the style in it and it would have a large height, while the
> secondary style combobox (e.g. character styles for writer) wouldnt have a
> preview and would be of standard height. The size and preview of these
> comboboxes can be seen in attachment 105848 [details].

I like that. Sounds like an excellent implementation of the idea.
Comment 27 Yousuf Philips (jay) 2015-06-14 10:33:45 UTC
(In reply to Evil Overlord from comment #26)
> I like that. Sounds like an excellent implementation of the idea.

Glad you like it.

So looking at what is currently possible for easy inclusion in the 'Styles' section, we are limited to having the Apply Style combobox (.uno:StyleApply) which works in Writer and Calc for paragraph and cell styles.

In order to get character styles in, we would need to create the control (bug 88512).
Comment 28 Commit Notification 2015-06-16 09:18:16 UTC
Rishabh Kumar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e436f31147c7eb75908a8750b0e4053c2efdca5b

tdf#73071:Styles tab addition to the sidebar for writer

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 29 Commit Notification 2015-06-16 14:45:53 UTC
Rishabh Kumar committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=31fcd558a2fdf892e190d9738c224a0752997903&h=libreoffice-5-0

tdf#73071: Styles tab addition to the sidebar for writer

It will be available in 5.0.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 30 Jean-Baptiste Faure 2015-06-16 20:05:01 UTC
Thank you very much for these commits. Works great in the master and LO 5.0 beta3+.
If I can suggest something, I would move the style dropdown list under Paragraph. Indeed when we will have the character style dropdown list, it will difficult to distinguish between both style lists.

Best regards. JBF
Comment 31 Yousuf Philips (jay) 2015-06-16 21:45:14 UTC
(In reply to Jean-Baptiste Faure from comment #30)
> If I can suggest something, I would move the style dropdown list under
> Paragraph. Indeed when we will have the character style dropdown list, it
> will difficult to distinguish between both style lists.

The reason for having it at the top is about showing its importance, similar to how it is the first control in the formatting toolbar. Once the character style drop down is created (bug 88512), then it would be possible to add it to the section, likely with a label before it. More work is needed to fully complete what is asked in this enhancement, so this report will stay open until then, but this is a great step forward.
Comment 32 Jean-Baptiste Faure 2015-06-23 08:20:12 UTC
Hi Rishabh Kumar,

I am afraid that your implementation produce some issue when you try to resize the sidebar when the properties tab is visible. In some cases I get an infinite loop between two sidebar widths.
I get the issue on my build of LO 5.0 RC1+ under Ubuntu (Unity) 15.04 x86-64.

Please, could you check on your side?

Best regards. JBF
Comment 33 Yousuf Philips (jay) 2015-06-23 11:07:36 UTC
(In reply to Jean-Baptiste Faure from comment #32)
> I am afraid that your implementation produce some issue when you try to
> resize the sidebar when the properties tab is visible. In some cases I get
> an infinite loop between two sidebar widths.
> I get the issue on my build of LO 5.0 RC1+ under Ubuntu (Unity) 15.04 x86-64.

That was reported in bug 78111, which was recently closed as working fine in 5.0, so it isnt likely related to Rishabh's work.
Comment 34 Jean-Baptiste Faure 2015-06-23 12:21:01 UTC
(In reply to Yousuf (Jay) Philips from comment #33)
> [...]
> That was reported in bug 78111, which was recently closed as working fine in
> 5.0, so it isnt likely related to Rishabh's work.

I wouldn't be so affirmative. Indeed I tested the current LO 5.0.0.1.0+ with and without the commit from Rishabh. Without this commit I am not able to reproduce bug 78111, and with this commit I reproduce it.
Note: bug 78111 has not been explicitly fixed by a commit, it has been closed as WorksForMe.

Best regards. JBF
Comment 35 Jean-Baptiste Faure 2015-06-23 12:32:20 UTC
follow-up to comment #34:
The problem seems to be linked to this file:
http://references.modernisation.gouv.fr/sites/default/files/Referentiel_General_Interoperabilite_V1.9.7-8.odt

I do not reproduce the problem with a new empty document.

Best regards. JBF
Comment 36 Yousuf Philips (jay) 2015-06-23 23:04:01 UTC
(In reply to Jean-Baptiste Faure from comment #34)
> I wouldn't be so affirmative. Indeed I tested the current LO 5.0.0.1.0+ with
> and without the commit from Rishabh. Without this commit I am not able to
> reproduce bug 78111, and with this commit I reproduce it.

Opened the doc in comment 35 and wasnt able to reproduce it in master (TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-06-20_01:01:56) on my linux mint xfce. Seems that this issue maybe be desktop environment related. Did notice that the minimum size of the sidebar was affected by the rendered size of the paragraph styles in the combobox.

> Note: bug 78111 has not been explicitly fixed by a commit, it has been
> closed as WorksForMe.

Was aware of that. :D Well i discussed the issue today with Rishabh before your comments and he said he had also noticed the freakout in the other bug and would look into the issue.

Would be good to add a screencast to the other bug and reopen it.
Comment 37 Commit Notification 2015-08-31 19:23:08 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1ba1a21aa6b77ef8d3d59b3658dfd2aa87d0dee2

tdf#73071 Enable styles content panel in calc and fix spacing issue

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 38 Commit Notification 2015-09-01 08:35:25 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6681627f700b058ec700b968ec222306962554ae&h=libreoffice-5-0

tdf#73071 Fix minor spacing issue in style section

It will be available in 5.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 39 Luke 2015-10-14 07:22:59 UTC
*** Bug 65351 has been marked as a duplicate of this bug. ***
Comment 40 tommy27 2015-11-08 07:38:39 UTC
@Jay
congrats, I've seen you did already a good job.
if the original report have all been pleased I proposed to set status to FIXED

If any residual problem still exists I suggest to open a new report as a follow-up of the current one which has already many comments and is getting hard to read.
Comment 41 Cor Nouws 2015-11-10 14:06:25 UTC
FYI: there is a discussion on the design mailing list wrt the styles in the side bar:

http://listarchives.libreoffice.org/global/design/msg07372.html
Comment 42 Juraj Václavík 2015-11-10 21:01:01 UTC
I prepared some ideas about formatting panel. I do not know, if it will be interesting for you, please see to bug 95731. There are some suggestions and some mock ups.
Comment 43 Yousuf Philips (jay) 2015-11-26 14:22:33 UTC
Might as well close this as paragraph styles are in writer and cell styles are in calc.
Comment 44 Robinson Tryon (qubit) 2015-12-16 05:32:27 UTC Comment hidden (obsolete)