Bug 65351 - Sidebar: Styles should be displayed first
Summary: Sidebar: Styles should be displayed first
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta1
Hardware: Other All
: high enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-Styles Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2013-06-04 13:33 UTC by pierre-yves samyn
Modified: 2017-07-27 20:32 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2013-06-04 13:33:36 UTC
Hello

The side bar is very well designed, thank you for this feature.

However the default view when:
- Select View> Sidebar,
- The buttons's order
- In the drop-down list of choices.

should be display styles (first button, first choice in the list).

View first properties encouraged to override the objects instead of using styles.

Best regards
Pierre-Yves
Comment 1 Cor Nouws 2013-06-04 14:00:57 UTC
Hi Pierre-Yves :)
Thanks for reporting!

I agree. Furthermore: I think the side bar is a nice piece of work which opens the possibility for some improvements in future.

Currently, it's just more or less doubling already existing functions. All controls for direct formatting both on the tool bar and in that nice panel.
Shiver ...

So currently it enhances the use of direct formating. The one and by far largest problem in office productivity work (and document exchange, compatibility etc etc and so forth...)

But: as I wrote: a change to improve something. As a first step, I strongly support your request.

Cheers - Cor
Comment 2 V Stuart Foote 2013-06-04 14:36:36 UTC
Agree, the default Properties panel currently emphasizes direct formatting vs. use of styles as represented in the Styles & Formatting panel -- and that is a valid UX discussion in further development of sidebar, and for that matter the Template Manager. But, direct formatting has its use for efficient creation and editing of documents, often because of a poorly implemented styling and template infrastructure.

But, as this experimental LibreOffice feature has not been developed or designed within LibreOffice, this UX discussion probably should be taken "upstream" where it belongs for the near term.

Stuart
Comment 3 Cor Nouws 2013-06-04 22:34:13 UTC
Hi Stuart,

(In reply to comment #2)

> But, as this experimental LibreOffice feature has not been developed or
> designed within LibreOffice, this UX discussion probably should be taken
> "upstream" where it belongs for the near term.

There´s some changed already in LibreOffice wrt styles, templates. On the user part. And for sure more in the code restructuring itself. 
So speaking of 'upstream' is a bit - let me say - unprecise ;)
But of course, this side thing initially came from IBM, and furthermore I fully respect that people work where they want on which feature.

Cheers, Cor
Comment 4 V Stuart Foote 2013-06-05 01:26:11 UTC
Hello Cor,
(In reply to comment #3)

> There´s some changed already in LibreOffice wrt styles, templates. On the
> user part. And for sure more in the code restructuring itself. 
> So speaking of 'upstream' is a bit - let me say - unprecise ;)
> But of course, this side thing initially came from IBM, and furthermore I
> fully respect that people work where they want on which feature.
> 
Not to too finely split hairs but to what changes and restructuring do you refer? 

I have yet to see a patch or adjustment to sidebar authored by anyone other than the primary sidebar devs at AOO, i.e. "upstream" for this experimental LO feature.  And, the only LO work I've noticed has been systematic cherry picks taken from our git repo of AOO svn, without substantive refactoring, committed verbatim into LO master.  So, really?

Stuart
Comment 5 Cor Nouws 2013-06-05 07:06:34 UTC
Hi Stuart,

(In reply to comment #4)

> Not to too finely split hairs but to what changes and restructuring do you
> refer? 

Different option in paragraph styles, different default styles, quite radical change in page style, different working of Ctrl+M. This just out of my head, so there prolly will be more.

> picks taken from our git repo of AOO svn, without substantive refactoring,

Sorry, but it seems you have to look better (but of course that discussion does not belong here.)
Kind regads,
Cor
Comment 6 Ysabeau 2013-10-03 13:23:30 UTC
(In reply to comment #0)
> Hello
> 
> The side bar is very well designed, thank you for this feature.
> 
> However the default view when:
> - Select View> Sidebar,
> - The buttons's order
> - In the drop-down list of choices.
> 
> should be display styles (first button, first choice in the list).
> 
> View first properties encouraged to override the objects instead of using
> styles.
> 

I agree thousand (and more if necessary) of times.
Comment 7 Samuel Mehrbrodt (CIB) 2014-08-24 11:54:23 UTC
There is nothing bad about direct formatting.
Most people don't know how to use styles and putting that view as default won't help them.

Please bring this to the UX-Advise list if you insist on this.
Comment 8 Thomas Arnhold 2014-08-24 17:37:49 UTC
I agree with Samuel. This should be well decided. I see no effort in having "Styles and Formatting" opening as the default Deck of the Sidebar. If we want to promote the Sidebar to the user, there will be only a small win - because he thinks of it as "Styles and Formatting" - which he rarely uses and closes it.

Moreover, be aware, that having "Styles and Formatting" as the default Deck in Impress makes absolutely no sense (I never heard of someone using this stuff there, and "Slide Properties" are much more of interest there).
Comment 9 Cor Nouws 2014-08-25 11:58:17 UTC
(In reply to comment #7)
> There is nothing bad about direct formatting.

Hmm, won't start that discussion here ;)
Comment 10 Cor Nouws 2014-08-25 12:01:36 UTC
(In reply to comment #8)
> I agree with Samuel. This should be well decided. I see no effort in having
> "Styles and Formatting" opening as the default Deck of the Sidebar. If we
> want to promote the Sidebar to the user, there will be only a small win -
> because he thinks of it as "Styles and Formatting" - which he rarely uses
> and closes it.


To be honest, I have a stronger believe in what was discussed somewhere else (issue? UX-list?? @Mirek2 ??) about giving styles a serious place in the properties deck..
Comment 11 V Stuart Foote 2014-08-25 13:51:30 UTC
(In reply to comment #8)

> Moreover, be aware, that having "Styles and Formatting" as the default Deck
> in Impress makes absolutely no sense (I never heard of someone using this
> stuff there, and "Slide Properties" are much more of interest there).

No sense because it is implemented in a strange legacy fashion, rather I would suggest the slide "Layouts" content panel for Impress does not belong in the --Properties-- tray, as it is formatting applied to each slide.

Rather that the existing --Styles and Formatting-- tray with the "Drawing Obejcts Styles" and "Presentation Styles" content panels, should be reworked and should include the selector for slide "Layout" formatting.

Properties would then only hold the direct formatting details of the styles/configurations applied to the Paragraph, Fontwork, or Drawing object selected active on the slide.
Comment 12 Cor Nouws 2014-11-13 09:13:12 UTC
Maybe split this issue in two:
 - enhancement to improve styles and formatting there
   (and if that really goes fine, open a discussion on making it default ;) )
 - enhancement to open side bar with pane that was active when last used?
Comment 13 Timur 2014-11-18 20:03:37 UTC
(In reply to Cor Nouws from comment #12)
> Maybe split this issue in two:
>  - enhancement to improve styles and formatting there
>    (and if that really goes fine, open a discussion on making it default ;) )
Is this an option: Bug 86443 - Sidebar: Add character and paragraph styles formatting drop-down box to Properties
>  - enhancement to open side bar with pane that was active when last used?
Good solution. This could be done immediately in this bug.
Comment 14 Cor Nouws 2014-11-18 20:47:33 UTC
(In reply to Timur from comment #13)

> >  - enhancement to improve styles and formatting there
> >    (and if that really goes fine, open a discussion on making it default ;) )
> Is this an option: Bug 86443 - Sidebar: Add character and paragraph styles
> formatting drop-down box to Properties

Yes, good catch.

> >  - enhancement to open side bar with pane that was active when last used?
> Good solution. This could be done immediately in this bug.

Then this issue should be blocked /headed by 86443
And the summary should be radically changed. So much that IMO a new issue is just as good..
Comment 15 Timur 2015-01-20 11:24:03 UTC
(In reply to Cor Nouws from comment #14)
> Then this issue should be blocked /headed by 86443
Bug 86443 - Sidebar: Add character and paragraph styles formatting drop-down box to Properties is a DUPE of Bug 73071 - Other: Sidebar: Styles are missing from Properties. "Depends" set.

> And the summary should be radically changed. So much that IMO a new issue is
> just as good..
Title changed from "Sidebar: default view is not Styles and formatting" to "Sidebar: open pane that was active when last used"
Comment 16 Timur 2015-01-27 10:44:31 UTC
In my last post, I marked this as dependent on 73071. But, please confirm, although it would be useful, they don't really have to depend, there can just be "See also".

https://wiki.documentfoundation.org/ReleaseNotes/4.4 says "the Sidebar now combines the functionalities of the old “Gallery” and “Styles & Formatting” floating panels, removing a lot of UI redundancy." which is fine.
But due to this annoying bug (Properties pane opens first and it doesn't have Style), I'm using “Styles & Formatting” floating panel and not Sidebar.
Comment 17 pierre-yves samyn 2015-02-20 11:07:59 UTC
Hi

(In reply to Timur from comment #16)
> In my last post, I marked this as dependent on 73071. But, please confirm,
> although it would be useful

Yes, I think too

Regards
Pierre-Yves
Comment 18 Jean-Francois Nifenecker 2015-09-25 16:44:46 UTC
Hi,

this bug submission is, IMO, not related to 73071. As the OP stated: the question is about the sidebar keeping track of its last state when the last LibO session was closed. As of v.5.0.1, this problem is still there.

The question about what should be the default pane in the sidebar is just unrelated and a whole question on its own.

Currently, as a professional writer, I want to have the Stylist pane visible by default but I can't. The Navigator is opened in a separate window but the Sidebar insists on displaying the Properties pane, even for documents I've been working on for some time.

So, to summarize: set whatever pane as default pane in the Sidebar (though I would prefer the Stylist ;) When the user selects another Sidebar pane when working on a document, further opening that document should activate the chosen pane.
Comment 19 Pierre C 2015-09-27 16:03:43 UTC
(In reply to Jean-Francois Nifenecker from comment #18)
> 
> So, to summarize: set whatever pane as default pane in the Sidebar (though I
> would prefer the Stylist ;) When the user selects another Sidebar pane when
> working on a document, further opening that document should activate the
> chosen pane.

I absolutely agree with that
Comment 20 Luke 2015-10-14 07:22:59 UTC
I agree with Jean-Francois. There are 2 completely separate issues being discussed here. The primary issue covered in the description is a dupe of 73071. The other is a dupe of 69534, where the module will remember if the sidebar is left open or closed.

*** This bug has been marked as a duplicate of bug 73071 ***
Comment 21 V Stuart Foote 2015-10-14 13:02:38 UTC
@Luke, *

As in the summary this is pretty cut and dry and does not duplicate bug 73071
This issue is whether to offer the current Properties content panel (with or with out style picker of bug 73071), or preferentially offer the Styles and Formatting content panel, or offer another content panel (perhaps a hybird of users choice, or the Navigator as Jean-Francois prefers).

That is to say... the default opening content panel in the Deck should not default to Properties--unless the user wants it to (through customization). 

Since we can not yet configure a choice of default (and retain that customization document to document, session to session) the default should be functional for the user.
Comment 22 Luke 2015-10-20 23:00:37 UTC
V Stuart Foote,
Both the original title and the description are asking for the styles to be added to the sidebar which is a dupe of bug 73071. Yes, this one is asking for it FIRST, which is where we added it. 

I know you want Writer to focus on styles. You've made this clear here and all through the bug tracker. While there are some interesting points raised here, they're buried in the 22 comments. So, it would be much more useful to open a new bug report, specifically with your request to hide paragraph properties by default. Hidden in here with the wrong title/description is a terrible way to promote your cause and just adds noise to the bug tracker.
Comment 23 V Stuart Foote 2015-10-21 00:23:12 UTC
@Luke,  no the original summary and issue in bug 65351 is *Sidebar: default view is not "Styles and formatting"*

The dominant position on the Sidebar's Tab bar unfortunately encourages direct formatting rather than efficient use of styles.

Also, I don't beleive I've ever advocated to "to hide paragraph properties by default" rather I've only consistently opined that Styles & Formatting should be the default landing deck--thereby deephasizing the Properties deck. 

That remains the situation.

So, while bug 73071 evolved into and has been implemented--adding an ill advised Styles dropdown "preview" content panel positioned prominently in the *Properties* deck--we still have the UI and UX issue of which is better GUI for supporting use of styles.

As it is now--neither Deck: Properties, nor Styles & Formatting--fulfills the needs.

Also even though bug 73071 has delivered a Style picker to the Properties deck--we still have the issue of customization where folks who really do work more effectively with styles rather than direct formatting will prefer to place 
the Styles and Formatting deck in the dominant position.

So in essence rather than cleaning up the existing Styles and Formatting deck and giving it top position--as this issue advised--we have instead duplicated a portion the Styles content panel for use as a picker on the Properties deck.  Again to the detriment of using styles rather than direct formatting.

Stuart
Comment 24 Olivier R. 2015-10-21 06:29:02 UTC
I confirm. This bug is not a duplicate of 73071.

But instead of having a default panel for the sidebar, I think the sidebar should just remember the last panel we selected. Or we should have a setting to choose the default panel we want.

It’s annoying to have to change back to the style panel all the time.

If I select the stylist and close LO. At restart, LO show me the properties I never use. I have to switch back to the stylist.

If I select the stylist and open a new document, LO still displays the properties panel, and I have to switch *again* the stylist.

And again, and again, and again. Each time I open a document.

There is an UX issue there.
Comment 25 Yousuf Philips (jay) (retired) 2017-07-27 20:32:47 UTC
The styles deck shouldn't be displayed first and the last used deck should be shown on restart (bug 67770).