Bug 79731 - FILESAVE: PPTX: error saving presentation with table
Summary: FILESAVE: PPTX: error saving presentation with table
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta1
Hardware: Other All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard:
Keywords: bibisected, regression
: 85813 (view as bug list)
Depends on:
Blocks: mab4.3
  Show dependency treegraph
 
Reported: 2014-06-06 16:56 UTC by Jacobo Aragunde Pérez
Modified: 2015-12-15 11:03 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Test case (18.57 KB, application/vnd.oasis.opendocument.presentation)
2014-06-06 16:56 UTC, Jacobo Aragunde Pérez
Details
console logs with master sources (138.36 KB, text/plain)
2014-06-06 20:52 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jacobo Aragunde Pérez 2014-06-06 16:56:16 UTC
Created attachment 100523 [details]
Test case

The test case is a presentation that contains a table pasted from another document.

To reproduce the bug:

1. Just open the test case
2. and try to save the document as .pptx.

LO will fail and the file won't be saved.

The bug doesn't happen in LibreOffice 4.2 branch but it does in 4.3 and 4.4.
Comment 1 Julien Nabet 2014-06-06 20:52:09 UTC
Created attachment 100560 [details]
console logs with master sources

On pc Debian x86-64 with master sources updated yesterday, I could reproduce the problem.
I attached detailed console logs (since I build with debug mode)
Comment 2 Marc Kaulisch 2014-07-16 20:40:43 UTC
Very annoying and can be reproduced with the 4.3.0.2 version on Windows 8.1
Comment 3 David Filiatrault 2014-08-29 17:48:34 UTC
Reproduced on with LO 4.3.1.1 on OSX 10.9.4
Comment 4 ign_christian 2014-08-30 02:32:23 UTC
Confirm regression, not occured with LO 4.2.6.3 - Ubuntu 12.04 x86
Comment 5 raal 2014-08-31 13:55:11 UTC
There are only 'skip'ped commits left to test.
The first bad commit could be any of:
bb138a397a1f29902ce6c69bb161254832081623
c2e967de61ee4b1291703af64dac729a8ada79fb
7d9e0cb59cf7fe20b31a5c291238b5391834c278
We cannot bisect more!

git bisect log
# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574
# bad: [4850941efe43ae800be5c76e1102ab80ac2c085d] source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b
git bisect bad 4850941efe43ae800be5c76e1102ab80ac2c085d
# skip: [a043626b542eb8314218d7439534dce2fc325304] source-hash-9379a922c07df3cdb7d567cc88dfaaa39ead3681
git bisect skip a043626b542eb8314218d7439534dce2fc325304
# skip: [aba65c3e4c0df07e4909aeefb758cdb688242bf6] source-hash-827524abfb4b577d08276fde40929a9adfb7ff1a
git bisect skip aba65c3e4c0df07e4909aeefb758cdb688242bf6
# skip: [aba65c3e4c0df07e4909aeefb758cdb688242bf6] source-hash-827524abfb4b577d08276fde40929a9adfb7ff1a
git bisect skip aba65c3e4c0df07e4909aeefb758cdb688242bf6
# good: [c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31] source-hash-c69ed33628ec0b7abf6296539cf280d6c4265930
git bisect good c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31
# good: [c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31] source-hash-c69ed33628ec0b7abf6296539cf280d6c4265930
git bisect good c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31
# good: [30cde618212ecaf5725321372bd1b8339f8e2b9f] source-hash-137f872aa8e6e598e7c7ed1ffa4d21e580e22bdb
git bisect good 30cde618212ecaf5725321372bd1b8339f8e2b9f
# good: [30cde618212ecaf5725321372bd1b8339f8e2b9f] source-hash-137f872aa8e6e598e7c7ed1ffa4d21e580e22bdb
git bisect good 30cde618212ecaf5725321372bd1b8339f8e2b9f
# bad: [306d62ec4b911895f08f2bb8efefebed7ac795f0] source-hash-735bd120c9ee2d9bb3514907936c27efb75d7282
git bisect bad 306d62ec4b911895f08f2bb8efefebed7ac795f0
# bad: [306d62ec4b911895f08f2bb8efefebed7ac795f0] source-hash-735bd120c9ee2d9bb3514907936c27efb75d7282
git bisect bad 306d62ec4b911895f08f2bb8efefebed7ac795f0
# good: [835ce851abe657bb5a8238693ea924287e6890c0] source-hash-1e53784811458563b36fd4cbaa15c2f526a7161b
git bisect good 835ce851abe657bb5a8238693ea924287e6890c0
# good: [835ce851abe657bb5a8238693ea924287e6890c0] source-hash-1e53784811458563b36fd4cbaa15c2f526a7161b
git bisect good 835ce851abe657bb5a8238693ea924287e6890c0
# bad: [7d9e0cb59cf7fe20b31a5c291238b5391834c278] source-hash-c828319753558e25a48ce7808604bcc648f2483d
git bisect bad 7d9e0cb59cf7fe20b31a5c291238b5391834c278
# skip: [c2e967de61ee4b1291703af64dac729a8ada79fb] source-hash-17dab5bf8efb3fd676e6854474b199b681d0dc28
git bisect skip c2e967de61ee4b1291703af64dac729a8ada79fb
# good: [98483e4e4f5256c92649d861f8deaf380e234906] source-hash-fa7c24e0e7b300fb7ac6ff7202a57eb1c60eb0b6
git bisect good 98483e4e4f5256c92649d861f8deaf380e234906
# skip: [bb138a397a1f29902ce6c69bb161254832081623] source-hash-acf233e2bb259759c9167a32e17fcf13e1f54f6c
git bisect skip bb138a397a1f29902ce6c69bb161254832081623
# only skipped commits left to test
# possible first bad commit: [7d9e0cb59cf7fe20b31a5c291238b5391834c278] source-hash-c828319753558e25a48ce7808604bcc648f2483d
# possible first bad commit: [bb138a397a1f29902ce6c69bb161254832081623] source-hash-acf233e2bb259759c9167a32e17fcf13e1f54f6c
# possible first bad commit: [c2e967de61ee4b1291703af64dac729a8ada79fb] source-hash-17dab5bf8efb3fd676e6854474b199b681d0dc28
Comment 6 Andras Timar 2014-11-04 12:53:48 UTC
*** Bug 85813 has been marked as a duplicate of this bug. ***
Comment 7 Andras Timar 2014-11-04 12:54:35 UTC
(In reply to Andras Timar from comment #6)
> *** Bug 85813 has been marked as a duplicate of this bug. ***

The duplicate bug has backtrace and it is bisected.
Comment 8 Miklos Vajna 2014-11-04 17:02:34 UTC
Adding myself to CC, the bisect says I broke this.
Comment 10 Timur 2014-11-06 12:06:58 UTC
Will this be backported to 4.3?
Comment 11 Robinson Tryon (qubit) 2015-12-15 11:03:33 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]