Bug 85813 - PPTX export: Impress table cannot be exported
Summary: PPTX export: Impress table cannot be exported
Status: RESOLVED DUPLICATE of bug 79731
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.4.0
Keywords: bisected
Depends on:
Blocks:
 
Reported: 2014-11-03 16:15 UTC by Andras Timar
Modified: 2014-11-05 11:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
bugdoc (10.75 KB, application/vnd.oasis.opendocument.presentation)
2014-11-03 16:15 UTC, Andras Timar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andras Timar 2014-11-03 16:15:57 UTC
Created attachment 108847 [details]
bugdoc

1. Open the sample file.
2. Save as PPTX
3a. Crash (dbgutil build) 
-- OR --
3b. "Error saving the document ...:
     Write Error.
     The file could not be written."
Comment 1 Andras Timar 2014-11-03 16:18:35 UTC
2440d0ba34d6cbc9eae6d2cb196a964840f084e4 is the first bad commit
commit 2440d0ba34d6cbc9eae6d2cb196a964840f084e4
Author: Miklos Vajna <vmiklos@collabora.co.uk>
Date:   Thu Dec 12 10:24:10 2013 +0100

    oox: allow a callback to be registered for shape text DML export
    
    Change-Id: Ice4dea8da117f61d947ad14ebbfccae0d2ed94df


backtrace:

#0  0x00002aaaab29d849 in raise () from /lib64/libc.so.6
#1  0x00002aaaab29ecd8 in abort () from /lib64/libc.so.6
#2  0x00002aaaabca6655 in __gnu_cxx::__verbose_terminate_handler() () from /usr/lib64/libstdc++.so.6
#3  0x00002aaaabca47c6 in ?? () from /usr/lib64/libstdc++.so.6
#4  0x00002aaaabca47f3 in std::terminate() () from /usr/lib64/libstdc++.so.6
#5  0x00002aaaabca4806 in ?? () from /usr/lib64/libstdc++.so.6
#6  0x00002aaaabca4482 in __cxa_call_unexpected () from /usr/lib64/libstdc++.so.6
#7  0x00002aaadc066d96 in oox::core::PowerPointExport::exportDocument (this=0x2cef360)
    at /home/timar/libreoffice-master/sd/source/filter/eppt/pptx-epptooxml.cxx:341
#8  0x00002aaacf6321c9 in oox::core::FilterBase::filter (this=0x2cef360, rMediaDescSeq=uno::Sequence of length 11 = {...})
    at /home/timar/libreoffice-master/oox/source/core/filterbase.cxx:468
#9  0x00002aaacf8fe927 in oox::ppt::PowerPointImport::filter (this=0x2f92dd0, rDescriptor=uno::Sequence of length 11 = {...})
    at /home/timar/libreoffice-master/oox/source/ppt/pptimport.cxx:157
#10 0x00002aaaae3f7156 in SfxObjectShell::ExportTo (this=0x20c7ff0, rMedium=...)
    at /home/timar/libreoffice-master/sfx2/source/doc/objstor.cxx:2418
#11 0x00002aaaae3f2137 in SfxObjectShell::SaveTo_Impl (this=0x20c7ff0, rMedium=..., pSet=0x0)
    at /home/timar/libreoffice-master/sfx2/source/doc/objstor.cxx:1560
#12 0x00002aaaae3f91b5 in SfxObjectShell::PreDoSaveAs_Impl (this=0x20c7ff0, rFileName="file:///home/timar/Documents/table.pptx", 
    aFilterName="Impress MS PowerPoint 2007 XML", pParams=0x30b8530) at /home/timar/libreoffice-master/sfx2/source/doc/objstor.cxx:2834
Comment 2 Andras Timar 2014-11-03 16:28:35 UTC
write slide: 0
----------------
mType: "drawing.Table"
write shape: com.sun.star.drawing.TableShape
write shape transformation
terminate called after throwing an instance of 'com::sun::star::beans::UnknownPropertyException'
Comment 3 tommy27 2014-11-03 19:36:54 UTC
reproducible under Win7x64 using LibO 4.3.2.2 and 4.4.0.0.alpha1+
Build ID: 1baad070d8c2a38581cf33d803c5043f1974647f
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-01_00:15:06
Comment 4 Andras Timar 2014-11-04 12:53:48 UTC

*** This bug has been marked as a duplicate of bug 79731 ***
Comment 5 Commit Notification 2014-11-05 11:24:47 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=02e52b15908a6d89b4aeb3c349e7414240eb9563

fdo#85813 drawingML export: fix handling of impress tables

It will be available in 4.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.