Bug Hunting Session
Bug 79755 - Suggest non defective Java runtime environment (JRE)
Summary: Suggest non defective Java runtime environment (JRE)
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta2
Hardware: Other Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Java-Runtime-JRE
  Show dependency treegraph
 
Reported: 2014-06-06 23:59 UTC by Yousuf Philips (jay) (retired)
Modified: 2016-10-16 10:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
the JRE defective dialog (21.01 KB, image/jpeg)
2014-06-06 23:59 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-06-06 23:59:06 UTC
Created attachment 100571 [details]
the JRE defective dialog

On Windows 7 with either java 7 update 51 or java 8 update 5, every time i try to run a macro through Tools > Macros > Run Macro..., i would get the error message titled 'JRE is Defective' requesting to select a different version or install a new one. So i'd like to suggest that a link be added to the dialog of where to get a new good version.
Comment 1 Jean-Baptiste Faure 2014-06-07 11:45:17 UTC
Perhaps it is a bug in the detection mechanism.

Best regards. JBF
Comment 2 m.a.riosv 2014-06-07 12:13:19 UTC
I don't think so, maybe Jay has a 64 bits Java version, what it's no possible to use with LibreOffice, as there is no 64 bits version for LibreOffice in Windows.

With a 32 bits Java version, from a long time it has been fine for me.

And to use Java in LibreOffice I think is needed to select what Java use in Menu/Tools/LibreOffice/Advanced even if it's only one installed.
Comment 3 Yousuf Philips (jay) (retired) 2014-06-07 12:33:59 UTC
(In reply to comment #2)
> I don't think so, maybe Jay has a 64 bits Java version, what it's no
> possible to use with LibreOffice, as there is no 64 bits version for
> LibreOffice in Windows.

Yes i have the 64-bit of Java.

> 
> With a 32 bits Java version, from a long time it has been fine for me.
> 

Yes using a 32-bit version doesn't show the same error. But whether its a 32-bit or 64-bit version of java, why should it show such a message when its not a defective version. And when it does show such a message, we should be able to point users to where they can get a non-defective version or instruct them to use the 32-bit version.

> And to use Java in LibreOffice I think is needed to select what Java use in
> Menu/Tools/LibreOffice/Advanced even if it's only one installed.

That had already been set. :)
Comment 4 Yousuf Philips (jay) (retired) 2014-06-25 03:22:49 UTC
Closing this as the problem is that LibO doesnt support 64-bit java, and bug 80509 is opened to solve this.