Bug 79856 - SVG regression in vector letters
Summary: SVG regression in vector letters
Status: RESOLVED DUPLICATE of bug 78554
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2014-06-09 23:28 UTC by Yousuf Philips (jay) (retired)
Modified: 2016-02-08 15:51 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
some letters on the book of the shield have filled enclosures. (212.79 KB, image/png)
2014-06-09 23:28 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-06-09 23:28:02 UTC
Created attachment 100775 [details]
some letters on the book of the shield have filled enclosures.

In attachment 78926 [details] from bug 64549, i noticed a regression in the lettering on the shield of the attached file from 4.1.6 to 4.2.4 or 4.3 beta 2. Tested on Linux Mint.
Comment 1 Joel Madero 2014-06-09 23:33:06 UTC
Confirmed:

Ubuntu 14.04 x 64
LibreOffice Master
Date of Build: Fri Jun 6 21:27:52 2014 +0100

Note that before the nipple on the breast did not show - now that shows but the letters render poorly (P and D) - likely related I think
Comment 2 Yousuf Philips (jay) (retired) 2014-06-10 02:52:17 UTC
in addition to the nipple showing in 4.2, the mermaid has a lower lip, more scales on the tale, and a belly button. the poorly rendered letters are A, R, and D, not P (joel must have been so mesmerized by the nipple).
Comment 3 Michael Stahl (CIB) 2014-06-10 22:05:29 UTC
4.2.0.4 had *both* nipple and proper letters ... up to 4.2.3.3.

ah looks like this one did it:

commit 0462b477b7e1006282b28ec96ce6f4bcaa1a3dd0
Author:     Tomaž Vajngerl <tomaz.vajngerl@collabora.com>
AuthorDate: Wed Apr 16 09:40:29 2014 +0200
Commit:     Andras Timar <andras.timar@collabora.com>
CommitDate: Fri Apr 18 11:55:10 2014 +0000

    fdo#74743 avoid infinite loop when gathering "svg" element styles
Comment 4 Yousuf Philips (jay) (retired) 2014-06-10 23:38:46 UTC
Adding bfoman and jorendc as the nipple saga continues. Two guys so consumed about the title of the previous bug report to actually check if the nipple was there or not. You guys crack me up. :)

Glad you were able to track it down so quickly Michael. You seem to be on a role today as i've gotten alot of emails from you to many triaged bugs. :)
Comment 5 Xisco Faulí 2014-07-16 08:45:47 UTC
The following commit fixes this issue as well:

Joren De Cuyper committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f6df52aa3aad9c7650b6ca051d9a28c4ccb6a060

fdo#78554 - SVG: Text from SVG no longer displayed in LibreOffice

Mark it as duplicated and close it.

*** This bug has been marked as a duplicate of bug 78554 ***