Bug 79927 - LibreOffice Calc very slow to plot xy line graphic
Summary: LibreOffice Calc very slow to plot xy line graphic
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Chart
  Show dependency treegraph
 
Reported: 2014-06-11 19:38 UTC by giovanni
Modified: 2020-01-26 16:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
test file-8500 lines. With a graphic. (360.32 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-06-11 19:38 UTC, giovanni
Details

Note You need to log in before you can comment on or make changes to this bug.
Description giovanni 2014-06-11 19:38:09 UTC
Created attachment 100900 [details]
test file-8500 lines. With a graphic.

Drawing a xy graphic with 8500+ lines takes too long.
Resizing the same graphic to a bigger size takes too long.
with over 10000 data points i needed to kill the program.

A workaround is to do the following:
1)Disable anti-aliasing. 
2)Plot/Resize.
3)Enable anti-aliasing.
This provides a much faster way, but should not be needed.


This problem does not occur with simple linear graphics.
Comment 1 Kevin Suo 2014-06-13 02:26:52 UTC
Comment on attachment 100900 [details]
test file-8500 lines. With a graphic.

Fixed MIME Type.
Comment 2 Kevin Suo 2014-06-13 03:01:54 UTC
Hi giovanni,

I do not reproduce the "long time" problem with your xy scatter chart, Drawing a xy scatter chart and resizing the chart was done within 5 seconds, no freezing.

However, I encounter the freeze issue when I was trying to draw a "line chart: lines only". It takes 20+ seconds for the chart to finish drawing. (This may be a different problem and I will consider to file a saparate bug report)

Steps to reproduce:
1. Open attachment 100900 [details];
2. Insert -> Object -> Chart -> Chart type: Line (Lines Only) -> Next -> Choose "First column as label", finish.

Current behaviour:
Calc freezes for more than 20 seconds to draw the line chart.

Version 4.2.5.1 and 4.3.0.0 beta2
OS: Windows XP SP3.
Comment 3 giovanni 2014-06-15 21:38:33 UTC
Sorry for the lack of infomation. 
Using the xy scatter chart, but not the dots only, any of the other options to draw the xy scatter chart, line and dots, only lines or the 3d lines.
Using the option to draw only the dots does not reproduce the problem.
Comment 4 Tom 2014-08-10 13:28:33 UTC
Hi,

Just to confirm - I was able to reproduce giovanni's problem in LO 4.1 and 4.3. And I have been experiencing poor performance with graphs for large data sets (around 10k rows and more) in both LibreOffice/OpenOffice. What is rendered in Excel in a snap, can take minutes in LO, to the point that it becomes unusable.

Also, I believe this should be merged with at least the following two:

"Bug 70872 - Calc very slow with charts with large numbers"
https://bugs.freedesktop.org/show_bug.cgi?id=70872

Whis was marked as a "duplicate" of:
"Bug 80677 - UI: Very sluggish with larger data sets"
https://bugs.freedesktop.org/show_bug.cgi?id=80677

Is there anyone looking at resolving this issue, please?
Comment 5 Mike 2014-10-26 19:38:16 UTC
CONFIRMED on Slack 14.1 + LO 4.4.0.0.alpha1.

Repro Steps:
- Grabbed the attachment that was provided by giovanni.

I can confirm the long drawing time for the graph, and for resizing when increasing the size of the graph.  However, shrinking the graph doesn't take long at all.
Comment 6 QA Administrators 2016-02-21 08:36:30 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2017-03-06 15:31:59 UTC Comment hidden (obsolete)
Comment 8 Thomas Lendo 2018-11-04 01:41:37 UTC
Can't reproduce the steps in comment 2 with Version: 6.2.0.0.alpha1+
Build ID: 612a107464c1889fdc4806a3c86da8c2fbf452c8
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); Calc: threaded
Comment 9 QA Administrators 2019-11-05 03:29:30 UTC Comment hidden (obsolete)
Comment 10 Julien Nabet 2020-01-26 15:26:22 UTC
Following Thomas Lendo's comment, could someone who had the slowdown could give a new try with last LO version 6.3.4?
Comment 11 Tom 2020-01-26 15:54:33 UTC
(In reply to Julien Nabet from comment #10)
> Following Thomas Lendo's comment, could someone who had the slowdown could
> give a new try with last LO version 6.3.4?

Hi Julien, there is no severe slowdown in 6.3.4.2, i.e. the interface is now responsive, and the graph renders much faster (~1-1.5s) despite running the test on a similar spec machine to the one before (as per my comment #4).

Version: 6.3.4.2
Build ID: 1:6.3.4-0ubuntu0.18.04.1~lo2
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded
Comment 12 Julien Nabet 2020-01-26 16:24:24 UTC
(In reply to Tom from comment #11)
> ...
> Hi Julien, there is no severe slowdown in 6.3.4.2, i.e. the interface is now
> responsive, and the graph renders much faster (~1-1.5s) despite running the
> test on a similar spec machine to the one before (as per my comment #4).
> ...

Thank you Tom for your quick feedback! :-)
Comment 13 Julien Nabet 2020-01-26 16:25:00 UTC
Argh, I changed to FIXED by error, let's revert to WFM