Download it now!
Bug 79965 - Error with Links in imagemap when exporting to PDF
Summary: Error with Links in imagemap when exporting to PDF
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.3 all versions
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: dataLoss, filter:pdf, implementationError
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2014-06-13 03:43 UTC by xavier
Modified: 2019-12-24 10:58 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
the source odt file and the result pointing to local folder (217.12 KB, application/zip)
2014-06-13 03:43 UTC, xavier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xavier 2014-06-13 03:43:04 UTC
Created attachment 100947 [details]
the source odt file and the result pointing to local folder

Problem description: 
Error with Links in imagemap when exporting to PDF

Steps to reproduce:
1. ....insert image
2. ....add url in imagemap
3. ....export as PDF

Current behavior:
The hyperlink opens the current directory where the PDF is.

Expected behavior:
http://Google.com
              
Same problem with diferent versions of LibreOffice 3x.x and 4x.x
Operating System: All
Version: 4.2.3.3 release
Comment 1 tommy27 2014-06-13 09:15:30 UTC
confirmed with LibO 4.2.4.2 under WinXP 32bit

please exactly define your O/S
Comment 2 QA Administrators 2016-09-20 10:02:18 UTC Comment hidden (obsolete)
Comment 3 Lehonti Ramos 2016-12-13 05:40:53 UTC
Confirmed with LibreOffice 5.1.4.2 under Ubuntu MATE 16.04 x64. It is reasonable to expect that the bug remains under all platforms.

The original poster says that the exported link points to the current folder. In my case, the behavior holds true for LibreOffice Writer, but in LibreOffice Impress there aren't hyperlinks at all. I also observed that the location it points to doesn't change even if you move the PDF to another folder.
Comment 4 QA Administrators 2017-12-14 07:09:14 UTC Comment hidden (obsolete)
Comment 5 ace_dent 2018-02-09 22:03:57 UTC
Reproduced.
As with Impress, the PDF produced in Drawing simply didn't export any of the hyperlinks.

Version: 5.4.1.2
Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
Locale: en-GB (en_GB.UTF-8); Calc: group
Comment 6 QA Administrators 2019-02-10 03:43:55 UTC Comment hidden (obsolete)
Comment 7 Timur 2019-12-24 10:58:18 UTC
When this was reported, there used to be image right-click "ImageMap" that doesn't exist now in LO.
I see that source.odt was saved with link to Google.com and that link is still shown with recent LO and it can't be exported, while ctrl+click will not open it. 
But double click opens standard Image-Hyperlink where we can type that or some other link.

OTOH, if we use image right-click Properties, and set Hyperlink, it works and PDF saved link opens.
So, this seems to be resolved.
Transition wasn't done well, because we still see wrong those previous links.
But that in my view, doesn't justify to keep the bug open.

Tested with master LO 6.5+.