Bug 80023 - Creating a new document via Windows right-click New->Opendocument spreadsheet sets part of document to english in non-English Libreoffice
Summary: Creating a new document via Windows right-click New->Opendocument spreadsheet...
Status: RESOLVED DUPLICATE of bug 35912
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-14 12:22 UTC by Toni Saarela
Modified: 2017-06-23 15:14 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Toni Saarela 2014-06-14 12:22:59 UTC
Tested with Windows 7 x64 English version, but Libreoffice was not English, in this case Finnish version was used. 

The following report works with Libreoffice Calc, possibly with others. Below when I say Libreoffice, I mean Libreoffice Calc.

Steps:

Don't start Libreoffice and make sure it is not running. Instead, right-click on desktop and select New from the popup menu. Now select Opendocument spreadsheet, although since it is not an English version, you see something different, like in Finnish it is "Opendocument-laskentataulukko".

All good so far. 

Now double-click the newly created empty spreadsheet file. Notice how at the bottom of the screen, the titles for different sheets are named Sheet1, Sheet2, Sheet3, even though this is supposed to be non-English version.

Now close the file and Libreoffice. Now start Libreoffice manually, which automatically opens a new spreadsheet. Notice how now the different sheets are not named in English anymore, in Finnish version they are called Taulukko1 and so on, which means Sheet1. This is correct.

Same happens if you select File-New and create a new spreadsheet, it uses correct language, but not if you use the method described above, without starting Libreoffice first.
Comment 1 Toni Saarela 2014-06-14 17:57:25 UTC
Also occurs in 4.2.5.1 RC 1.
Comment 2 raal 2014-09-07 15:44:15 UTC
Hello,
Thank you for submitting the bug. I can confirm that the bug is present in version 4.3.1.2 (Czech version).
Comment 3 QA Administrators 2015-10-14 19:56:47 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2015-12-03 14:34:29 UTC
Maybe related to bug 90286
Comment 5 QA Administrators 2017-01-03 19:40:49 UTC Comment hidden (obsolete)
Comment 6 Buovjaga 2017-06-23 15:14:36 UTC

*** This bug has been marked as a duplicate of bug 35912 ***