Download it now!
Bug 80270 - FORMATTING: if a Table of contents (TOC) in Writer is over two pages, it is impossible to change page style of the second page
Summary: FORMATTING: if a Table of contents (TOC) in Writer is over two pages, it is i...
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: TableofContents-Indexes Writer-Styles-Page
  Show dependency treegraph
 
Reported: 2014-06-20 07:22 UTC by delbouys
Modified: 2020-02-22 08:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
IndexTwoPages document (15.66 KB, application/vnd.oasis.opendocument.text)
2014-06-20 09:32 UTC, pierre-yves samyn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description delbouys 2014-06-20 07:22:36 UTC
Problem description: 

When you create a table of contents with Writer, if the table of contents is more than one page, it is impossible to change the page style of the second page.
The style of the second page is always the default style

Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior:

Expected behavior:

              
Operating System: Windows 8
Version: 4.1.6.2 release
Comment 1 pierre-yves samyn 2014-06-20 09:31:41 UTC
Hi 

I reproduce on windows 7/64 & Version: 4.3.0.1
Build ID: 67f5430184326974072b65403ef1d9d934fc4481

I change from bug to enhancement: this is not strictly a bug.

The style of second page is not always "default" (the style of the first page is kept).

There is a workaround :
- Edit the index, Index/Table tab
-Unprotect against manual changes

See the IndexTwoPages attached.

You can modify the text flow, but beware to no longer update the index


Thank's for reporting
Regards
Pierre-Yves
Comment 2 pierre-yves samyn 2014-06-20 09:32:20 UTC
Created attachment 101421 [details]
IndexTwoPages document
Comment 3 Mike Kaganski 2020-02-21 05:31:07 UTC
I cannot reproduce.

I do:
1. Create a page style for following pages of ToC (e.g., landscape);
2. Create a page style for first page of ToC, and set the style created in #1 as Next style on Organizer tab;
3. It works as expected with long ToC

Version: 6.4.1.1 (x64)
Build ID: 56f3c78975db08733f771c53643b5d1aa7c57567
CPU threads: 12; OS: Windows 10.0 Build 18363; UI render: GL; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: CL
Comment 4 Mike Kaganski 2020-02-21 06:15:10 UTC
It worked that way already in OOo 3.2.0.

So I cannot understand what's missing, and what is the proposed enhancement. Both ways is and was working: the "proper" one using page styles' "Next style", and using manual page breaks with page styles.

Since the actual *proposal* is missing (like "Add this"), and the premise is wrong (it's in fact *possible* to change page style of the second page), I suggest close INVALID.
Comment 5 pierre-yves samyn 2020-02-22 08:35:43 UTC
Hi

(In reply to Mike Kaganski from comment #4)
> So I cannot understand what's missing

What's missing:
- Click the 1st paragraph of the second index page and then do Insert> More Breaks> Manual break (to choose the page style).
- Or edit the same 1st paragraph text flow.

Manual page break works in my sample file because I unchecked the index protection against manual changes but:

- this is not the default value of this option
- it's lost when the index is updated.

In any case, I fully agree that, as it works with the page style sequencing, we classify this request as INVALID.

To tell the truth, I don't remember or understand why I supported this request :)
Comment 6 Mike Kaganski 2020-02-22 08:57:09 UTC
(In reply to pierre-yves samyn from comment #5)
> What's missing:
> - Click the 1st paragraph of the second index page and then do Insert> More
> Breaks> Manual break (to choose the page style).
> - Or edit the same 1st paragraph text flow.
> 
> Manual page break works in my sample file because I unchecked the index
> protection against manual changes but:
> 
> - this is not the default value of this option
> - it's lost when the index is updated.

Which is the only way it should be. ToC is not just any text, it's an auto-generated field. The same way, you may only mark some part of ToC bold or add your custom text there only removing the protection; and the same way it is reverted when index is regenerated. A "paragraph" in ToC which you make breaking with a page style doesn't exist when ToC is regenerated: ToC does not edit its paragraphs, it creates them anew. Say, you changed chapter headings; rearranged the chapters; added new or removed existing. Which paragraph in the new ToC is the paragraph you modified in the old ToC?

> In any case, I fully agree that, as it works with the page style sequencing,
> we classify this request as INVALID.
> 
> To tell the truth, I don't remember or understand why I supported this
> request :)

:-) So let's do it.