Download it now!
Bug 80298 - VIEWING PRINTING: wrong work with svg images inserted into document
Summary: VIEWING PRINTING: wrong work with svg images inserted into document
Status: RESOLVED DUPLICATE of bug 78554
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-20 17:46 UTC by Alex
Modified: 2015-03-03 12:55 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Needed files for testing (336.50 KB, application/zip)
2014-06-20 17:46 UTC, Alex
Details
svg source (37.23 KB, application/vnd.oasis.opendocument.graphics)
2014-06-20 17:49 UTC, Alex
Details
svg file (92.75 KB, image/svg+xml)
2014-06-20 17:49 UTC, Alex
Details
Test odt (104.10 KB, application/vnd.oasis.opendocument.text)
2014-06-20 17:50 UTC, Alex
Details
Screenshot of bug (93.74 KB, image/png)
2014-06-20 17:50 UTC, Alex
Details
Screenshot of how it should be (100.55 KB, image/png)
2014-06-20 17:51 UTC, Alex
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2014-06-20 17:46:31 UTC
Created attachment 101442 [details]
Needed files for testing

Since Libre Office 4.2.4 writer shows and prints inserted svg image. All text disappears. Version 4.2.3.3 works fine.
By making some experiments it seems that the problem is connected to 
..\program\svgiolo.dll
If you replace the newer one with the one from 4.2.3.3 everything starts to work fine.
In the attachment .zip there are 
- libre draw document (the source of svg)
- svg
- test odt document

- screenshot from 4.2.4 & 4.2.5
- screenshot from 4.2.5.2 with svgiolo.dll replaced with version 4.2.3.3
Comment 1 Alex 2014-06-20 17:49:35 UTC
Created attachment 101443 [details]
svg source
Comment 2 Alex 2014-06-20 17:49:59 UTC
Created attachment 101444 [details]
svg file
Comment 3 Alex 2014-06-20 17:50:18 UTC
Created attachment 101445 [details]
Test odt
Comment 4 Alex 2014-06-20 17:50:53 UTC
Created attachment 101446 [details]
Screenshot of bug
Comment 5 Alex 2014-06-20 17:51:35 UTC
Created attachment 101447 [details]
Screenshot of how it should be
Comment 6 Alex 2014-06-20 17:58:06 UTC
Updated description to prevent misunderstanding

Since Libre Office 4.2.4 writer shows and prints inserted svg images wrong. All text disappears. Version 4.2.3.3 works fine though.
By making some experiments it seems that the problem is connected to 
..\program\svgiolo.dll
If you replace the newer one with the one from 4.2.3.3 everything starts to work fine.
In the attachment .zip there are 
- libre draw document (the source of svg)
- svg
- test odt document

- screenshot from 4.2.4 & 4.2.5
- screenshot from 4.2.5.2 with svgiolo.dll replaced with version 4.2.3.3
Comment 7 Cor Nouws 2014-06-20 22:03:46 UTC
Hi Alex,

Thanks for reporting. I guess that this is already reported in issue 78557 or in issue 78554 ?

ciao,
Cor
Comment 8 Alex 2014-06-21 03:54:08 UTC
(In reply to comment #7)
> Hi Alex,
> 
> Thanks for reporting. I guess that this is already reported in issue 78557
> or in issue 78554 ?
> 
> ciao,
> Cor

Seems like one part (about printing and PDF) is reported in issue 78557 and other one (about viewing) - in issue 78554.
Anyway I figured out that it seems to be connected only to one lib (svgiolo.dll in win version).
So now I'm kind of confused what to do - either obsolete this report and add it's info into those two issue reports or unite and include them into this one...
Comment 9 Cor Nouws 2014-06-22 09:40:02 UTC
Hi Alex,

(In reply to comment #8)
> Seems like one part (about printing and PDF) is reported in issue 78557 and
> other one (about viewing) - in issue 78554.

Thanks for confirming!

> Anyway I figured out that it seems to be connected only to one lib
> (svgiolo.dll in win version).

OK. Hint for who ?

> So now I'm kind of confused what to do - either obsolete this report and add
> it's info into those two issue reports or unite and include them into this
> one...

Good question. Good practice is that we have one report for one issue. So I would suggest to add your comments - when needed! - to the other issues and close this one as duplicate of the one of your choice. OK?
Cheers, Cor
Comment 10 Alex 2014-06-22 13:29:52 UTC
You can find this bug also in windows version

Since Libre Office 4.2.4 writer shows and prints inserted svg images wrong. All text disappears. Version 4.2.3.3 works fine though.

By making some experiments it seems that the problem (of win version at least) is connected to 
..\program\svgiolo.dll
If you replace it with the one from LiO 4.2.3.3 everything starts to work fine.

*** This bug has been marked as a duplicate of bug 78554 ***