Bug 80346 - Preferred default fonts for Asian and CTL documents should be Libre fonts
Summary: Preferred default fonts for Asian and CTL documents should be Libre fonts
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.0.1 rc
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-CTL Infobar CJK Fonts-Bundled Fonts-Locale
  Show dependency treegraph
 
Reported: 2014-06-22 06:40 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-02-13 08:26 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-06-22 06:40:31 UTC
LibreOffice ships free fonts with it and by default uses them for the creation of new western documents rather than proprietary ones since 4.2, but unfortunately this doesnt happen for asian and ctl documents.

Liberation Serif and Liberation Sans are the default fonts used in Tools > Options > LibreOffice Writer > Basic Fonts (Western) even if Times New Roman and Arial are present. But with Basic Fonts (Asian), it defaults to proprietary Simsun and Microsoft YaHei if available rather than Droid Sans and with Basic Fonts (CTL), it defaults to proprietary Tahoma if available rather than DejaVu Sans.

In order to access the Basic Fonts (Asian) and Basic Fonts (CTL) options, you will have to enable the ability to create such documents in Tools > Options > Language Settings > Languages under 'Default languages for documents'.
Comment 1 Kevin Suo 2014-06-23 16:25:15 UTC
Jay I totally disagree with you on this issue.

Libreoffice default fonts for westen is libration sans, this does not cause problem when you send (ODF) files to others, because if they  install libreoffice they also have libration sans/serif installed.

But, LibreO does not ship with CJK fonts by default. So in order to retain the best appearance when others open your file, it's important to set the default font to the fonts most users have. Most users have SimSun and Micosoft Yahei, as most PCs in the world are Windows. For linux users, I am sure that if they are for productivity usage they must have simsun and ms yahei installed; even if they dont, most of them know how to embed fonts in their ODF document (while most windows users do not know this feature.)

Simsun and MS Yahei are the most common fonts used, at least for Chinese users.  Even if it's better to use free CJK fonts by default, there is no good fonts to choose. (ttf-wqy? it's buggy, not good look for printing. Droidfallback? based on my testing, in libreO some chars are shown as boxes in libreO with droidfallback fonts, and it's for screen reading, not good for printing.)
Comment 2 Yousuf Philips (jay) (retired) 2014-06-23 23:52:43 UTC
For most users, whether it be on windows or linux, they use the fonts that come with their system and microsoft proprietary fonts like simsun and yahei are not available to linux users unless they purchase them or copy them from their windows installation. While with free fonts, if a user doesnt have it, they can easily download it for free.

Ultimately, if free CJK fonts do a good enough job for displaying and printing, they should be the default if present on the system and if a user wishes to use other fonts instead, they can do so. Only by having more people use the free fonts, will the problems with these fonts be noticed and hopefully corrected.

With more chinese using linux distributions like Ubuntu Kylin and Linux Deepin, i believe the WenQuanYi fonts < http://en.wikipedia.org/wiki/WenQuanYi > will only get better with time. I hope that you will also encourage the visitors to your chinese LibO forum to visit < http://wenq.org/wqy2/index.cgi > and help improve the fonts. I would love your feedback on how well chinese linux distros handle this lack of complete CJK fonts.

jmadero suggested that i set this to ux-advise to hear what they have to say about the issue.
Comment 3 Adolfo Jayme 2014-06-26 04:07:02 UTC
Jay, I believe Kevin’s opinion should have more weight as he is a Chinese reader. He knows about fonts for his language, and he can tell the strenghts and weaknesses of each one of them.

I don’t think any of us (in UX-Advise) is in a position to evaluate whether a move to other fonts for CJK is good or not – that should be evaluated by native readers of the script, not by a bunch of UX enthusiasts who don’t even know Chinese.

Also, I don’t think that libre fonts are necessarily better for the purposes of interoperability that LibreOffice is trying to pursue. This is even more of a complicated issue for non-Latin scripts.

And when we changed default fonts to Liberation, the request was escalated to the ESC, IIRC. And we actually shipped those fonts. Defaulting to fonts that we don’t ship makes no sense, as it made no sense when OOo defaulted to AGFA fonts.
Comment 4 Yousuf Philips (jay) (retired) 2014-06-26 05:42:50 UTC
Thanks for your input Adolfo about CJK fonts and i hope this issue is brought up in the future when CJK fonts are better. As this bug was about both Asian and CTL fonts, can you way in on CTL, as i'm a CTL user.
Comment 5 Adolfo Jayme 2014-06-26 09:30:01 UTC
Oh yeah, thanks for reminding me. Well, it would depend on the exact script you’re talking about; again, the input of native readers of the language in question is extremely valuable for a decision to be made.

But one must also take into account:
 1) Will the new fonts render well* under Windows (where LO is most used)?
 2) Will the users be happy about a potentially problematic change (e.g., doc.
    reflow because of different font metrics) every time they create a new
    document? Will they expect the change?
 3) Do the new fonts fix any bug (e.g., misdrawn glyphs or broken metrics)?
and so on...

When requesting a font change, a better rationale than “it’s a libre font” is needed. But that’s just my opinion anyway, the ESC should be better prepared to decide on changes like this than me.

--
* For example, the Liberation fonts were professionally produced and hinted by Monotype (supplies fonts for Microsoft). Although FLOSS has pretty much catched up and there’s a tool called ttfautohint that makes fonts look awesome under Windows.
Comment 6 Yousuf Philips (jay) (retired) 2014-06-27 01:14:29 UTC
Well i use arabic in CTL and my best friend is a native speaker and we both are trying to complete the arabic UI translation before 4.3. :)

Did some investigating about arabic fonts and here are the results.
1) LibreOffice defaults to Tahoma for arabic
2) DejaVu Sans has arabic and closely resembles Tahoma in metrics.
3) DejaVu Sans already comes with LibreOffice
4) Wikipedia uses DejaVu Sans to render arabic pages - http://ar.wikipedia.org/wiki/ليبر_أوفيس
5) Word 2013 defaults to Arial for arabic text

IMHO, part of document liberation is preserving the look of a document and that look cant be preserved if a user doesnt have access to a proprietary font that is used in the creation of the document. I'm assuming that must have been the same reason for shifting from Times New Roman and Arial to Liberation fonts.

I'm going to do additional investigation on what arabic fonts are more used online and which fonts are more visually please both on screen and in print.
Comment 7 Yousuf Philips (jay) (retired) 2014-08-02 02:00:03 UTC
Kevin has mentioned that now that adode/google have released the Source Han Sans / Noto Sans cjk fonts under the Apache License 2 on July 15, these could be used as default fonts, if they are bundled with libreoffice and the pdf export didnt crash when using the fonts [bug 81516].
Comment 8 Kevin Suo 2014-08-02 03:13:07 UTC
(In reply to comment #7)
> Kevin has mentioned that now that adode/google have released the Source Han
> Sans / Noto Sans cjk fonts under the Apache License 2 on July 15, these
> could be used as default fonts, if they are bundled with libreoffice and the
> pdf export didnt crash when using the fonts [bug 81516].

Yes, I was going to file an enhancement request on this.
Comment 9 Owen Genat (retired) 2014-08-02 05:02:25 UTC
(In reply to comment #7)
> Kevin has mentioned that now that adode/google have released the Source Han
> Sans / Noto Sans cjk fonts under the Apache License 2 on July 15, these
> could be used as default fonts, if they are bundled with libreoffice 

This would increase each download by 81.5 MB (Noto Sans CJK) and ~95-100 MB (Source Han Sans) i.e., by nearly 100%. A far better option would be to provide a link to a separate download on LO download pages for CJK locale (in a similar manner to the existing help / language packs). This would also make each font download smaller (~25-50 MB) as users will only be offered C or J or K.
Comment 10 Kevin Suo 2014-08-02 05:54:25 UTC
(In reply to comment #9)
> This would increase each download by 81.5 MB (Noto Sans CJK) and ~95-100 MB
> (Source Han Sans) i.e., by nearly 100%. A far better option would be to
> provide a link to a separate download on LO download pages for CJK locale
> (in a similar manner to the existing help / language packs). This would also
> make each font download smaller (~25-50 MB) as users will only be offered C
> or J or K.

Good point...I will add a Source Han Sans CJK font download link on our Simplified Chinese LibreOffice download website.
Comment 11 Yousuf Philips (jay) (retired) 2014-08-06 10:48:01 UTC
(In reply to comment #9)
> This would increase each download by 81.5 MB (Noto Sans CJK) and ~95-100 MB
> (Source Han Sans) i.e., by nearly 100%.

Well they both are the same font with different names, so only one would have had to be included. :) And due to the size, i would have only suggested that the installer include the individual CJK locale version needed.

> A far better option would be to
> provide a link to a separate download on LO download pages for CJK locale
> (in a similar manner to the existing help / language packs). This would also
> make each font download smaller (~25-50 MB) as users will only be offered C
> or J or K.

I think that would be great for users who come libreoffice's website to download it. I think an even better idea would be that an infobar appears the first time a CJK user opens libreoffice after an upgrade/install if they dont have the fonts and suggests a means for them to download it, as many users dont come to the libreoffice website, including users who have it downloaded within libreoffice.
Comment 12 Owen Genat (retired) 2014-08-10 05:18:42 UTC
(In reply to comment #11)
> Well they both are the same font with different names, so only one would
> have had to be included. :) 

I would advocate for Noto Sans over Source Han Sans because of the smaller and more locale-friendly packaging of the OTF files. The Source Han Sans OTF files are larger, presumably due to locale combining. This (like my prior comment) is merely a pragmatic concern.

> I think that would be great for users who come libreoffice's website to
> download it. I think an even better idea would be that an infobar appears
> the first time a CJK user opens libreoffice after an upgrade/install if they
> dont have the fonts and suggests a means for them to download it

Agreed. I think at this point in the discussion (given Noto Sans / Source Hans Sans) that this report can be confirmed. Whether and how a solution is implemented remains for developers / l10n experts to determine. Some interesting and worthwhile options have been presented in the discussion IMO. Status set to NEW. For clarity, bug 80538 contains details about the infobar, although this may not need to be added to the See Also list.
Comment 13 Matthew Francis 2015-04-08 06:38:50 UTC Comment hidden (obsolete)
Comment 14 Robinson Tryon (qubit) 2016-08-25 05:39:16 UTC Comment hidden (obsolete)
Comment 15 V字龍(Vdragon) 2018-02-08 16:14:43 UTC
Maybe implement a CJK fontpack and recommend CJK users to install it then?  This will greatly improve interoperability as just yesterday my Source Han Sans presentation looked VERY UGLY on my mom's Windows PC without the fonts installed.
Comment 16 Yousuf Philips (jay) (retired) 2018-02-13 08:26:05 UTC
We are defaulting to open source fonts in hebrew (bug 113538) and chinese (bug 114768) and will soon be defaulting also in arabic (bug 113532) and japanese (bug 114751), so there isnt a need to keep this open.

(In reply to V字龍(Vdragon) from comment #15)
> Maybe implement a CJK fontpack and recommend CJK users to install it then? 

This has been suggested in bug 113496.