Bug 80373 - EDITING: Transparency tab of picture dialog only affects background and not image
Summary: EDITING: Transparency tab of picture dialog only affects background and not i...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.1 rc
Hardware: All All
: medium minor
Assignee: Joel Madero
URL:
Whiteboard: target:4.4.0
Keywords:
Depends on:
Blocks: Image-Dialog
  Show dependency treegraph
 
Reported: 2014-06-23 02:03 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-10-31 06:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
how the image looked at the end of step 10 (462.97 KB, image/png)
2014-06-23 02:03 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-06-23 02:03:40 UTC
Created attachment 101548 [details]
how the image looked at the end of step 10

Confirming this bug as the second bug mentioned in bug 80294.

Steps to reproduce:
1) open blank writer document
2) add an image
3) in the picture toolbar, set the image transparency to 50%
4) open the picture dialog (right-click > picture) and go to transparency tab
5) transparency still set to 'no transparency'

- this confirms transparency tab isnt referring to the image transparency -

6) close dialog and set image transparency to 1% in picture toolbar
7) open the picture dialog and in the transparency tab set transparency to 50%
8) goto area tab and set fill color to black
9) goto crop tab and press the down arrow button once on both the top and bottom fields
10) press okay and grey padding should appear above and below the picture, as in attachment

- this confirms transparency tab is referring to the background transparency -

I'm assuming someone pulled the transparency tab from Area dialog of drawing objects and didnt do the necessary to make it work with image transparency.
Comment 1 Yousuf Philips (jay) (retired) 2014-06-23 02:17:47 UTC
If the intent of the transparency tab is to be of managing the background transparency, then the tab name should be altered to 'Area Transparency'. In addition to this, under the picture tab, a field for image transparency should be added, as it would be useful to control the image transparency from the dialog.
Comment 2 Cor Nouws 2014-06-23 05:24:30 UTC
(In reply to comment #1)
> If the intent of the transparency tab is to be of managing the background
> transparency, then the tab name should be altered to 'Area Transparency'

Yes, that would be OK. Same in Draw.
Basically the whole dialog is for handling the pictures frame.

> In addition to this, under the picture tab, a field for image transparency
> should be added, as it would be useful to control the image transparency
> from the dialog.

In addition to the opaque setting in the picture toolbar.. Then the same for color settings?
Comment 3 Cor Nouws 2014-06-23 05:25:03 UTC
Hi Jay,

what makes this high & critical :) ?
Comment 4 Yousuf Philips (jay) (retired) 2014-06-23 14:59:58 UTC
(In reply to comment #2)
> Yes, that would be OK. Same in Draw.
> Basically the whole dialog is for handling the pictures frame.

Yes its possible to look at most of the features in the picture dialog as being of handling the picture's frame, though i dont think of it in that manner, but the picture tab has settings that manipulate the image and not the frame.

> In addition to the opaque setting in the picture toolbar.. Then the same for
> color settings?

Yes all features found in the picture toolbar should be accessible in the picture dialog IMHO.

(In reply to comment #3)
> Hi Jay,
> 
> what makes this high & critical :) ?

I had set the version to 4.3.0, as the transparency tab is newly introduced in this version and isnt found in previous versions. I set it as high & critical as i felt it was a problem with the implementation of the newly introduced feature in this new version.
Comment 5 Joel Madero 2014-06-23 17:45:00 UTC
This is supposed to be version 4.3.0.1 rc as the Transparency tab I believe is NEW - I checked with 4.1.x.x and could not find it. After talking to Jay this is confirmed to be a new feature.

That being said proper priority:

Minor - can slow down but won't prevent high quality work
Medium - because it's a new feature probably should be implemented just a little less confusing. Upping from "low" to "medium"

Also probably relatively easy to tackle: suggested solution:

1 tab - Transparency

2 Sections - "Image Transparency" "Image Background Transparency"
Comment 6 Joel Madero 2014-06-23 19:04:24 UTC
Should be fixed in 4.4 after commit is accepted
Comment 7 Cor Nouws 2014-06-23 19:37:49 UTC
(In reply to comment #4)

> I had set the version to 4.3.0, as the transparency tab is newly introduced
> in this version and isnt found in previous versions. [...]

Ah really, then I have to make apologies. Obviously was confused with other dialogs.

Best,
Cor
Comment 8 Yousuf Philips (jay) (retired) 2014-06-24 04:56:13 UTC
(In reply to comment #6)
> Should be fixed in 4.4 after commit is accepted

Cant wait to see it in 4.3. :)

(In reply to comment #7)
> Ah really, then I have to make apologies. Obviously was confused with other
> dialogs.

Yes triaging all day will do that to you. :)
Comment 9 Commit Notification 2014-06-24 09:11:20 UTC
Joel committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3f8046a2e52312458c400b34fca36013c53c8f2c

fdo#80373 Updated label to read "Image background transparency"



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Yousuf Philips (jay) (retired) 2014-06-25 02:47:06 UTC
the image transparency in the transparency tab bug is bug 80421.
Comment 11 Yousuf Philips (jay) (retired) 2014-06-25 02:56:37 UTC
(In reply to comment #9)
> 
> fdo#80373 Updated label to read "Image background transparency"
> 

'Background transparency' is a better one to go with as the dialog is already labelled 'Picture' :)
Comment 12 Regina Henschel 2014-06-25 19:04:57 UTC
Isn't that dialog used for frames, Math-objects and other OLE-objects too? If yes, then the wording "Image background" is not correct. I suggest "Area Transparency Mode" because this settings apply to whatever has been chosen in the tab "Area".
Comment 13 Adolfo Jayme 2014-06-29 09:57:03 UTC
Yeah, and please change it to Title Case again (cf. bug 76203).
Comment 14 Yousuf Philips (jay) (retired) 2014-06-30 00:30:13 UTC
@Adolfo: just wanted to bring this to your attention, most of labels in the Tools > Options dialog is in non-title case.
Comment 15 Commit Notification 2014-07-16 11:03:16 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a76bb8fd4248495c3ad0a625be71198111a3dc93

fdo#80373: change wording to 'Area Transparency Mode'



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 16 Adolfo Jayme 2014-08-16 19:11:18 UTC
The offending label has been tweaked. And no, this won’t be backported to 4.3.