Download it now!
Bug 80408 - FILESAVE: Embedded binary DOC object inside DOCX converted to picture when round tripped in LO
Summary: FILESAVE: Embedded binary DOC object inside DOCX converted to picture when ro...
Status: RESOLVED DUPLICATE of bug 80410
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-23 14:50 UTC by Mark Kaplan
Modified: 2014-06-25 02:13 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
A DOCX file which has an embedded DOC object (binary Word 97-2003 document) (19.51 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-06-23 14:50 UTC, Mark Kaplan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Kaplan 2014-06-23 14:50:07 UTC
Created attachment 101595 [details]
A DOCX file which has an embedded DOC object (binary Word 97-2003 document)

Problem description:
When loading a DOCX into Writer that has an embedded DOC object, and saving it to a NEW.DOCX - the embedded DOCX is being converted to a picture (when opening the NEW.DOCX in Word 2010 and selecting the embedded object, the 'Picture Tools' contextual menu appears).

Steps to reproduce:
1. Open attached DOCX in LO 
2. Save as NEW.DOCX
3. Open NEW.DOCX in Word - the embedded DOC had been converted to a picture

Current behavior:
Embedded DOC object is converted to a picture when round tripped in LO

Expected behavior:
Embedded DOC object should be preserved when round tripped in LO

              
Operating System: All
Version: 4.4.0.0.alpha0+ Master
Comment 1 Mark Kaplan 2014-06-23 15:28:04 UTC
Sorry for the typo in the Problem Description, here is the correction:
When loading a DOCX into Writer that has an embedded DOC object, and saving it to a NEW.DOCX - the embedded DOC is being converted to a picture
Comment 2 Yousuf Philips (jay) (retired) 2014-06-25 02:13:54 UTC
Closing this as the issue is with the saving of the OLE in DOCX format and not which format is being embedded in the OLE.

*** This bug has been marked as a duplicate of bug 80410 ***